summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Kinard <kumba@gentoo.org>2016-01-01 23:08:23 -0500
committerJoshua Kinard <kumba@gentoo.org>2016-01-01 23:08:23 -0500
commit6f1c67b6da6e2ba6a87510383f2ac00253832bda (patch)
tree48648657cc61ade742a5909ceaa2d0ed474a6f96 /sys-block/parted/parted-3.2-r1.ebuild
parentsys-process/fcron: version bump to 3.2.0 (diff)
downloadgentoo-6f1c67b6da6e2ba6a87510383f2ac00253832bda.tar.gz
gentoo-6f1c67b6da6e2ba6a87510383f2ac00253832bda.tar.bz2
gentoo-6f1c67b6da6e2ba6a87510383f2ac00253832bda.zip
For uClibc userlands, add dep to dev-libs/libiconv and append -liconv to LIBS. Fixes/recloses #542296.
Package-Manager: portage-2.2.26
Diffstat (limited to 'sys-block/parted/parted-3.2-r1.ebuild')
-rw-r--r--sys-block/parted/parted-3.2-r1.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/sys-block/parted/parted-3.2-r1.ebuild b/sys-block/parted/parted-3.2-r1.ebuild
index e48c62046256..c9c699918ceb 100644
--- a/sys-block/parted/parted-3.2-r1.ebuild
+++ b/sys-block/parted/parted-3.2-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
-inherit autotools eutils
+inherit autotools eutils flag-o-matic
DESCRIPTION="Create, destroy, resize, check, copy partitions and file systems"
HOMEPAGE="https://www.gnu.org/software/parted"
@@ -23,6 +23,7 @@ RDEPEND="
device-mapper? ( >=sys-fs/lvm2-2.02.45 )
readline? ( >=sys-libs/readline-5.2:0= )
selinux? ( sys-libs/libselinux )
+ elibc_uclibc? ( dev-libs/libiconv )
"
DEPEND="
${RDEPEND}
@@ -40,6 +41,7 @@ src_prepare() {
}
src_configure() {
+ use elibc_uclibc && append-libs -liconv
econf \
$(use_enable debug) \
$(use_enable device-mapper) \