summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-block/raid-check/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-block/raid-check/files')
-rw-r--r--sys-block/raid-check/files/raid-check-20140719-makefile.patch48
-rw-r--r--sys-block/raid-check/files/raid-check-20140719-path.patch9
2 files changed, 57 insertions, 0 deletions
diff --git a/sys-block/raid-check/files/raid-check-20140719-makefile.patch b/sys-block/raid-check/files/raid-check-20140719-makefile.patch
new file mode 100644
index 000000000000..95c27ef8cc69
--- /dev/null
+++ b/sys-block/raid-check/files/raid-check-20140719-makefile.patch
@@ -0,0 +1,48 @@
+diff --git a/Makefile b/Makefile
+index 0c9ec8a..6bc0bb5 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,9 +1,6 @@
+ ### The project name
+ PROJECT=raid-check
+
+-### Dependencies
+-DEP_BINS=grep cat sleep awk ps renice ionice logger
+-
+ ### Destination Paths
+ D_BIN=/usr/local/sbin
+ D_CNF=/etc
+@@ -15,16 +12,11 @@ F_CONF=raid-check.conf raid-check.cron
+
+ all: install
+
+-install: test bin config
++bin install: $(PROJECT).sh config
+ # install the actual script
+- install -D --owner root --group root -m 0755 $(PROJECT).sh $(DESTDIR)$(D_BIN)/$(PROJECT)
++ install -D $(PROJECT).sh $(DESTDIR)$(D_BIN)/$(PROJECT)
+
+ test:
+- @echo "==> Checking for required external dependencies"
+- for bindep in $(DEP_BINS) ; do \
+- which $$bindep > /dev/null || { echo "$$bindep not found"; exit 1;} ; \
+- done
+-
+ @echo "==> Checking for valid script syntax"
+ bash -n raid-check.sh
+
+@@ -32,12 +24,8 @@ bin: $(PROJECT).sh test
+
+ config: $(F_CONF)
+ # Install (without overwriting) configuration files
+- if [ ! -e $(DESTDIR)$(D_CNF)/raid-check.conf ] ; then \
+- install -D -m 0644 raid-check.conf $(DESTDIR)$(D_CNF)/raid-check.conf ; \
+- fi
+- if [ ! -e $(DESTDIR)$(D_CNF)/cron.d/raid-check ] ; then \
+- install -D -m 0644 raid-check.cron $(DESTDIR)$(D_CNF)/cron.d/raid-check ; \
+- fi
++ install -D raid-check.conf $(DESTDIR)$(D_CNF)/raid-check.conf
++ install -D -m 0644 raid-check.cron $(DESTDIR)$(D_CNF)/cron.d/raid-check
+
+ uninstall:
+ rm -f $(DESTDIR)$(D_BIN)/$(PROJECT)
diff --git a/sys-block/raid-check/files/raid-check-20140719-path.patch b/sys-block/raid-check/files/raid-check-20140719-path.patch
new file mode 100644
index 000000000000..4c8680f4c01c
--- /dev/null
+++ b/sys-block/raid-check/files/raid-check-20140719-path.patch
@@ -0,0 +1,9 @@
+diff --git a/raid-check.cron b/raid-check.cron
+index 92aa48b..d7f23fd 100644
+--- a/raid-check.cron
++++ b/raid-check.cron
+@@ -1,3 +1,2 @@
+ # Run system wide raid-check once a week on Sunday at 1am by default
+-0 1 * * Sun root /usr/local/sbin/raid-check
+-
++0 1 * * Sun root /usr/sbin/raid-check