summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-block/rts_pstor
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-block/rts_pstor')
-rw-r--r--sys-block/rts_pstor/Manifest1
-rw-r--r--sys-block/rts_pstor/files/rts_pstor-linux-3.10.patch53
-rw-r--r--sys-block/rts_pstor/files/rts_pstor-linux-3.8.patch29
-rw-r--r--sys-block/rts_pstor/metadata.xml12
-rw-r--r--sys-block/rts_pstor/rts_pstor-1.10-r4.ebuild38
5 files changed, 133 insertions, 0 deletions
diff --git a/sys-block/rts_pstor/Manifest b/sys-block/rts_pstor/Manifest
new file mode 100644
index 000000000000..dff8ce89ee00
--- /dev/null
+++ b/sys-block/rts_pstor/Manifest
@@ -0,0 +1 @@
+DIST rts_pstor-1.10.tar.bz2 79549 SHA256 21d819a9b89f029a86fdc807f212ca38ed903e071bed204b2ddb84b2a017a31f SHA512 26d29ccda55672adab8b96a8318e240d0c9d50ebf614853284cf218058c5788cc83b818ce118ac313c0ce6a67aef8ad13d93ed26212db7e05db51b8a7860b48d WHIRLPOOL 15d4cb19ababfffd41b95160531ca048cf2d1affc9ac8f846c7ea7e3c92289a47751e028908333e973c2a92e3ff18b606c92c8223ae8a48fdf5ef911e5c1d43c
diff --git a/sys-block/rts_pstor/files/rts_pstor-linux-3.10.patch b/sys-block/rts_pstor/files/rts_pstor-linux-3.10.patch
new file mode 100644
index 000000000000..0070549b88d8
--- /dev/null
+++ b/sys-block/rts_pstor/files/rts_pstor-linux-3.10.patch
@@ -0,0 +1,53 @@
+--- rts_pstor.a/rtsx.c 2013-07-03 05:39:26.316723407 +0530
++++ rts_pstor.b/rtsx.c 2013-07-03 05:28:28.584882761 +0530
+@@ -135,38 +135,18 @@
+
+
+ #undef SPRINTF
+-#define SPRINTF(args...) \
+- do { if (pos < buffer+length) pos += sprintf(pos, ## args); } while (0)
++#define SPRINTF(args...) seq_printf(m, ##args)
+
+-static int proc_info (struct Scsi_Host *host, char *buffer,
+- char **start, off_t offset, int length, int inout)
++static int show_info(struct seq_file *m, struct Scsi_Host *host)
+ {
+- char *pos = buffer;
+-
+-
+- if (inout)
+- return length;
+-
+
+ SPRINTF(" Host scsi%d: %s\n", host->host_no, CR_DRIVER_NAME);
+-
+
+ SPRINTF(" Vendor: Realtek Corp.\n");
+ SPRINTF(" Product: PCIE Card Reader\n");
+ SPRINTF(" Version: %s\n", DRIVER_VERSION);
+ SPRINTF(" Build: %s\n", DRIVER_MAKE_TIME);
+-
+- /*
+- * Calculate start of next buffer, and return value.
+- */
+- *start = buffer + offset;
+-
+- if ((pos - buffer) < offset)
+- return (0);
+- else if ((pos - buffer - offset) < length)
+- return (pos - buffer - offset);
+- else
+- return (length);
++ return 0;
+ }
+
+
+@@ -272,7 +252,7 @@
+
+ .name = CR_DRIVER_NAME,
+ .proc_name = CR_DRIVER_NAME,
+- .proc_info = proc_info,
++ .show_info = show_info,
+ .info = host_info,
+
+
diff --git a/sys-block/rts_pstor/files/rts_pstor-linux-3.8.patch b/sys-block/rts_pstor/files/rts_pstor-linux-3.8.patch
new file mode 100644
index 000000000000..797b1088f31b
--- /dev/null
+++ b/sys-block/rts_pstor/files/rts_pstor-linux-3.8.patch
@@ -0,0 +1,29 @@
+--- rts_pstor.a/rtsx.c 2011-01-11 14:41:07.000000000 +0530
++++ rts_pstor.b/rtsx.c 2013-05-29 00:39:11.319267655 +0530
+@@ -913,7 +913,7 @@
+ chip->s3_pwr_off_delay = 1000;
+ }
+
+-static int __devinit rtsx_probe(struct pci_dev *pci, const struct pci_device_id *pci_id)
++static int rtsx_probe(struct pci_dev *pci, const struct pci_device_id *pci_id)
+ {
+ struct Scsi_Host *host;
+ struct rtsx_dev *dev;
+@@ -1077,7 +1077,7 @@
+ }
+
+
+-static void __devexit rtsx_remove(struct pci_dev *pci)
++static void rtsx_remove(struct pci_dev *pci)
+ {
+ struct rtsx_dev *dev = (struct rtsx_dev *)pci_get_drvdata(pci);
+
+@@ -1104,7 +1104,7 @@
+ .name = CR_DRIVER_NAME,
+ .id_table = rtsx_ids,
+ .probe = rtsx_probe,
+- .remove = __devexit_p(rtsx_remove),
++ .remove = rtsx_remove,
+ #ifdef CONFIG_PM
+ .suspend = rtsx_suspend,
+ .resume = rtsx_resume,
diff --git a/sys-block/rts_pstor/metadata.xml b/sys-block/rts_pstor/metadata.xml
new file mode 100644
index 000000000000..f7ecccc7cec2
--- /dev/null
+++ b/sys-block/rts_pstor/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>vikraman@gentoo.org</email>
+ <name>Vikraman Choudhury</name>
+ </maintainer>
+ <longdescription lang="en">
+ PCIE RTS5209 card reader driver for Linux.
+ </longdescription>
+</pkgmetadata>
+
diff --git a/sys-block/rts_pstor/rts_pstor-1.10-r4.ebuild b/sys-block/rts_pstor/rts_pstor-1.10-r4.ebuild
new file mode 100644
index 000000000000..5b47781512cc
--- /dev/null
+++ b/sys-block/rts_pstor/rts_pstor-1.10-r4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit linux-mod
+
+DESCRIPTION="PCIE RTS5209 card reader driver for Linux"
+HOMEPAGE="http://www.realtek.com.tw/Downloads/downloadsView.aspx?PNid=15&PFid=25&Level=4&Conn=3&DownTypeID=3"
+SRC_URI="http://dev.gentoo.org/~vikraman/distfiles/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+MODULE_NAMES="rts_pstor(misc/drivers/scsi)"
+BUILD_TARGETS="default"
+
+src_prepare() {
+ sed -e 's/\/lib\/modules\/\$(shell uname -r)\/build\//\$(KERNELDIR)/g' \
+ -i Makefile || die "Sed failed!"
+ ([ ${KV_MAJOR} -gt 3 ] || ([ ${KV_MAJOR} -eq 3 ] && [ ${KV_MINOR} -ge 8 ])) \
+ && epatch "${FILESDIR}/${PN}-linux-3.8.patch"
+ ([ ${KV_MAJOR} -gt 3 ] || ([ ${KV_MAJOR} -eq 3 ] && [ ${KV_MINOR} -ge 10 ])) \
+ && epatch "${FILESDIR}/${PN}-linux-3.10.patch"
+}
+
+pkg_setup() {
+ linux-mod_pkg_setup
+ BUILD_PARAMS="KERNELDIR=${KERNEL_DIR}"
+}