summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2019-04-22 13:31:50 +0200
committerDavid Seifert <soap@gentoo.org>2019-04-23 10:51:08 +0200
commit8b48d1017d08f93b99b60c8872edd618435af7ba (patch)
treea8cf13df043736c34a6549e471d44366ecb70859 /sys-block/scsiadd
parentmedia-video/blinkenthemes: drop old (EAPI0) (diff)
downloadgentoo-8b48d1017d08f93b99b60c8872edd618435af7ba.tar.gz
gentoo-8b48d1017d08f93b99b60c8872edd618435af7ba.tar.bz2
gentoo-8b48d1017d08f93b99b60c8872edd618435af7ba.zip
sys-block/scsiadd: drop old (EAPI2)
Signed-off-by: Michael Mair-Keimberger <m.mairkeimberger@gmail.com> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sys-block/scsiadd')
-rw-r--r--sys-block/scsiadd/scsiadd-1.97.ebuild59
1 files changed, 0 insertions, 59 deletions
diff --git a/sys-block/scsiadd/scsiadd-1.97.ebuild b/sys-block/scsiadd/scsiadd-1.97.ebuild
deleted file mode 100644
index 0ba638443227..000000000000
--- a/sys-block/scsiadd/scsiadd-1.97.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="2"
-
-inherit user toolchain-funcs flag-o-matic
-
-DESCRIPTION="Add and remove SCSI devices from your Linux system during runtime"
-HOMEPAGE="https://llg.cubic.org/tools/"
-SRC_URI="https://llg.cubic.org/tools/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="suid"
-DEPEND=""
-
-pkg_setup() {
- use suid && enewgroup scsi
-}
-
-src_prepare() {
- # remove 'strip' command
- sed -i -e "s:^\(.*strip.*\):#\1:g" Makefile.in
-
- # convert docs to utf-8
- if [ -x "$(type -p iconv)" ]; then
- for X in NEWS README; do
- iconv -f LATIN1 -t UTF8 -o "${X}~" "${X}" && mv -f "${X}~" "${X}" || rm -f "${X}~"
- done
- fi
-}
-
-src_compile() {
- # extra safety for suid
- append-ldflags -Wl,-z,now
-
- emake CC="$(tc-getCC)" || die "emake failed"
-}
-
-src_install() {
- dosbin scsiadd || die "install failed"
- if use suid; then
- fowners root:scsi /usr/sbin/scsiadd
- fperms 4710 /usr/sbin/scsiadd
- fi
- dodoc NEWS README TODO
- doman scsiadd.8
-}
-
-pkg_postinst() {
- if use suid; then
- ewarn
- ewarn "You have chosen to install ${PN} with the binary setuid root. This"
- ewarn "means that if there any undetected vulnerabilities in the binary,"
- ewarn "then local users may be able to gain root access on your machine."
- ewarn
- fi
-}