summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-04-01 12:49:28 +0200
committerLars Wendler <polynomial-c@gentoo.org>2020-04-01 12:50:05 +0200
commitcf734ae4d6922dcae8c0f0f549cb0e73d99882ca (patch)
treec3b289a579b20ecdf61754389f571f623b531285 /sys-block/smp_utils/smp_utils-0.99.ebuild
parentdev-lang/mercury-extras: version bump (diff)
downloadgentoo-cf734ae4d6922dcae8c0f0f549cb0e73d99882ca.tar.gz
gentoo-cf734ae4d6922dcae8c0f0f549cb0e73d99882ca.tar.bz2
gentoo-cf734ae4d6922dcae8c0f0f549cb0e73d99882ca.zip
sys-block/smp_utils: Bump to version 0.99
Package-Manager: Portage-2.3.96, Repoman-2.3.22 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-block/smp_utils/smp_utils-0.99.ebuild')
-rw-r--r--sys-block/smp_utils/smp_utils-0.99.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sys-block/smp_utils/smp_utils-0.99.ebuild b/sys-block/smp_utils/smp_utils-0.99.ebuild
new file mode 100644
index 000000000000..bee6f5958ece
--- /dev/null
+++ b/sys-block/smp_utils/smp_utils-0.99.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Utilities for SAS management protocol (SMP)"
+HOMEPAGE="http://sg.danny.cz/sg/smp_utils.html"
+MY_PV="${PV/_beta/b}"
+MY_PV="${MY_PV/_p/r}"
+MY_P="${PN}-${MY_PV}"
+SRC_URI="http://sg.danny.cz/sg/p/${MY_P}.tar.xz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="static-libs"
+
+DOCS=( AUTHORS ChangeLog COVERAGE CREDITS README )
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable static-libs static)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ find "${ED}" -type f -name "*.la" -delete || die
+} \ No newline at end of file