summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-block/whdd
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-block/whdd')
-rw-r--r--sys-block/whdd/Manifest2
-rw-r--r--sys-block/whdd/metadata.xml16
-rw-r--r--sys-block/whdd/whdd-2.1.ebuild28
-rw-r--r--sys-block/whdd/whdd-2.2.ebuild28
-rw-r--r--sys-block/whdd/whdd-9999.ebuild22
5 files changed, 96 insertions, 0 deletions
diff --git a/sys-block/whdd/Manifest b/sys-block/whdd/Manifest
new file mode 100644
index 000000000000..3e106be9535a
--- /dev/null
+++ b/sys-block/whdd/Manifest
@@ -0,0 +1,2 @@
+DIST whdd-2.1.tar.gz 32363 SHA256 a5cdb289381a623b4f9aad9e8a736ae206a91b3c214942f2755e83865b2d4c7b SHA512 a43796acf359069e27c622b9816de3d041f87ff77a83167020796c445e65ca0c728c8fd3418814802d84fa8cb594a72c764dd5b11e85771a024ab9c8a43b26a0 WHIRLPOOL 6214f10c223ee661185954b2adfd7df2bf8ac60f19af638b6ccdce170264e03df6910e48eeabccc958a559cb3f929a32735a79d7ca23567bb1e2535c9eaeb205
+DIST whdd-2.2.tar.gz 33317 SHA256 49d615e46117f1271aac22a063703e87fab749e5357a0c5bb4a369e39d7c9241 SHA512 ab30c1e418cb7ba9881b1a91b99d0b1d5389172c4d5802be69d98cb9c16f1282ff7808e2b40bb937987a9d3ad9fa7f20e630d19307eb0aa1090cff531a904d4a WHIRLPOOL c7d9eee7a21e6390a0c1a5befe5bcb17bf326c0b17ae89164452d5e70a94567cb987ecaf17c90ca0631e3ef1f0d958f8d46881f65169179202c84bedb826719b
diff --git a/sys-block/whdd/metadata.xml b/sys-block/whdd/metadata.xml
new file mode 100644
index 000000000000..514413068c26
--- /dev/null
+++ b/sys-block/whdd/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>andrey.krieger.utkin@gmail.com</email>
+ <name>Andrey Utkin</name>
+ </maintainer>
+ <maintainer>
+ <email>maksbotan@gentoo.org</email>
+ <name>Maxim Koltsov</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">krieger-od/whdd</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sys-block/whdd/whdd-2.1.ebuild b/sys-block/whdd/whdd-2.1.ebuild
new file mode 100644
index 000000000000..6998deac85d9
--- /dev/null
+++ b/sys-block/whdd/whdd-2.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit cmake-utils
+
+DESCRIPTION="Diagnostic and recovery tool for block devices"
+HOMEPAGE="http://github.com/krieger-od/whdd"
+SRC_URI="http://github.com/krieger-od/${PN}/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-util/dialog
+ sys-libs/ncurses[unicode]"
+RDEPEND="${DEPEND}
+ sys-apps/smartmontools"
+
+src_unpack() {
+ default
+ mv krieger-od-${PN}-* ${P}
+ echo ${PV} > "${S}"/VERSION || die
+}
diff --git a/sys-block/whdd/whdd-2.2.ebuild b/sys-block/whdd/whdd-2.2.ebuild
new file mode 100644
index 000000000000..1775f6d7702a
--- /dev/null
+++ b/sys-block/whdd/whdd-2.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit cmake-utils
+
+DESCRIPTION="Diagnostic and recovery tool for block devices"
+HOMEPAGE="http://github.com/krieger-od/whdd"
+SRC_URI="http://github.com/krieger-od/${PN}/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-util/dialog
+ sys-libs/ncurses[unicode]"
+RDEPEND="${DEPEND}
+ sys-apps/smartmontools"
+
+src_unpack() {
+ default
+ mv krieger-od-${PN}-* ${P}
+ echo ${PV} > "${S}"/VERSION || die
+}
diff --git a/sys-block/whdd/whdd-9999.ebuild b/sys-block/whdd/whdd-9999.ebuild
new file mode 100644
index 000000000000..21661b408085
--- /dev/null
+++ b/sys-block/whdd/whdd-9999.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+EGIT_REPO_URI="git://github.com/krieger-od/whdd.git"
+
+inherit cmake-utils git-2
+
+DESCRIPTION="Diagnostic and recovery tool for block devices"
+HOMEPAGE="http://github.com/krieger-od/whdd"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+DEPEND="
+ dev-util/dialog
+ sys-libs/ncurses[unicode]"
+RDEPEND="${DEPEND}
+ sys-apps/smartmontools"