summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2018-06-05 12:21:41 +0800
committerJason Zaman <perfinion@gentoo.org>2018-06-05 12:31:59 +0800
commit88639a8b7164915a31a0dcea93518bcf78ee7ee9 (patch)
treebdc048ad25753953e3e74c74e3ede927f426f60a /sys-block/zram-init
parentsys-fs/cachefilesd: drop old (diff)
downloadgentoo-88639a8b7164915a31a0dcea93518bcf78ee7ee9.tar.gz
gentoo-88639a8b7164915a31a0dcea93518bcf78ee7ee9.tar.bz2
gentoo-88639a8b7164915a31a0dcea93518bcf78ee7ee9.zip
sys-block/zram-init: bump 7.1
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'sys-block/zram-init')
-rw-r--r--sys-block/zram-init/Manifest1
-rw-r--r--sys-block/zram-init/zram-init-7.1.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/sys-block/zram-init/Manifest b/sys-block/zram-init/Manifest
index 114812cf6954..9a78d829a8f5 100644
--- a/sys-block/zram-init/Manifest
+++ b/sys-block/zram-init/Manifest
@@ -3,3 +3,4 @@ DIST zram-init-3.0.tar.gz 5578 BLAKE2B 980ae8a2df219d087e6a5ec0895b5b6c52b932079
DIST zram-init-3.4.tar.gz 5825 BLAKE2B aa4ec0f311a79f69b1954f469baf546733864e31dd457b7b406408a0d6a768176d37d2f1bed93f1d87696c41681555c8bb871f5432964da29d3782122f034743 SHA512 985cbe5dd63c900ce88bf8f8989bc04f982b27104dbc40e9c4cf504310aca335efafba842d801e0b9250e8b6925d063bcd2c555122fc7c7295128687ccd4080f
DIST zram-init-3.6.tar.gz 6207 BLAKE2B 13d97889495c19b03ec190168b71072bf6f5e1664e98708ebff0cd746d3b574c519124847dac67b81f05367b95972a08b841fd65cdd2b645ca1c4577278e5c4e SHA512 535104beca6de225aeb482ebb7a01a2498c841784a68d60e8e09f04ab193e6a8ae3ea55797308c89d54f3ce66bdac3f8c535059561ea6ccf848582c594b7f667
DIST zram-init-3.8.tar.gz 6619 BLAKE2B c22482a619e5b0137c2d3eb45babee82ff36778a32caaed959beaf6ed3683e0010ef42328f8c4db7956696ca9c6a80c9e676c9db7d533f7283832036203beb34 SHA512 c083f34bba6031f8e247f61a1451343e14cc4bc5c4731ad3a32a5f0eea265936a83b27ad0e3cbd2ba0e05e2bec1e6ae739b6e4149d120dafbcc057437188f07f
+DIST zram-init-7.1.tar.gz 9054 BLAKE2B 70c1aee839db3c4599fa59a0ecda7bb7a905a18cbbd90872865f266364da0602bd6ada85c35d7da5f8e6f4c6f9da122abf01abd57080a0728d4314fc2ed03c0d SHA512 6a9a6568d1c439f941401cb5638645a034a3cb29aaafa0d7595ad19fe7c50296e72c6751393eaa5cd8877b0d2bd0376339fb0f596c9517f9b17d425cc9c5ed53
diff --git a/sys-block/zram-init/zram-init-7.1.ebuild b/sys-block/zram-init/zram-init-7.1.ebuild
new file mode 100644
index 000000000000..e27e24d952bc
--- /dev/null
+++ b/sys-block/zram-init/zram-init-7.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit readme.gentoo-r1 systemd
+
+DESCRIPTION="Scripts to support compressed swap devices or ramdisks with zram"
+HOMEPAGE="https://github.com/vaeth/zram-init/"
+SRC_URI="https://github.com/vaeth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="!<sys-apps/openrc-0.13"
+
+DISABLE_AUTOFORMATTING="true"
+DOC_CONTENTS="To use zram, activate it in your kernel and add it to default runlevel:
+ rc-config add zram default
+If you use systemd enable zram_swap, tmp, and/or var_tmp with systemctl.
+You might need to modify /etc/modprobe.d/zram.conf"
+
+src_prepare() {
+ use prefix || sed -i \
+ -e '1s"^#!/usr/bin/env sh$"#!'"${EPREFIX}/bin/sh"'"' \
+ -- sbin/* || die
+ eapply_user
+}
+
+src_install() {
+ dosbin sbin/*
+ doinitd openrc/init.d/*
+ doconfd openrc/conf.d/*
+ systemd_dounit systemd/system/*
+ insinto /etc/modprobe.d
+ doins modprobe.d/*
+ insinto /usr/share/zsh/site-functions
+ doins zsh/*
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}