summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-08-21 10:40:57 +0200
committerJustin Lecher <jlec@gentoo.org>2015-08-21 11:35:01 +0200
commit12b1d70ccba67cb73f34512e14415d0a5c173c5a (patch)
tree5e1a6844b030fd5ab1e7a73b80f4b7b0f411418d /sys-block
parentmedia-video/mplayer: Propagate vdpau dep to ffmpeg. (diff)
downloadgentoo-12b1d70ccba67cb73f34512e14415d0a5c173c5a.tar.gz
gentoo-12b1d70ccba67cb73f34512e14415d0a5c173c5a.tar.bz2
gentoo-12b1d70ccba67cb73f34512e14415d0a5c173c5a.zip
sys-block/parted: Set correct subslot dependency for ncurses
Package-Manager: portage-2.2.20.1 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/parted/metadata.xml10
-rw-r--r--sys-block/parted/parted-2.4.ebuild6
-rw-r--r--sys-block/parted/parted-3.2.ebuild11
3 files changed, 14 insertions, 13 deletions
diff --git a/sys-block/parted/metadata.xml b/sys-block/parted/metadata.xml
index 57a676994422..54903f1e1aa0 100644
--- a/sys-block/parted/metadata.xml
+++ b/sys-block/parted/metadata.xml
@@ -1,17 +1,17 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>livecd</herd>
-<use>
- <flag name='device-mapper'>
+ <herd>livecd</herd>
+ <use>
+ <flag name="device-mapper">
Enable device-mapper support from <pkg>sys-fs/lvm2</pkg> in parted
</flag>
- <flag name="debug">
+ <flag name="debug">
Enable debugging as encouraged by upstream: [The default configuration]
includes --enable-debug (by default), which contains many assertions.
Obviously, these "waste" space, but in the past, they have caught
potentially dangerous bugs before they would have done damage, so we think
it's worth it. Also, it means we get more bug reports ;)
</flag>
-</use>
+ </use>
</pkgmetadata>
diff --git a/sys-block/parted/parted-2.4.ebuild b/sys-block/parted/parted-2.4.ebuild
index 2e7ae565ce87..fe0b0e079f27 100644
--- a/sys-block/parted/parted-2.4.ebuild
+++ b/sys-block/parted/parted-2.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -19,9 +19,9 @@ RESTRICT="test"
# to fix bug 85999
RDEPEND="
>=sys-fs/e2fsprogs-1.27
- >=sys-libs/ncurses-5.2
+ >=sys-libs/ncurses-5.2:5=
device-mapper? ( >=sys-fs/lvm2-2.02.45 )
- readline? ( >=sys-libs/readline-5.2 )
+ readline? ( >=sys-libs/readline-5.2:0= )
selinux? ( sys-libs/libselinux )
"
DEPEND="
diff --git a/sys-block/parted/parted-3.2.ebuild b/sys-block/parted/parted-3.2.ebuild
index e89f3eb16737..a3a8786b034b 100644
--- a/sys-block/parted/parted-3.2.ebuild
+++ b/sys-block/parted/parted-3.2.ebuild
@@ -3,6 +3,7 @@
# $Id$
EAPI=5
+
inherit autotools eutils
DESCRIPTION="Create, destroy, resize, check, copy partitions and file systems"
@@ -19,9 +20,9 @@ RESTRICT="test"
# to fix bug 85999
RDEPEND="
>=sys-fs/e2fsprogs-1.27
- >=sys-libs/ncurses-5.7-r7
+ >=sys-libs/ncurses-5.7-r7:5=
device-mapper? ( >=sys-fs/lvm2-2.02.45 )
- readline? ( >=sys-libs/readline-5.2 )
+ readline? ( >=sys-libs/readline-5.2:0= )
selinux? ( sys-libs/libselinux )
"
DEPEND="
@@ -31,9 +32,9 @@ DEPEND="
"
src_prepare() {
- epatch "${FILESDIR}"/${PN}-3.2-devmapper.patch
-
- epatch "${FILESDIR}"/${PN}-3.2-po4a-mandir.patch
+ epatch \
+ "${FILESDIR}"/${PN}-3.2-devmapper.patch \
+ "${FILESDIR}"/${PN}-3.2-po4a-mandir.patch
eautoreconf
}