summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Payno <vpayno@gaikai.com>2019-11-14 14:45:46 -0800
committerRobin H. Johnson <robbat2@gentoo.org>2019-12-17 23:30:22 -0800
commit3c0241d918bac448ecbc2dc2aff316082b8ec6db (patch)
tree2ca0e9f0e1871d11eee76884454c4e2d919c5639 /sys-block
parentnet-libs/nodejs: Versions 8.17.0 10.18.0 12.14.0 13.4.0 (diff)
downloadgentoo-3c0241d918bac448ecbc2dc2aff316082b8ec6db.tar.gz
gentoo-3c0241d918bac448ecbc2dc2aff316082b8ec6db.tar.bz2
gentoo-3c0241d918bac448ecbc2dc2aff316082b8ec6db.zip
sys-block/sas3ircu: version bump to 16
Fixes: https://github.com/gentoo/gentoo/pull/13656 Signed-off-by: Victor Payno <vpayno+gentoo@gmail.com> Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/sas3ircu/Manifest1
-rw-r--r--sys-block/sas3ircu/sas3ircu-16.ebuild90
2 files changed, 91 insertions, 0 deletions
diff --git a/sys-block/sas3ircu/Manifest b/sys-block/sas3ircu/Manifest
index 4e2a047b3b99..1a41d548a7ef 100644
--- a/sys-block/sas3ircu/Manifest
+++ b/sys-block/sas3ircu/Manifest
@@ -1,5 +1,6 @@
DIST SAS3IRCU_P14.zip 6536687 BLAKE2B c8f5fbf9e92aa752baf173f23536e90920dbce94813ad4408a38a616ee4c0ab1fac302ca8ae324b5052813e2e1f025704b80a7f098176aa614f381017779cfd6 SHA512 50125edf382b12aec88c83b6a11e94f766d0ecd94247e0f5e16f6dc3571c34e21ccfedf15563b41bc48983d881a216a2291fad66353370bc076f4f513863a288
DIST SAS3IRCU_P15.zip 6577897 BLAKE2B 8bb7a9deefee875f88f4ac7ac8432e9e5d7ac0122454a009b2946ba82ef48d6ffb1582ecc438a0fcda928780999c221c1475640d0a9b28be5fedbf3c4be8aba8 SHA512 d2020a4148a04109c82025dd99401d9c110201a294a4c03aca32483e8d54d179c2104fd12e427c577652b257ec9dbe9ea54089929bc35b5fd9cf1a166d6902c1
+DIST SAS3IRCU_P16.zip 6342932 BLAKE2B a5c4f9a83eb1f51a049e9f04c29c029580590500deb48ae03b0960c394946f1e89d40efc68a0d505004bda519e3174fc573111e95f028c09b1a0ae6bd18f98ed SHA512 cc44d64c500f2608895129414d95cc3d23fae5a3ae39bb28119f150b830ec20b6c934cd1d23dcd1253e9c38ca3b16a7020ae0b8386412638fd2dca6d93d92ac0
DIST SAS3IRCU_P5.zip 2655605 BLAKE2B 78b7b3555d725166bad03b6619e890c025901fd41be80ac7657945acf9429fa05b91881fe98dd76061c676a373c95079c429196ba73b24407ccfae7f11f48a41 SHA512 233ec5ea8e32123652382a9072831fa35f496ce0755d8fd7113139f43e57837053e00eb7cae5f5273177510444f384fc6f08f7278232fe3d6601771ee214d9dc
DIST SAS3IRCU_UG.pdf 690245 BLAKE2B 781ec32443eaa99dc0c7d30739ecde21deb62e013b6c08d617cd46567d3905913711a36cd26eccf6e260fda9ed1ec4c0aaffee4a434224ca864379519967debb SHA512 9e7a47f32bd19b708b1eedd63d7d7112a17c8da952b74630196dc2891cd14f758394dcc14b8be05666e6133a3bb10e77784bd62749fe4b1e2d7f7c71ae26fe2b
DIST SAS3_IR_UG.pdf 714573 BLAKE2B 09a3a47abf6118343f023f4cdf85ab2f5f583f806e305dafa6397d1099fc01ecc33b331afd10d63ac8bb75a365d09c931c19fc673fa707b5171feb23d64f97bf SHA512 4db16dedcadc3daf853e62531ac620af4a3e41d001b58fcd333692f9121d1ca3ec8b9de0113693506b31da714b9368ff55addb0398f2f843e4a6a1bf3d665433
diff --git a/sys-block/sas3ircu/sas3ircu-16.ebuild b/sys-block/sas3ircu/sas3ircu-16.ebuild
new file mode 100644
index 000000000000..4b6cbd3d3e64
--- /dev/null
+++ b/sys-block/sas3ircu/sas3ircu-16.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit mount-boot
+
+DESCRIPTION="LSI MPT-SAS3 controller management tool"
+HOMEPAGE="https://www.broadcom.com/products/storage/host-bus-adapters/sas-9300-8e#downloads"
+LICENSE="LSI"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86 ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc efi"
+RESTRICT="strip fetch mirror"
+BDEPEND="app-arch/unzip"
+QA_PREBUILT="opt/lsi/sas3ircu boot/efi/sas3ircu.efi"
+
+MY_PN=SAS3IRCU
+MY_P="${MY_PN}_P${PV}"
+
+DISTFILE_BIN=${MY_P}.zip
+DISTFILE_DOC=SAS3_IR_UG.pdf
+
+SRC_URI_BASE='https://docs.broadcom.com/docs-and-downloads/host-bus-adapters'
+SRC_URI="
+ ${SRC_URI_BASE}/host-bus-adapters-common-files/sas_sata_12g_p${PV}/${DISTFILE_BIN}
+ doc? ( "${SRC_URI_BASE}/${DISTFILE_DOC}" )"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_nofetch() {
+ elog "Broadcom has a mandatory click-through license on thier binaries."
+ elog "Please visit ${HOMEPAGE} and download ${DISTFILE_BIN} from the Mangement Software section."
+ elog "After downloading, move ${MY_P} into your DISTDIR directory"
+ if use doc; then
+ elog "Please also download 'SAS-3 Integrated RAID Configuration Utility User Guide' (${DISTFILE_DOC}) "
+ elog "and also place it into your DISTDIR directory"
+ fi
+ einfo "${SRC_URI}"
+}
+
+supportedcards() {
+ elog "This binary supports should support ALL cards, including, but not"
+ elog "limited to the following series:"
+ elog ""
+ elog "LSI SAS 3004"
+ elog "LSI SAS 3008"
+ elog "LSI SAS 3108"
+ elog "LSI SAS 3116"
+ elog "LSI SAS 3208"
+ elog "LSI SAS 3308"
+}
+
+src_install() {
+ # The second number is some sort of internal revision that is inconsistent between releases.
+ local DOCS=( IRCU_MPT_GEN3_Phase"${PV}".0-*.pdf "README_SAS3IRCU_P${PV}.txt" )
+
+ if use doc; then
+ DOCS+=( "${DISTDIR}/${DISTFILE_DOC}" )
+ fi
+
+ default
+
+ exeinto /opt/lsi/
+ if use amd64; then
+ doexe sas3ircu_rel/sas3ircu/sas3ircu_linux_x64_rel/sas3ircu
+ elif use x86; then
+ doexe sas3ircu_rel/sas3ircu/sas3ircu_linux_x86_rel/sas3ircu
+ elif use arm64; then
+ doexe sas3ircu_rel/sas3ircu/sas3ircu_linux_arm_rel/sas3ircu
+ elif use ppc64; then
+ doexe sas3ircu_rel/sas3ircu/sas3ircu_linux_ppc64_rel/sas3ircu
+ elif use amd64-fbsd; then
+ doexe sas3ircu_rel/sas3ircu/sas3ircu_freebsd_amd64_rel/sas3ircu
+ elif use x86-fbsd; then
+ doexe sas3ircu_rel/sas3ircu/sas3ircu_freebsd_i386_rel/sas3ircu
+ elif use x64-solaris || use x86-solaris; then
+ doexe sas3ircu_rel/sas3ircu/sas3ircu_solaris_x86_rel/sas3ircu
+ elif use sparc-solaris; then
+ doexe sas3ircu_rel/sas3ircu/sas3ircu_solaris_sparc_rel/sas3ircu
+ fi
+
+ if use efi; then
+ exeinto /boot/efi/
+ if use amd64; then
+ doexe sas3ircu_rel/sas3ircu/sas3ircu_udk_uefi_x64_rel/sas3ircu.efi
+ elif use arm64; then
+ doexe sas3ircu_rel/sas3ircu/sas3ircu_udk_uefi_arm_rel/sas3ircu.efi
+ fi
+ fi
+}