summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVikraman Choudhury <vikraman@gentoo.org>2015-09-17 01:22:11 -0400
committerVikraman Choudhury <vikraman@gentoo.org>2015-09-17 01:22:11 -0400
commit59018e5a7d863049677b3ea17ad53f02a69e574a (patch)
treece68316e631457f5fb3a9e9258de88f12ea4defd /sys-block
parentdev-ruby/sprockets: version bump (diff)
downloadgentoo-59018e5a7d863049677b3ea17ad53f02a69e574a.tar.gz
gentoo-59018e5a7d863049677b3ea17ad53f02a69e574a.tar.bz2
gentoo-59018e5a7d863049677b3ea17ad53f02a69e574a.zip
sys-block/rts5229: Fix build with kernel 4.2.0
Gentoo-Bug: 559424 Package-Manager: portage-2.2.20.1
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/rts5229/files/rts5229-vmalloc.patch33
-rw-r--r--sys-block/rts5229/rts5229-1.07-r6.ebuild (renamed from sys-block/rts5229/rts5229-1.07-r5.ebuild)1
2 files changed, 34 insertions, 0 deletions
diff --git a/sys-block/rts5229/files/rts5229-vmalloc.patch b/sys-block/rts5229/files/rts5229-vmalloc.patch
new file mode 100644
index 000000000000..51058cfb6f0c
--- /dev/null
+++ b/sys-block/rts5229/files/rts5229-vmalloc.patch
@@ -0,0 +1,33 @@
+diff -Naur rts5229.a/ms.c rts5229.b/ms.c
+--- rts5229.a/ms.c 2012-03-20 21:40:18.000000000 -0400
++++ rts5229.b/ms.c 2015-09-17 01:13:54.830723253 -0400
+@@ -23,6 +23,7 @@
+ #include <linux/blkdev.h>
+ #include <linux/kthread.h>
+ #include <linux/sched.h>
++#include <linux/vmalloc.h>
+
+ #include "rtsx.h"
+ #include "rtsx_transport.h"
+diff -Naur rts5229.a/rtsx_chip.c rts5229.b/rtsx_chip.c
+--- rts5229.a/rtsx_chip.c 2012-03-20 21:40:18.000000000 -0400
++++ rts5229.b/rtsx_chip.c 2015-09-17 01:13:29.574133449 -0400
+@@ -24,6 +24,7 @@
+ #include <linux/kthread.h>
+ #include <linux/sched.h>
+ #include <linux/workqueue.h>
++#include <linux/vmalloc.h>
+
+ #include "rtsx.h"
+ #include "rtsx_transport.h"
+diff -Naur rts5229.a/rtsx_scsi.c rts5229.b/rtsx_scsi.c
+--- rts5229.a/rtsx_scsi.c 2012-03-20 21:40:18.000000000 -0400
++++ rts5229.b/rtsx_scsi.c 2015-09-17 01:13:44.035898653 -0400
+@@ -23,6 +23,7 @@
+ #include <linux/blkdev.h>
+ #include <linux/kthread.h>
+ #include <linux/sched.h>
++#include <linux/vmalloc.h>
+
+ #include "rtsx.h"
+ #include "rtsx_transport.h"
diff --git a/sys-block/rts5229/rts5229-1.07-r5.ebuild b/sys-block/rts5229/rts5229-1.07-r6.ebuild
index e80c8954e334..fff45c794893 100644
--- a/sys-block/rts5229/rts5229-1.07-r5.ebuild
+++ b/sys-block/rts5229/rts5229-1.07-r6.ebuild
@@ -32,6 +32,7 @@ src_prepare() {
&& epatch "${FILESDIR}/${PN}-linux-3.10.patch"
sed -e '/__DATE__/d' \
-i rtsx.c || die "Sed failed!"
+ epatch "${FILESDIR}/${PN}-vmalloc.patch"
}
pkg_setup() {