summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2017-12-20 12:32:09 +0800
committerJason Zaman <perfinion@gentoo.org>2017-12-20 12:42:41 +0800
commit741f0b3d105bea48aea7706273f6c2871c14e344 (patch)
tree0e5757b78e25724217b18aeb35012e45020fa110 /sys-block
parentsci-libs/mathgl: Drop old (diff)
downloadgentoo-741f0b3d105bea48aea7706273f6c2871c14e344.tar.gz
gentoo-741f0b3d105bea48aea7706273f6c2871c14e344.tar.bz2
gentoo-741f0b3d105bea48aea7706273f6c2871c14e344.zip
sys-block/sas2ircu: bump to v20, update links and hashes
Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/sas2ircu/Manifest6
-rw-r--r--sys-block/sas2ircu/sas2ircu-20.ebuild97
2 files changed, 101 insertions, 2 deletions
diff --git a/sys-block/sas2ircu/Manifest b/sys-block/sas2ircu/Manifest
index f221dd21b516..7030b636fc70 100644
--- a/sys-block/sas2ircu/Manifest
+++ b/sys-block/sas2ircu/Manifest
@@ -1,2 +1,4 @@
-DIST SAS2IRCU_P19.zip 2664125 SHA256 e5bb0bc37099016d6f7486f623cb74baeef9903afdd0610a7c8850331ff8b3d5 SHA512 99f5092e1344747912b081f4f9e22a1f22d55e5a951583f5482213a38a1faa7cd890b573fdeb50d4770bb862d970364ccaff982969813edd9581e80bc39e2bdf WHIRLPOOL 9e173c5f4ade04a7fecb994f98c4d7457375c559c7f0e9994d38e3a2b1847577084449ee0ab1a3ece06e5a57c74ae41294b135aeffa396aa56120d5a6a0ea37d
-DIST SAS2IRCU_User_Guide.pdf 794046 SHA256 b39867aab18d60180a21d34d01476216aa07d6b2af5368713f7bb16cba249506 SHA512 515869794be428ffbefcbfadac992912fb0eebab0cda640b315b4a231b5f25f1205978605f108b9009380015f3058c47e0ce4352c693ef23ab31980ea8b821a0 WHIRLPOOL 2ce68f5e2880d2c865164fde7d69669893b547da71d784c84194116a3aa491b2f2d72e932217ef0e265fbf1f67289bcb8d29bb010cf21a2ca2d8f1acb367774f
+DIST SAS2IRCU_P19.zip 2664125 BLAKE2B a005c556750bb8eeb3cb02a2aa138182ffeb2489088bfb6bad7696f5c659dbb8d02031474bf12d7f42f282351a2bf5f0791635e92625f0d7b32e63544913d8af SHA512 99f5092e1344747912b081f4f9e22a1f22d55e5a951583f5482213a38a1faa7cd890b573fdeb50d4770bb862d970364ccaff982969813edd9581e80bc39e2bdf
+DIST SAS2IRCU_P20.zip 2777958 BLAKE2B ba8c3ef1cf353af90f32a53722b3a7039768c0f48e1d5b48766acdf1c1c05a039692e1edc2586140da5af0f1f2378f4bfaca219895317dc7974004f3aed25343 SHA512 a0a4fa7d07959aa6a81d3540e71e3cc248c23267875ca098da6a80850e008cbdf57b2d6456b5fe17ef890fd39ac550788c9769d169a0673578632f1a8c8a8311
+DIST SAS2IRCU_User_Guide.pdf 794046 BLAKE2B e976f57ada3c51b58bfee24cd2f5d059f59b48bf388d93b146238d54aa09b06f6d450e3ccf149903871dfcdb32807a35d6f379738e149b410b7c1279f811153f SHA512 515869794be428ffbefcbfadac992912fb0eebab0cda640b315b4a231b5f25f1205978605f108b9009380015f3058c47e0ce4352c693ef23ab31980ea8b821a0
+DIST SAS2_IR_User_Guide.pdf 999388 BLAKE2B 4f1a198ccaa04cf250430106e3254cfb37fd16a1e89861030ed92f52de1d8cff17337709bb641093d78acb44995c03fceff739a0c416f7e3b1692c3b8c6a85dc SHA512 7370b54021978eb543270c992569637092571eaad73896b4bfdf7c7bc45bfd0cb0c6f8f34468255372103f562eb1e3ce2ad30cc6f0d37e7f9bc23f61ee166355
diff --git a/sys-block/sas2ircu/sas2ircu-20.ebuild b/sys-block/sas2ircu/sas2ircu-20.ebuild
new file mode 100644
index 000000000000..bc3aebe2751e
--- /dev/null
+++ b/sys-block/sas2ircu/sas2ircu-20.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit mount-boot
+
+DESCRIPTION="LSI MPT-SAS2 controller management tool"
+HOMEPAGE="https://www.broadcom.com/products/storage/host-bus-adapters/sas-9207-8e#tab-archive-drivers4-abc"
+LICENSE="LSI"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86 ~x86-fbsd ~ppc64 ~amd64-fbsd ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="efi doc"
+RESTRICT="strip fetch mirror"
+DEPEND=""
+RDEPEND=""
+QA_PREBUILT="opt/lsi/sas2ircu boot/efi/sas2ircu.efi"
+
+MY_PN=SAS2IRCU
+MY_P="${MY_PN}_P${PV}"
+
+DISTFILE_BIN=${MY_P}.zip
+DISTFILE_DOC=SAS2_IR_User_Guide.pdf
+DOC_PV=12
+
+SRC_URI="
+https://docs.broadcom.com/docs-and-downloads/host-bus-adapters/host-bus-adapters-common-files/sas_sata_6g_p20_point6/$DISTFILE_BIN
+doc? ( https://docs.broadcom.com/docs-and-downloads/host-bus-adapters/host-bus-adapters-common-files/SAS2_IR_User_Guide.pdf )
+"
+
+LICENSE_URL="http://www.lsi.com/cm/License.do?url=&prodName=&subType=Miscellaneous&locale=EN"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_nofetch() {
+ elog "LSI has a mandatory click-through license on thier binaries."
+ elog "Please visit $HOMEPAGE and download ${DISTFILE_BIN} from the Management Software and Tools section."
+ elog "After downloading, move ${DISTFILE_BIN} into $DISTDIR"
+ if use doc; then
+ elog "Please also download 'SAS-2 Integrated RAID Configuration Utility User Guide' (${DISTFILE_DOC}) "
+ elog "and also place it into $DISTDIR"
+ fi
+}
+
+supportedcards() {
+ elog "This binary supports should support ALL cards, including, but not"
+ elog "limited to the following series:"
+ elog ""
+ elog "LSI SAS 2004"
+ elog "LSI SAS 2008"
+ elog "LSI SAS 2108"
+ elog "LSI SAS 2208"
+ elog "LSI SAS 2304"
+ elog "LSI SAS 2308"
+ elog "Dell PERC H200, H700"
+ elog "IBM System x3200 M2 (4367, 4368)"
+ elog "IBM System x3200 M3 (7327, 7328)"
+ elog "IBM System x3250 M2 (4190, 4191, 4194)"
+ elog "IBM System x3250 M3 (4251, 4252, 4261)"
+ elog "IBM System x3350 (4192, 4193)"
+ elog "IBM System x3400 (7973, 7974, 7975, 7976)"
+ elog "IBM System x3400 M2 (7836, 7837)"
+ elog "IBM System x3455 (7940, 7941)"
+ elog "IBM System x3500 (7977)"
+ elog "IBM System x3500 M2 (7839)"
+ elog "IBM System x3550 (7978, 1913)"
+ elog "IBM System x3550 M2 (7946, 4198)"
+ elog "IBM System x3650 (7979, 1914)"
+ elog "IBM System x3650 M2 (7947, 4199)"
+ elog "IBM System x3650 NAS (7979)"
+ elog "IBM System x3655 (7985, 7943)"
+ elog "IBM System x3755 (8877, 7163)"
+ elog "IBM System x3850 M2 (7141, 7144, 7233, 7234)"
+ elog "IBM System x3850 X5 (7145, 7146)"
+ elog "IBM System x3950 M2 (7141, 7233, 7234)"
+ elog "IBM System x3950 X5 (7145)"
+}
+
+src_unpack() {
+ unpack ${DISTFILE_BIN}
+}
+
+src_install() {
+ exeinto /opt/lsi/
+ use amd64 || use x86 && doexe sas2ircu_linux_x86_rel/sas2ircu
+ use ppc64 && doexe sas2ircu_linux_x86_rel/sas2ircu
+ use amd64-fbsd && doexe sas2ircu_freebsd_amd64_rel/sas2ircu
+ use x86-fbsd && doexe sas2ircu_freebsd_i386_rel/sas2ircu
+ use x64-solaris || use x86-solaris && doexe sas2ircu_solaris_x86_rel/sas2ircu
+ use sparc-solaris && doexe sas2ircu_solaris_sparc_rel/sas2ircu
+ if use efi; then
+ exeinto /boot/efi/
+ doexe sas2ircu_efi_ebc_rel/sas2ircu.efi
+ fi
+ dodoc Readme_Release_Notes_SAS2IRCU_Phase_${PV}.00.00.00.txt
+ dodoc SAS2IRCU_Phase${PV}.0-${PV}.00.00.00.pdf
+ use doc && dodoc "${DISTDIR}"/$DISTFILE_DOC
+}