summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFelix Neumärker <xdch47@posteo.de>2020-01-17 23:41:51 +0100
committerJason Zaman <perfinion@gentoo.org>2020-02-16 21:34:12 +0800
commitccba6ee861c716a8e0ca1123a36ab2b1cf2ab1f6 (patch)
treefa2341d4d9e0df3648c89e0211242e29257ac84d /sys-block
parentnet-misc/rclone-1.51.0 version bump (diff)
downloadgentoo-ccba6ee861c716a8e0ca1123a36ab2b1cf2ab1f6.tar.gz
gentoo-ccba6ee861c716a8e0ca1123a36ab2b1cf2ab1f6.tar.bz2
gentoo-ccba6ee861c716a8e0ca1123a36ab2b1cf2ab1f6.zip
sys-block/zram-init: bump to 9.1 and fix push.sh reference
Closes: https://github.com/gentoo/gentoo/pull/14371 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Felix Neumärker <xdch47@posteo.de> Signed-off-by: Jason Zaman <perfinion@gentoo.org>
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/zram-init/Manifest1
-rw-r--r--sys-block/zram-init/zram-init-8.1-r1.ebuild55
-rw-r--r--sys-block/zram-init/zram-init-9.1.ebuild56
-rw-r--r--sys-block/zram-init/zram-init-9999.ebuild6
4 files changed, 116 insertions, 2 deletions
diff --git a/sys-block/zram-init/Manifest b/sys-block/zram-init/Manifest
index 8963ed2869de..f0102627e4b4 100644
--- a/sys-block/zram-init/Manifest
+++ b/sys-block/zram-init/Manifest
@@ -1 +1,2 @@
DIST zram-init-8.1.tar.gz 9177 BLAKE2B 229a469aeeb0b22b80f48d946d4ff746c7bd5d7b58ea9290db0da011df6d618c7c55ad95810b0be74ff81350182057d9067e834ecba688eb4ffa668521468a8b SHA512 8f688accb7a4231f705f694c4b4e7344bbb338b2b1f09a6dacd900020a4e8583105b25fef5b40f39630db88db6fcc8ec79824945ceaee95ea1279d09d081a994
+DIST zram-init-9.1.tar.gz 11414 BLAKE2B d7f7d1fd49594882a043322b905c02ac9e1f6ea78a626fb35ab0939096a062ef384e759d62e2cc4a990946e124317d70a4325b145e38612ebad173752209fa55 SHA512 4e3c76a389d188df98479f3f70af28405144b065df60ba191777cbec88d9bfe94be472d94bbb16314c0eefd41d177105cba74b45d1f13e82a741ff21a4d69c6a
diff --git a/sys-block/zram-init/zram-init-8.1-r1.ebuild b/sys-block/zram-init/zram-init-8.1-r1.ebuild
new file mode 100644
index 000000000000..74cb80aa2101
--- /dev/null
+++ b/sys-block/zram-init/zram-init-8.1-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit readme.gentoo-r1 systemd
+
+DESCRIPTION="Scripts to support compressed swap devices or ramdisks with zram"
+HOMEPAGE="https://github.com/vaeth/zram-init/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/vaeth/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/vaeth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~x86"
+fi
+
+RDEPEND=">=app-shells/push-2.0
+ !<sys-apps/openrc-0.13"
+
+DISABLE_AUTOFORMATTING="true"
+DOC_CONTENTS="To use zram, activate it in your kernel and add it to default runlevel:
+ rc-config add zram default
+If you use systemd enable zram_swap, tmp, and/or var_tmp with systemctl.
+You might need to modify /etc/modprobe.d/zram.conf"
+
+src_prepare() {
+ use prefix || sed -i \
+ -e '1s"^#!/usr/bin/env sh$"#!'"${EPREFIX}/bin/sh"'"' \
+ -e 's#PushA_=`push.sh 2>/dev/null`#PushA_=`cat '"${EPREFIX}"'/usr/share/push/push.sh`#' \
+ -- sbin/zram-init || die
+ default
+}
+
+src_install() {
+ doinitd openrc/init.d/*
+ doconfd openrc/conf.d/*
+ systemd_dounit systemd/system/*
+ insinto /etc/modprobe.d
+ doins modprobe.d/*
+ insinto /usr/share/zsh/site-functions
+ doins zsh/*
+ dodoc AUTHORS ChangeLog README.md
+ readme.gentoo_create_doc
+ into /
+ dosbin sbin/*
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}
diff --git a/sys-block/zram-init/zram-init-9.1.ebuild b/sys-block/zram-init/zram-init-9.1.ebuild
new file mode 100644
index 000000000000..87a6d31eaf21
--- /dev/null
+++ b/sys-block/zram-init/zram-init-9.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit readme.gentoo-r1 systemd
+
+DESCRIPTION="Scripts to support compressed swap devices or ramdisks with zram"
+HOMEPAGE="https://github.com/vaeth/zram-init/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/vaeth/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/vaeth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~x86"
+fi
+
+RDEPEND=">=app-shells/push-2.0
+ !<sys-apps/openrc-0.13"
+
+DISABLE_AUTOFORMATTING="true"
+DOC_CONTENTS="To use zram, activate it in your kernel and add it to default runlevel:
+ rc-config add zram default
+If you use systemd enable zram_swap, tmp, and/or var_tmp with systemctl.
+You might need to modify /etc/modprobe.d/zram.conf"
+
+src_prepare() {
+ use prefix || sed -i \
+ -e '1s"^#!/usr/bin/env sh$"#!'"${EPREFIX}/bin/sh"'"' \
+ -e 's#PushA_=`push.sh 2>/dev/null`#PushA_=`cat '"${EPREFIX}"'/usr/share/push/push.sh`#' \
+ -- sbin/zram-init || die
+ default
+}
+
+src_install() {
+ doinitd openrc/init.d/*
+ doconfd openrc/conf.d/*
+ systemd_dounit systemd/system/*
+ insinto /etc/modprobe.d
+ doins modprobe.d/*
+ insinto /usr/share/zsh/site-functions
+ doins zsh/*
+ dodoc AUTHORS ChangeLog README.md
+ readme.gentoo_create_doc
+ into /
+ dosbin sbin/*
+ doman man/${PN}.8
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}
diff --git a/sys-block/zram-init/zram-init-9999.ebuild b/sys-block/zram-init/zram-init-9999.ebuild
index 2b9aa4db74d0..87a6d31eaf21 100644
--- a/sys-block/zram-init/zram-init-9999.ebuild
+++ b/sys-block/zram-init/zram-init-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -31,7 +31,8 @@ You might need to modify /etc/modprobe.d/zram.conf"
src_prepare() {
use prefix || sed -i \
-e '1s"^#!/usr/bin/env sh$"#!'"${EPREFIX}/bin/sh"'"' \
- -- sbin/* || die
+ -e 's#PushA_=`push.sh 2>/dev/null`#PushA_=`cat '"${EPREFIX}"'/usr/share/push/push.sh`#' \
+ -- sbin/zram-init || die
default
}
@@ -47,6 +48,7 @@ src_install() {
readme.gentoo_create_doc
into /
dosbin sbin/*
+ doman man/${PN}.8
}
pkg_postinst() {