summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-01-17 09:09:03 +0100
committerJeroen Roovers <jer@gentoo.org>2018-01-17 09:09:03 +0100
commitf29b5e0790cdd9ed08b9018c20e12b18fe3caf97 (patch)
tree5d92955959f877f4e07b13edef03c71d9170b251 /sys-block
parentdev-python/pyblake2: x86 stable (bug #640898) (diff)
downloadgentoo-f29b5e0790cdd9ed08b9018c20e12b18fe3caf97.tar.gz
gentoo-f29b5e0790cdd9ed08b9018c20e12b18fe3caf97.tar.bz2
gentoo-f29b5e0790cdd9ed08b9018c20e12b18fe3caf97.zip
sys-block/parted: Debian patch level 19.
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/parted/Manifest1
-rw-r--r--sys-block/parted/parted-3.2_p19.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/sys-block/parted/Manifest b/sys-block/parted/Manifest
index a44cec40e3f7..47cb7217ab03 100644
--- a/sys-block/parted/Manifest
+++ b/sys-block/parted/Manifest
@@ -1,3 +1,4 @@
DIST parted-2.4.tar.xz 1516412 BLAKE2B fdc489ba9e0636b6f3e67d3863acf88ab3143e60aab2a75765502347e644954014530b7b1ad6dd625e6504abf936d367e65d418ba13379f57b4ba1c386583a23 SHA512 1f7ac11079981b176c1157bd6d858e67394bb4be9b622f91d4e78412a41c696809ed60912b8b94f3a2a924b2f43638dd5d6cb6f4c28e8dc63a2d421380cb5477
DIST parted-3.1.tar.xz 1524344 BLAKE2B 51f6cb84fb0a08dc5c9f634e265e4ac7778cde9f5400771af897a8661bf6dcdcfac2b2dec817c7d0f61d3fd5f8408c065754ea756ed59491dff75595d4306a2d SHA512 f29a67a16cf79f08abbfc5eeb6ad0480d834aa50e715378626dc89e3b12ce71f19202e9f38429e5521ebe877c4e74ff1e08f0b0ecbdbe79ba1c51fdcbef6e852
DIST parted-3.2.tar.xz 1655244 BLAKE2B 56608590b26a9b5266dacf3698d990b730bdb35d9374d1da57103fbef3ef5037e40dd2fe0f523ca8e0e75401a3b25cf543e5ca5c94cf410bbaa62ea15d6f0ba3 SHA512 4e37dbdd6f5032c9ebfec43704f6882379597d038167b9c4d04053efa083c68a705196713864451fa9e11d32777e16c68982877945c5efd9ea5f8252cb20e1c4
+DIST parted_3.2-19.debian.tar.xz 87288 BLAKE2B f0cef2978ead9edca3e952849deb36526eea0a050d45ab480b2aa62d02ba0a1750c28e93c28a714df6629f02ccf5a1e4fbb33a6e42b82bf6685c05aeaad1756c SHA512 de3e55545d7d94668eb608c8c31440f550baaf7b664836d199f73f7a8c75bba4ff59b4c06a23459c7d522250d7c03d29fa7f727f7d1a2b1e5a0366e83a2d871a
diff --git a/sys-block/parted/parted-3.2_p19.ebuild b/sys-block/parted/parted-3.2_p19.ebuild
new file mode 100644
index 000000000000..8e46676f03f2
--- /dev/null
+++ b/sys-block/parted/parted-3.2_p19.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools eutils flag-o-matic
+
+DESCRIPTION="Create, destroy, resize, check, copy partitions and file systems"
+HOMEPAGE="https://www.gnu.org/software/parted"
+SRC_URI="
+ mirror://gnu/${PN}/${P/_p*/}.tar.xz
+ mirror://debian/pool/main/p/${PN}/${PN}_${PV/_p/-}.debian.tar.xz
+"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="+debug device-mapper nls readline selinux static-libs"
+RESTRICT="test"
+
+# specific version for gettext needed
+# to fix bug 85999
+RDEPEND="
+ >=sys-fs/e2fsprogs-1.27
+ device-mapper? ( >=sys-fs/lvm2-2.02.45 )
+ readline? ( >=sys-libs/readline-5.2:0= >=sys-libs/ncurses-5.7-r7:0= )
+ selinux? ( sys-libs/libselinux )
+ elibc_uclibc? ( dev-libs/libiconv )
+"
+DEPEND="
+ ${RDEPEND}
+ nls? ( >=sys-devel/gettext-0.12.1-r2 )
+ virtual/pkgconfig
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.2-devmapper.patch
+ "${FILESDIR}"/${PN}-3.2-po4a-mandir.patch
+ "${FILESDIR}"/${PN}-3.2-sysmacros.patch
+)
+S=${WORKDIR}/${P/_p*/}
+
+src_prepare() {
+ default
+ for patch in $(< "${WORKDIR}"/debian/patches/series); do
+ eapply "${WORKDIR}/debian/patches/$patch"
+ done
+
+ eautoreconf
+}
+
+src_configure() {
+ use elibc_uclibc && append-libs -liconv
+ econf \
+ $(use_enable debug) \
+ $(use_enable device-mapper) \
+ $(use_enable nls) \
+ $(use_enable selinux) \
+ $(use_enable static-libs static) \
+ $(use_with readline) \
+ --disable-rpath \
+ --disable-silent-rules
+}
+
+DOCS=( AUTHORS BUGS ChangeLog NEWS README THANKS TODO doc/{API,FAT,USER.jp} )
+
+src_install() {
+ default
+
+ prune_libtool_files
+}