summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-05-26 12:10:00 +0200
committerDavid Seifert <soap@gentoo.org>2017-05-26 12:26:45 +0200
commitbd9d0922aec4371bbfc2628ce195762d0f3969db (patch)
tree7c08e693ea32458ddf8fefd0102586e4e524ec2c /sys-boot/bootcreator/bootcreator-1.1.ebuild
parentdev-python/pytest-3.0.6-r0: add ~alpha keyword (diff)
downloadgentoo-bd9d0922aec4371bbfc2628ce195762d0f3969db.tar.gz
gentoo-bd9d0922aec4371bbfc2628ce195762d0f3969db.tar.bz2
gentoo-bd9d0922aec4371bbfc2628ce195762d0f3969db.zip
sys-boot/bootcreator: Port to EAPI 6
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'sys-boot/bootcreator/bootcreator-1.1.ebuild')
-rw-r--r--sys-boot/bootcreator/bootcreator-1.1.ebuild24
1 files changed, 9 insertions, 15 deletions
diff --git a/sys-boot/bootcreator/bootcreator-1.1.ebuild b/sys-boot/bootcreator/bootcreator-1.1.ebuild
index 274359223c86..6c39fd7daa63 100644
--- a/sys-boot/bootcreator/bootcreator-1.1.ebuild
+++ b/sys-boot/bootcreator/bootcreator-1.1.ebuild
@@ -1,35 +1,29 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-inherit eutils
+EAPI=6
DESCRIPTION="Simple generator for Forth based BootMenu scripts for Pegasos machines"
-
HOMEPAGE="http://tbs-software.com/morgoth/projects.html"
SRC_URI="http://tbs-software.com/morgoth/files/bootcreator-src.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="ppc -*"
IUSE=""
-DEPEND=""
-S=${WORKDIR}/${PN}
+DEPEND=""
-src_unpack() {
- unpack ${A}
- cd ${S}
- mv examples/example.bc examples/bootmenu.example
-}
+S=${WORKDIR}
src_compile() {
- cd ${S}
- make all || die "Can't compile bootmenu"
+ emake all
}
src_install() {
- cd ${S}
dosbin src/bootcreator
+ dodoc doc/README
+
insinto /etc
- doins examples/bootmenu.example
- dodoc doc/README doc/COPYING
+ newins examples/example.bc bootmenu.example
}