summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2016-08-19 13:51:17 -0400
committerMike Gilbert <floppym@gentoo.org>2016-08-19 13:56:13 -0400
commit863fd60b1c2dbc26f4091b3b1291e9d4ee1e41ce (patch)
tree843c5d8d1d38899c26867b9efb8ad9ff30116334 /sys-boot/efibootmgr/efibootmgr-13.ebuild
parentsys-libs/efivar: bump to 27 (diff)
downloadgentoo-863fd60b1c2dbc26f4091b3b1291e9d4ee1e41ce.tar.gz
gentoo-863fd60b1c2dbc26f4091b3b1291e9d4ee1e41ce.tar.bz2
gentoo-863fd60b1c2dbc26f4091b3b1291e9d4ee1e41ce.zip
sys-boot/efibootmgr: bump to 13
Package-Manager: portage-2.3.0_p16
Diffstat (limited to 'sys-boot/efibootmgr/efibootmgr-13.ebuild')
-rw-r--r--sys-boot/efibootmgr/efibootmgr-13.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sys-boot/efibootmgr/efibootmgr-13.ebuild b/sys-boot/efibootmgr/efibootmgr-13.ebuild
new file mode 100644
index 000000000000..51308d22483b
--- /dev/null
+++ b/sys-boot/efibootmgr/efibootmgr-13.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="User-space application to modify the EFI boot manager"
+HOMEPAGE="https://github.com/rhinstaller/efibootmgr"
+SRC_URI="https://github.com/rhinstaller/efibootmgr/releases/download/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~x86"
+IUSE=""
+
+RDEPEND="sys-apps/pciutils
+ >=sys-libs/efivar-25:="
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ sed -i -e s/-Werror// Make.defaults || die
+}
+
+src_configure() {
+ tc-export CC
+}
+
+src_install() {
+ default
+ dosbin src/efibootdump
+}