summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-07-01 07:45:04 +0100
committerSam James <sam@gentoo.org>2021-07-01 07:45:21 +0100
commitf4da428e42fcf46821f2fa412b7ccc5a4632dc82 (patch)
tree6685b9b17e30336a48e4660748a74b1c1e801103 /sys-boot/mokutil/mokutil-0.5.0-r1.ebuild
parentnet-ftp/gproftpd: drop configure mv (diff)
downloadgentoo-f4da428e42fcf46821f2fa412b7ccc5a4632dc82.tar.gz
gentoo-f4da428e42fcf46821f2fa412b7ccc5a4632dc82.tar.bz2
gentoo-f4da428e42fcf46821f2fa412b7ccc5a4632dc82.zip
sys-boot/mokutil: add missing keyutils dep
Closes: https://bugs.gentoo.org/799443 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-boot/mokutil/mokutil-0.5.0-r1.ebuild')
-rw-r--r--sys-boot/mokutil/mokutil-0.5.0-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/sys-boot/mokutil/mokutil-0.5.0-r1.ebuild b/sys-boot/mokutil/mokutil-0.5.0-r1.ebuild
new file mode 100644
index 000000000000..560c290cb156
--- /dev/null
+++ b/sys-boot/mokutil/mokutil-0.5.0-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="The utility to manipulate machines owner keys which managed in shim"
+HOMEPAGE="https://github.com/lcp/mokutil"
+SRC_URI="https://github.com/lcp/mokutil/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-libs/openssl:=
+ sys-apps/keyutils:=
+ sys-libs/efivar:=
+ virtual/libcrypt:="
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+ eautoreconf
+}