summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStéphane Veyret <stephane@neptura.org>2020-04-29 21:19:10 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-04-30 14:59:56 +0300
commit6ea0ac9d85b3d9360e28420cc4bb01552d18208c (patch)
treee18dd3307fe13c169a5aa755c85e249eb8c125e5 /sys-boot/refind
parentsys-boot/udk: Remove colon from sed (diff)
downloadgentoo-6ea0ac9d85b3d9360e28420cc4bb01552d18208c.tar.gz
gentoo-6ea0ac9d85b3d9360e28420cc4bb01552d18208c.tar.bz2
gentoo-6ea0ac9d85b3d9360e28420cc4bb01552d18208c.zip
sys-boot/refind: Bump to version 0.12.0
Closes: https://bugs.gentoo.org/711832 Closes: https://bugs.gentoo.org/720034 Signed-off-by: Stéphane Veyret <stephane@neptura.org> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-boot/refind')
-rw-r--r--sys-boot/refind/Manifest1
-rw-r--r--sys-boot/refind/refind-0.12.0.ebuild168
2 files changed, 169 insertions, 0 deletions
diff --git a/sys-boot/refind/Manifest b/sys-boot/refind/Manifest
index a294c06247e8..bf2e5d87e50f 100644
--- a/sys-boot/refind/Manifest
+++ b/sys-boot/refind/Manifest
@@ -2,3 +2,4 @@ DIST refind-src-0.10.4.tar.gz 3970380 BLAKE2B 0d14c005d3e93a1f0008b6c65e34eb6391
DIST refind-src-0.11.2.tar.gz 4533034 BLAKE2B fa05781fc1d87d314677f8e670bd7282b591fd3b6f4a5863e81cb962fdb773c774faabb6c45544b0659c8d5c4ef7ce1dba8d798a4caa97364ad7aa2532a42050 SHA512 796d86f05152d93340773c2dfbae0ca50ab036373ebed60fcc80404ee269ef4bc100df4b141d555d3363b820c3e9234fc0cf637791061281c86329958dca3479
DIST refind-src-0.11.3.tar.gz 3792206 BLAKE2B 369b25dbc97d83f9143ccbe19e89b5975f0796f1e4a2decfc124e4b45c5ef1db8f3e2bb83413f596ca28e82e67b0b9c5682b557a5422e3146780cec151d2a36e SHA512 96907b79e1c9c8199c62058bb6851fa5d6f158802f3777ba19a62c6c0d7d5b49132754bcafa925510fd21c8bafe8ce393117070a628baf4c277fa5f8f536b797
DIST refind-src-0.11.4.tar.gz 3812192 BLAKE2B 7219eeffffb63961a7ba8f7617546a12021cfe80df80a83c4dbd47cd40b0d8afbdc510abb44de3029ff15ed49372bd59e0b156f4c27eab3ef7bd6ccc3c7e02db SHA512 529962ae432edaf1895ba98deb00a23c66bd742578e1a367f70f7ed22dd7be7daf1960df8af410fba79ca775169120499a4c10119331b2b12b55a002d4354de1
+DIST refind-src-0.12.0.tar.gz 3898337 BLAKE2B 1197049fb7d91db64135dafda7488bdb1da4997ce6a6d49dfe635526240e3193d8c7c22597aee0f2d6754ce6061b4127d8aa21d43c9f061501de98e25de609d3 SHA512 3ade9642d7acf31097daa5308acb96a9fa3371314073b5a09601a886fc30444752efa08ed9fb35e421efb0b4eb9efbccd7b5c9bd6b3b9ed4af74c58f22a74729
diff --git a/sys-boot/refind/refind-0.12.0.ebuild b/sys-boot/refind/refind-0.12.0.ebuild
new file mode 100644
index 000000000000..9091a88cfcb1
--- /dev/null
+++ b/sys-boot/refind/refind-0.12.0.ebuild
@@ -0,0 +1,168 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multiprocessing toolchain-funcs
+
+DESCRIPTION="The UEFI Boot Manager by Rod Smith"
+HOMEPAGE="https://www.rodsbooks.com/refind/"
+SRC_URI="mirror://sourceforge/project/${PN}/${PV}/${PN}-src-${PV}.tar.gz"
+
+LICENSE="BSD GPL-2 GPL-3 FDL-1.3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+FS_USE="btrfs +ext2 +ext4 hfs +iso9660 ntfs reiserfs"
+IUSE="${FS_USE} custom-cflags doc gnuefi"
+
+DEPEND="gnuefi? ( >=sys-boot/gnu-efi-3.0.2 )
+ !gnuefi? ( >=sys-boot/udk-2018-r1 )"
+
+DOCS=(README.txt)
+PATCHES=("${FILESDIR}/makefile.patch")
+UDK_WORKSPACE="${T}/udk"
+
+pkg_pretend() {
+ if use custom-cflags; then
+ ewarn
+ ewarn "You have enabled building with USE=custom-cflags. Be aware that"
+ ewarn "using this can result in EFI binaries that fail to run and may"
+ ewarn "fail to build at all. This is strongly advised against by upstream."
+ ewarn
+ ewarn "See https://bugs.gentoo.org/598587#c3 for more information"
+ ewarn
+ fi
+}
+
+pkg_setup() {
+ if use x86; then
+ export EFIARCH=ia32
+ export BUILDARCH=ia32
+ elif use amd64; then
+ export EFIARCH=x64
+ export BUILDARCH=x86_64
+ fi
+}
+
+src_prepare() {
+ default
+
+ # bug 598647 - PIE not supported
+ sed -e '/^CFLAGS/s:$: -fno-PIE:' -i Make.common || die
+
+ # Prepare UDK workspace
+ if ! use gnuefi; then
+ mkdir "${UDK_WORKSPACE}" || die
+ ln -s "${EPREFIX}/usr/lib/udk/"{Mde,IntelFramework}{,Module}Pkg \
+ "${UDK_WORKSPACE}" || die "Could not link UDK files"
+ fi
+}
+
+src_configure() {
+ if ! use gnuefi; then
+ # Use the side effect of the script which will create configuration files
+ (. udk-workspace "${UDK_WORKSPACE}" || die)
+ sed -e "s:^#\?\s*\(MAX_CONCURRENT_THREAD_NUMBER\s*=\).*$:\1 $(makeopts_jobs):" \
+ -i "${UDK_WORKSPACE}/Conf/target.txt" || die "Failed to configure target file"
+ sed -e "s:\(_\(CC\|ASM\|PP\|VFRPP\|ASLCC\|ASLPP\|DLINK\)_PATH\s*=\).*$:\1 $(tc-getCC):" \
+ -e "s:\(_ASLDLINK_PATH\s*=\).*$:\1 $(tc-getLD):" \
+ -e "s:\(_OBJCOPY_PATH\s*=\).*$:\1 $(tc-getOBJCOPY):" \
+ -e "s:\(_RC_PATH\s*=\).*$:\1 $(tc-getOBJCOPY):" \
+ -e "s:\(_SLINK_PATH\s*=\).*$:\1 $(tc-getAR):" \
+ -e "s:-Werror::" \
+ -i "${UDK_WORKSPACE}/Conf/tools_def.txt" \
+ || die "Failed to prepare tools definition file"
+ fi
+}
+
+src_compile() {
+ # Update fs targets depending on uses
+ local fs fs_names=()
+ for fs in ${FS_USE}; do
+ fs=${fs#+}
+ if use "${fs}"; then
+ fs_names+=(${fs})
+ fi
+ done
+ use gnuefi && fs_names=("${fs_names[@]/%/_gnuefi}")
+
+ # Prepare flags
+ local make_flags=(
+ ARCH="${BUILDARCH}"
+ CC="$(tc-getCC)"
+ AS="$(tc-getAS)"
+ LD="$(tc-getLD)"
+ AR="$(tc-getAR)"
+ RANLIB="$(tc-getRANLIB)"
+ OBJCOPY="$(tc-getOBJCOPY)"
+ GNUEFILIB="/usr/$(get_libdir)"
+ EFILIB="/usr/$(get_libdir)"
+ EFICRT0="/usr/$(get_libdir)"
+ EDK2BASE="${UDK_WORKSPACE}"
+ EDK2_DRIVER_BASENAMES="${fs_names[@]}"
+ FILESYSTEMS="${fs_names[@]}"
+ FILESYSTEMS_GNUEFI="${fs_names[@]}"
+ )
+ if use custom-cflags; then
+ make_flags=(CFLAGS="${CFLAGS}" "${make_flags[@]}")
+ fi
+
+ emake "${make_flags[@]}" all_$(usex gnuefi gnuefi edk2)
+}
+
+src_install() {
+ exeinto "/usr/lib/${PN}"
+ doexe refind-install
+ dosym "../lib/${PN}/refind-install" "/usr/sbin/refind-install"
+
+ if use doc; then
+ doman "docs/man/"*
+ DOCS+=(NEWS.txt docs/refind docs/Styles)
+ fi
+ einstalldocs
+
+ insinto "/usr/lib/${PN}/refind"
+ doins "refind/refind_${EFIARCH}.efi"
+ doins "refind.conf-sample"
+ doins -r images icons fonts banners
+
+ if [[ -d "drivers_${EFIARCH}" ]]; then
+ doins -r "drivers_${EFIARCH}"
+ fi
+
+ insinto "/usr/lib/${PN}/refind/tools_${EFIARCH}"
+ doins "gptsync/gptsync_${EFIARCH}.efi"
+
+ insinto "/etc/refind.d"
+ doins -r "keys"
+
+ dosbin "mkrlconf"
+ dosbin "mvrefind"
+ dosbin "refind-mkdefault"
+}
+
+pkg_postinst() {
+ elog "rEFInd has been built and installed into ${EROOT}/usr/lib/${PN}"
+ elog "You will need to use the command 'refind-install' to install"
+ elog "the binaries into your EFI System Partition"
+ elog ""
+ elog "refind-install requires additional packages to be fully functional:"
+ elog " app-crypt/sbsigntools for binary signing for use with SecureBoot"
+ elog " sys-boot/efibootmgr for writing to NVRAM"
+ elog " sys-apps/gptfdisk for ESP management"
+ elog ""
+ elog "refind-mkdefault requires >=dev-lang/python-3"
+ elog ""
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "A sample configuration can be found at"
+ elog "${EROOT}/usr/lib/${PN}/refind/refind.conf-sample"
+ else
+ if ver_test "${REPLACING_VERSIONS}" -lt "0.12.0"; then
+ ewarn "This new version uses sys-apps/gptfdisk instead of sys-block/parted"
+ ewarn "to manage ESP"
+ ewarn ""
+ fi
+ ewarn "Note that this installation will not update any EFI binaries"
+ ewarn "on your EFI System Partition - this needs to be done manually"
+ fi
+}