summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jordan <immoloism@gmail.com>2022-11-18 03:15:53 +0000
committerSam James <sam@gentoo.org>2022-12-24 07:05:41 +0000
commit457a408fd47cc48950a5c7cd86ed99c3c42206ce (patch)
treed140598dffec7ddd64ead8e53a39e3494fcc06a7 /sys-boot/syslinux
parentdev-perl/Net-SSLeay: Search for OpenSSL using ESYSROOT (diff)
downloadgentoo-457a408fd47cc48950a5c7cd86ed99c3c42206ce.tar.gz
gentoo-457a408fd47cc48950a5c7cd86ed99c3c42206ce.tar.bz2
gentoo-457a408fd47cc48950a5c7cd86ed99c3c42206ce.zip
sys-boot/syslinux: Filter LTO
Syslinux can only use LTO when using the ffat-lto-objects cflag and as this is a hack solution I recommend filtering which seems to be the only way to do it without. Closes: https://bugs.gentoo.org/863722 Signed-off-by: Ian Jordan <immoloism@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/28318 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-boot/syslinux')
-rw-r--r--sys-boot/syslinux/syslinux-6.04_pre1-r4.ebuild4
-rw-r--r--sys-boot/syslinux/syslinux-6.04_pre1-r5.ebuild4
-rw-r--r--sys-boot/syslinux/syslinux-6.04_pre3-r1.ebuild4
3 files changed, 9 insertions, 3 deletions
diff --git a/sys-boot/syslinux/syslinux-6.04_pre1-r4.ebuild b/sys-boot/syslinux/syslinux-6.04_pre1-r4.ebuild
index cf6b824f1fdc..0c721bfd018e 100644
--- a/sys-boot/syslinux/syslinux-6.04_pre1-r4.ebuild
+++ b/sys-boot/syslinux/syslinux-6.04_pre1-r4.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit toolchain-funcs
+inherit toolchain-funcs flag-o-matic
DESCRIPTION="SYSLINUX, PXELINUX, ISOLINUX, EXTLINUX and MEMDISK bootloaders"
HOMEPAGE="https://www.syslinux.org/"
@@ -104,6 +104,8 @@ _emake() {
}
src_compile() {
+ filter-lto #863722
+
# build system abuses the LDFLAGS variable to pass arguments to ld
unset LDFLAGS
if [[ ! -z ${loaderarch} ]]; then
diff --git a/sys-boot/syslinux/syslinux-6.04_pre1-r5.ebuild b/sys-boot/syslinux/syslinux-6.04_pre1-r5.ebuild
index e4925c07622a..41c78e9eeffb 100644
--- a/sys-boot/syslinux/syslinux-6.04_pre1-r5.ebuild
+++ b/sys-boot/syslinux/syslinux-6.04_pre1-r5.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit toolchain-funcs
+inherit toolchain-funcs flag-o-matic
DESCRIPTION="SYSLINUX, PXELINUX, ISOLINUX, EXTLINUX and MEMDISK bootloaders"
HOMEPAGE="https://www.syslinux.org/"
@@ -50,6 +50,8 @@ src_prepare() {
default
}
src_compile() {
+ filter-lto #863722
+
local DATE=$(date -u -r NEWS +%Y%m%d)
local HEXDATE=$(printf '0x%08x' "${DATE}")
diff --git a/sys-boot/syslinux/syslinux-6.04_pre3-r1.ebuild b/sys-boot/syslinux/syslinux-6.04_pre3-r1.ebuild
index 9c48e26d67c6..65c9463b4d12 100644
--- a/sys-boot/syslinux/syslinux-6.04_pre3-r1.ebuild
+++ b/sys-boot/syslinux/syslinux-6.04_pre3-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit toolchain-funcs
+inherit toolchain-funcs flag-o-matic
DESCRIPTION="SYSLINUX, PXELINUX, ISOLINUX, EXTLINUX and MEMDISK bootloaders"
HOMEPAGE="https://www.syslinux.org/"
@@ -67,6 +67,8 @@ efimake() {
}
src_compile() {
+ filter-lto #863722
+
local DATE=$(date -u -r NEWS +%Y%m%d)
local HEXDATE=$(printf '0x%08x' "${DATE}")