summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2019-01-10 11:45:18 +0300
committerMikle Kolyada <zlogene@gentoo.org>2019-01-10 11:45:35 +0300
commit06b44e6ede596b21ac3a83091b8b5ecb17251ce3 (patch)
tree5e59fa78154dd834fd892c1c6713f3d0b8cb2eb5 /sys-boot
parentapp-admin/fluentd: Version bump (v1.3.2) (diff)
downloadgentoo-06b44e6ede596b21ac3a83091b8b5ecb17251ce3.tar.gz
gentoo-06b44e6ede596b21ac3a83091b8b5ecb17251ce3.tar.bz2
gentoo-06b44e6ede596b21ac3a83091b8b5ecb17251ce3.zip
sys-boot/grub-static: remove last rited package
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/grub-static/Manifest3
-rw-r--r--sys-boot/grub-static/grub-static-0.97-r10.ebuild177
-rw-r--r--sys-boot/grub-static/grub-static-0.97-r12.ebuild181
-rw-r--r--sys-boot/grub-static/grub-static-0.97-r9.ebuild173
-rw-r--r--sys-boot/grub-static/metadata.xml8
5 files changed, 0 insertions, 542 deletions
diff --git a/sys-boot/grub-static/Manifest b/sys-boot/grub-static/Manifest
deleted file mode 100644
index 0a661f9a9fcf..000000000000
--- a/sys-boot/grub-static/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST grub-static-0.97-r10.tar.bz2 888963 BLAKE2B 1891685b312c129efb47fd78ffd2a433655225b8dcb8a60592faabbc5300ce6d56efea70272cf9a1e8cfaa70224d1a3a313d1c2e2296bfd43593a4a12aec541e SHA512 2a18405c9f7b0712dac2246213f723c1a2be6734bff133b7906e7c18e4370faf924f35d3b834d74761cf50b3ab59e969fbff010e13292618187c65a72aa45a87
-DIST grub-static-0.97-r12.tar.bz2 1171586 BLAKE2B 066cde81f4b1849467d83ec982745dc8449e38895edc0eee979d6ea782a802c2a2c6b2a4f03eb976c03ce3f6e3213d3605e9bb6c99f8479e59fafb1716cbd0c9 SHA512 0a4c0b3b556db366df70c7c51a1a26f614f949be4002d7f9a053b7261b80c2c49410e8fd04c7e3717ea560e7cbc6a692d859d07bdfe2099a78a33bce78ac5395
-DIST grub-static-0.97-r9.tar.bz2 937621 BLAKE2B a61fa8b41de4208cf30222fa742bb84a5f60bb924f5cf57f12ae9a382b1bf9e7feff740029ca3a08939d070275b4bb5389981c9a26f6decd18d4c7120f8d0f52 SHA512 a8b1f7cd416f2c41c88ba5c34889e7afe9615bf985e69b2d1d3ec2a20b7ceb13e53e8b3df91a5077bfa1a217f3274362033d72f9bafe3ad22be378f26728035c
diff --git a/sys-boot/grub-static/grub-static-0.97-r10.ebuild b/sys-boot/grub-static/grub-static-0.97-r10.ebuild
deleted file mode 100644
index 0eb33ec53e23..000000000000
--- a/sys-boot/grub-static/grub-static-0.97-r10.ebuild
+++ /dev/null
@@ -1,177 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=0
-
-# XXX: we need to review menu.lst vs grub.conf handling. We've been converting
-# all systems to grub.conf (and symlinking menu.lst to grub.conf), but
-# we never updated any of the source code (it still all wants menu.lst),
-# and there is no indication that upstream is making the transition.
-
-inherit eutils mount-boot toolchain-funcs linux-info
-
-PATCHVER="1.9" # Not used, just for tracking with main grub
-
-DESCRIPTION="GNU GRUB Legacy boot loader (static build)"
-
-HOMEPAGE="https://www.gnu.org/software/grub/"
-SRC_URI="mirror://gentoo/${PF}.tar.bz2"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="-* amd64 ~x86"
-IUSE=""
-DEPEND="!<sys-boot/grub-2"
-RDEPEND="${DEPEND}"
-
-# These are already stripped since we use a binpkg.
-QA_PRESTRIPPED="/sbin/grub /bin/mbchk"
-
-pkg_setup() {
- local arch="$(tc-arch)"
- case ${arch} in
- amd64)
- CONFIG_CHECK='~IA32_EMULATION'
- WARNING_IA32_EMULATION="You will NOT be able to run grub unless you have IA32_EMULATION set!"
- check_extra_config
- ;;
- esac
-}
-
-src_install() {
- cp -a "${WORKDIR}"/* "${D}"/
- if [[ -z "${I_KNOW_WHAT_I_AM_DOING}" ]]; then
- run_test_grub "${D}"/sbin/grub && einfo "New grub can run on your system, good!"
- fi
-}
-
-run_test_grub() {
- local grub="$1"
- local version="$(${grub} \
- --read-only --no-pager --no-floppy --no-curses \
- --no-config-file --batch --version)"
- local error="grub test-run failed"
- use amd64 && error="${error} Is IA32_EMULATION set?"
- [ "${version/${PV}}" != "${version}" ] || die "${error}"
- return 0
-}
-
-#
-# Below this point, everything is also used in grub-static!
-# Please keep in sync!
-#
-
-setup_boot_dir() {
- local boot_dir=$1
- local dir=${boot_dir}
-
- if [[ -z "${I_KNOW_WHAT_I_AM_DOING}" ]]; then
- run_test_grub /sbin/grub
- fi
-
- mkdir -p "${dir}"
- [[ ! -L ${dir}/boot ]] && ln -s . "${dir}/boot"
- dir="${dir}/grub"
- if [[ ! -e ${dir} ]] ; then
- mkdir "${dir}" || die "${dir} does not exist!"
- fi
-
- # change menu.lst to grub.conf
- if [[ ! -e ${dir}/grub.conf ]] && [[ -e ${dir}/menu.lst ]] ; then
- mv -f "${dir}"/menu.lst "${dir}"/grub.conf
- ewarn
- ewarn "*** IMPORTANT NOTE: menu.lst has been renamed to grub.conf"
- ewarn
- fi
-
- if [[ ! -e ${dir}/menu.lst ]]; then
- einfo "Linking from new grub.conf name to menu.lst"
- ln -snf grub.conf "${dir}"/menu.lst
- fi
-
- if [[ -e ${dir}/stage2 ]] ; then
- mv "${dir}"/stage2{,.old}
- ewarn "*** IMPORTANT NOTE: you must run grub and install"
- ewarn "the new version's stage1 to your MBR. Until you do,"
- ewarn "stage1 and stage2 will still be the old version, but"
- ewarn "later stages will be the new version, which could"
- ewarn "cause problems such as an unbootable system."
- ewarn "This means you must use either grub-install or perform"
- ewarn "root/setup manually! For more help, see the handbook:"
- ewarn "https://www.gentoo.org/doc/en/handbook/handbook-${ARCH}.xml?part=1&chap=10#grub-install-auto"
- ebeep
- fi
-
- einfo "Copying files from /lib/grub, /usr/lib/grub and /usr/share/grub to ${dir}"
- for x in \
- "${ROOT}"/lib*/grub/*/* \
- "${ROOT}"/usr/lib*/grub/*/* \
- "${ROOT}"/usr/share/grub/* ; do
- [[ -f ${x} ]] && cp -p "${x}" "${dir}"/
- done
-
- if [[ ! -e ${dir}/grub.conf ]] ; then
- s="${ROOT}/usr/share/doc/${PF}/grub.conf.gentoo"
- [[ -e "${s}" ]] && cat "${s}" >${dir}/grub.conf
- [[ -e "${s}.gz" ]] && zcat "${s}.gz" >${dir}/grub.conf
- [[ -e "${s}.bz2" ]] && bzcat "${s}.bz2" >${dir}/grub.conf
- fi
-
- # Per bug 218599, we support grub.conf.install for users that want to run a
- # specific set of Grub setup commands rather than the default ones.
- grub_config=${dir}/grub.conf.install
- [[ -e ${grub_config} ]] || grub_config=${dir}/grub.conf
- if [[ -e ${grub_config} ]] ; then
- local tmp="${TMPDIR}/${P}-setup_boot_dir-$$"
- egrep \
- -v '^[[:space:]]*(#|$|default|fallback|initrd|password|splashimage|timeout|title)' \
- "${grub_config}" >"${tmp}"
- # Do NOT fail here, only warn.
- /sbin/grub --batch \
- --device-map="${dir}"/device.map \
- >/dev/null <"${tmp}"
- rc=$?
- [[ $rc -ne 0 ]] && ewarn "Grub failed to run!"
- fi
-
- # the grub default commands silently piss themselves if
- # the default file does not exist ahead of time
- if [[ ! -e ${dir}/default ]] ; then
- # This may fail, don't worry about it.
- grub-set-default --root-directory="${boot_dir}" default
- :
- fi
- einfo "Grub has been installed to ${boot_dir} successfully."
-}
-
-pkg_postinst() {
- mount-boot_pkg_postinst
-
- if [[ -n ${DONT_MOUNT_BOOT} ]]; then
- elog "WARNING: you have DONT_MOUNT_BOOT in effect, so you must apply"
- elog "the following instructions for your /boot!"
- elog "Neglecting to do so may cause your system to fail to boot!"
- elog
- else
- setup_boot_dir "${ROOT}"/boot
- # Trailing output because if this is run from pkg_postinst, it gets mixed into
- # the other output.
- einfo ""
- fi
- elog "To interactively install grub files to another device such as a USB"
- elog "stick, just run the following and specify the directory as prompted:"
- elog " emerge --config =${PF}"
- elog "Alternately, you can export GRUB_ALT_INSTALLDIR=/path/to/use to tell"
- elog "grub where to install in a non-interactive way."
-
-}
-
-pkg_config() {
- local dir
- if [ ! -d "${GRUB_ALT_INSTALLDIR}" ]; then
- einfo "Enter the directory where you want to setup grub:"
- read dir
- else
- dir="${GRUB_ALT_INSTALLDIR}"
- fi
- setup_boot_dir "${dir}"
-}
diff --git a/sys-boot/grub-static/grub-static-0.97-r12.ebuild b/sys-boot/grub-static/grub-static-0.97-r12.ebuild
deleted file mode 100644
index b824c17fb821..000000000000
--- a/sys-boot/grub-static/grub-static-0.97-r12.ebuild
+++ /dev/null
@@ -1,181 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=0
-
-# XXX: we need to review menu.lst vs grub.conf handling. We've been converting
-# all systems to grub.conf (and symlinking menu.lst to grub.conf), but
-# we never updated any of the source code (it still all wants menu.lst),
-# and there is no indication that upstream is making the transition.
-
-inherit eutils mount-boot toolchain-funcs linux-info
-
-PATCHVER="1.14" # Not used, just for tracking with main grub
-
-DESCRIPTION="GNU GRUB Legacy boot loader (static build)"
-
-HOMEPAGE="https://www.gnu.org/software/grub/"
-SRC_URI="mirror://gentoo/${PF}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="-* amd64 ~x86"
-IUSE=""
-
-DEPEND="!<sys-boot/grub-2"
-RDEPEND="${DEPEND}"
-
-S=${WORKDIR}
-
-pkg_setup() {
- case $(tc-arch) in
- amd64)
- CONFIG_CHECK='~IA32_EMULATION'
- WARNING_IA32_EMULATION="You will NOT be able to run grub unless you have IA32_EMULATION set!"
- check_extra_config
- ;;
- esac
-}
-
-src_install() {
- cp -a * "${D}"/
- # Make sure the docs get compressed
- dodoc usr/share/doc/${PF}/*
-
- if [[ -z "${I_KNOW_WHAT_I_AM_DOING}" ]]; then
- run_test_grub "${D}"/sbin/grub && einfo "New grub can run on your system, good!"
- fi
-}
-
-run_test_grub() {
- local grub="$1"
- local version="$(${grub} \
- --read-only --no-pager --no-floppy --no-curses \
- --no-config-file --batch --version)"
- local error="grub test-run failed"
- use amd64 && error="${error} Is IA32_EMULATION set?"
- [ "${version/${PV}}" != "${version}" ] || die "${error}"
- return 0
-}
-
-#
-# Below this point, everything is also used in grub-static!
-# Please keep in sync!
-#
-
-setup_boot_dir() {
- local boot_dir=$1
- local dir=${boot_dir}
-
- if [[ -z "${I_KNOW_WHAT_I_AM_DOING}" ]]; then
- run_test_grub /sbin/grub
- fi
-
- mkdir -p "${dir}"
- [[ ! -L ${dir}/boot ]] && ln -s . "${dir}/boot"
- dir="${dir}/grub"
- if [[ ! -e ${dir} ]] ; then
- mkdir "${dir}" || die
- fi
-
- # change menu.lst to grub.conf
- if [[ ! -e ${dir}/grub.conf ]] && [[ -e ${dir}/menu.lst ]] ; then
- mv -f "${dir}"/menu.lst "${dir}"/grub.conf
- ewarn
- ewarn "*** IMPORTANT NOTE: menu.lst has been renamed to grub.conf"
- ewarn
- fi
-
- if [[ ! -e ${dir}/menu.lst ]]; then
- einfo "Linking from new grub.conf name to menu.lst"
- ln -snf grub.conf "${dir}"/menu.lst
- fi
-
- if [[ -e ${dir}/stage2 ]] ; then
- mv "${dir}"/stage2{,.old}
- ewarn "*** IMPORTANT NOTE: you must run grub and install"
- ewarn "the new version's stage1 to your MBR. Until you do,"
- ewarn "stage1 and stage2 will still be the old version, but"
- ewarn "later stages will be the new version, which could"
- ewarn "cause problems such as an unbootable system."
- ewarn "This means you must use either grub-install or perform"
- ewarn "root/setup manually! For more help, see the handbook:"
- ewarn "https://www.gentoo.org/doc/en/handbook/handbook-${ARCH}.xml?part=1&chap=10#grub-install-auto"
- ebeep
- fi
-
- einfo "Copying files from /lib/grub, /usr/lib/grub and /usr/share/grub to ${dir}"
- for x in \
- "${ROOT}"/lib*/grub/*/* \
- "${ROOT}"/usr/lib*/grub/*/* \
- "${ROOT}"/usr/share/grub/* ; do
- [[ -f ${x} ]] && cp -p "${x}" "${dir}"/
- done
-
- if [[ ! -e ${dir}/grub.conf ]] ; then
- s="${ROOT}/usr/share/doc/${PF}/grub.conf.gentoo"
- [[ -e "${s}" ]] && cat "${s}" >${dir}/grub.conf
- [[ -e "${s}.gz" ]] && zcat "${s}.gz" >${dir}/grub.conf
- [[ -e "${s}.bz2" ]] && bzcat "${s}.bz2" >${dir}/grub.conf
- fi
-
- # Per bug 218599, we support grub.conf.install for users that want to run a
- # specific set of Grub setup commands rather than the default ones.
- grub_config=${dir}/grub.conf.install
- [[ -e ${grub_config} ]] || grub_config=${dir}/grub.conf
- if [[ -e ${grub_config} ]] ; then
- local tmp="${TMPDIR}/${P}-setup_boot_dir-$$"
- egrep \
- -v '^[[:space:]]*(#|$|default|fallback|initrd|password|splashimage|timeout|title)' \
- "${grub_config}" >"${tmp}"
- # Do NOT fail here, only warn.
- /sbin/grub --batch \
- --device-map="${dir}"/device.map \
- >/dev/null <"${tmp}"
- rc=$?
- [[ $rc -ne 0 ]] && ewarn "Grub failed to run!"
- fi
-
- # the grub default commands silently piss themselves if
- # the default file does not exist ahead of time
- if [[ ! -e ${dir}/default ]] ; then
- # This may fail, don't worry about it.
- grub-set-default --root-directory="${boot_dir}" default
- fi
- einfo "Grub has been installed to ${boot_dir} successfully."
-}
-
-pkg_postinst() {
- mount-boot_mount_boot_partition
-
- if [[ -n ${DONT_MOUNT_BOOT} ]]; then
- elog "WARNING: you have DONT_MOUNT_BOOT in effect, so you must apply"
- elog "the following instructions for your /boot!"
- elog "Neglecting to do so may cause your system to fail to boot!"
- elog
- else
- setup_boot_dir "${ROOT}"/boot
- # Trailing output because if this is run from pkg_postinst, it gets mixed into
- # the other output.
- einfo ""
- fi
- elog "To interactively install grub files to another device such as a USB"
- elog "stick, just run the following and specify the directory as prompted:"
- elog " emerge --config =${PF}"
- elog "Alternately, you can export GRUB_ALT_INSTALLDIR=/path/to/use to tell"
- elog "grub where to install in a non-interactive way."
-
- # needs to be after we call setup_boot_dir
- mount-boot_pkg_postinst
-}
-
-pkg_config() {
- local dir
- if [ ! -d "${GRUB_ALT_INSTALLDIR}" ]; then
- einfo "Enter the directory where you want to setup grub:"
- read dir
- else
- dir="${GRUB_ALT_INSTALLDIR}"
- fi
- setup_boot_dir "${dir}"
-}
diff --git a/sys-boot/grub-static/grub-static-0.97-r9.ebuild b/sys-boot/grub-static/grub-static-0.97-r9.ebuild
deleted file mode 100644
index 47441893ef6b..000000000000
--- a/sys-boot/grub-static/grub-static-0.97-r9.ebuild
+++ /dev/null
@@ -1,173 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=0
-
-# XXX: we need to review menu.lst vs grub.conf handling. We've been converting
-# all systems to grub.conf (and symlinking menu.lst to grub.conf), but
-# we never updated any of the source code (it still all wants menu.lst),
-# and there is no indication that upstream is making the transition.
-
-inherit eutils mount-boot toolchain-funcs linux-info
-
-PATCHVER="1.9" # Not used, just for tracking with main grub
-
-DESCRIPTION="GNU GRUB Legacy boot loader (static build)"
-
-HOMEPAGE="https://www.gnu.org/software/grub/"
-SRC_URI="mirror://gentoo/${PF}.tar.bz2"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="-* amd64 x86"
-IUSE=""
-DEPEND="!<sys-boot/grub-2"
-RDEPEND="${DEPEND}"
-
-# These are already stripped since we use a binpkg.
-QA_PRESTRIPPED="/sbin/grub /bin/mbchk"
-
-pkg_setup() {
- local arch="$(tc-arch)"
- case ${arch} in
- amd64)
- CONFIG_CHECK='~IA32_EMULATION'
- WARNING_IA32_EMULATION="You will NOT be able to run grub unless you have IA32_EMULATION set!"
- check_extra_config
- ;;
- esac
-}
-
-src_install() {
- cp -a "${WORKDIR}"/* "${D}"/
- run_test_grub "${D}"/sbin/grub && einfo "New grub can run on your system, good!"
-}
-
-run_test_grub() {
- local grub="$1"
- local version="$(${grub} \
- --read-only --no-pager --no-floppy --no-curses \
- --no-config-file --batch --version)"
- local error="grub test-run failed"
- use amd64 && error="${error} Is IA32_EMULATION set?"
- [ "${version/${PV}}" != "${version}" ] || die "${error}"
- return 0
-}
-
-#
-# Below this point, everything is also used in grub-static!
-# Please keep in sync!
-#
-
-setup_boot_dir() {
- local boot_dir=$1
- local dir=${boot_dir}
-
- run_test_grub /sbin/grub
-
- mkdir -p "${dir}"
- [[ ! -L ${dir}/boot ]] && ln -s . "${dir}/boot"
- dir="${dir}/grub"
- if [[ ! -e ${dir} ]] ; then
- mkdir "${dir}" || die "${dir} does not exist!"
- fi
-
- # change menu.lst to grub.conf
- if [[ ! -e ${dir}/grub.conf ]] && [[ -e ${dir}/menu.lst ]] ; then
- mv -f "${dir}"/menu.lst "${dir}"/grub.conf
- ewarn
- ewarn "*** IMPORTANT NOTE: menu.lst has been renamed to grub.conf"
- ewarn
- fi
-
- if [[ ! -e ${dir}/menu.lst ]]; then
- einfo "Linking from new grub.conf name to menu.lst"
- ln -snf grub.conf "${dir}"/menu.lst
- fi
-
- if [[ -e ${dir}/stage2 ]] ; then
- mv "${dir}"/stage2{,.old}
- ewarn "*** IMPORTANT NOTE: you must run grub and install"
- ewarn "the new version's stage1 to your MBR. Until you do,"
- ewarn "stage1 and stage2 will still be the old version, but"
- ewarn "later stages will be the new version, which could"
- ewarn "cause problems such as an unbootable system."
- ewarn "This means you must use either grub-install or perform"
- ewarn "root/setup manually! For more help, see the handbook:"
- ewarn "https://www.gentoo.org/doc/en/handbook/handbook-${ARCH}.xml?part=1&chap=10#grub-install-auto"
- ebeep
- fi
-
- einfo "Copying files from /lib/grub, /usr/lib/grub and /usr/share/grub to ${dir}"
- for x in \
- "${ROOT}"/lib*/grub/*/* \
- "${ROOT}"/usr/lib*/grub/*/* \
- "${ROOT}"/usr/share/grub/* ; do
- [[ -f ${x} ]] && cp -p "${x}" "${dir}"/
- done
-
- if [[ ! -e ${dir}/grub.conf ]] ; then
- s="${ROOT}/usr/share/doc/${PF}/grub.conf.gentoo"
- [[ -e "${s}" ]] && cat "${s}" >${dir}/grub.conf
- [[ -e "${s}.gz" ]] && zcat "${s}.gz" >${dir}/grub.conf
- [[ -e "${s}.bz2" ]] && bzcat "${s}.bz2" >${dir}/grub.conf
- fi
-
- # Per bug 218599, we support grub.conf.install for users that want to run a
- # specific set of Grub setup commands rather than the default ones.
- grub_config=${dir}/grub.conf.install
- [[ -e ${grub_config} ]] || grub_config=${dir}/grub.conf
- if [[ -e ${grub_config} ]] ; then
- local tmp="${TMPDIR}/${P}-setup_boot_dir-$$"
- egrep \
- -v '^[[:space:]]*(#|$|default|fallback|initrd|password|splashimage|timeout|title)' \
- "${grub_config}" >"${tmp}"
- # Do NOT fail here, only warn.
- /sbin/grub --batch \
- --device-map="${dir}"/device.map \
- >/dev/null <"${tmp}"
- rc=$?
- [[ $rc -ne 0 ]] && ewarn "Grub failed to run!"
- fi
-
- # the grub default commands silently piss themselves if
- # the default file does not exist ahead of time
- if [[ ! -e ${dir}/default ]] ; then
- # This may fail, don't worry about it.
- grub-set-default --root-directory="${boot_dir}" default
- :
- fi
- einfo "Grub has been installed to ${boot_dir} successfully."
-}
-
-pkg_postinst() {
- mount-boot_pkg_postinst
-
- if [[ -n ${DONT_MOUNT_BOOT} ]]; then
- elog "WARNING: you have DONT_MOUNT_BOOT in effect, so you must apply"
- elog "the following instructions for your /boot!"
- elog "Neglecting to do so may cause your system to fail to boot!"
- elog
- else
- setup_boot_dir "${ROOT}"/boot
- # Trailing output because if this is run from pkg_postinst, it gets mixed into
- # the other output.
- einfo ""
- fi
- elog "To interactively install grub files to another device such as a USB"
- elog "stick, just run the following and specify the directory as prompted:"
- elog " emerge --config =${PF}"
- elog "Alternately, you can export GRUB_ALT_INSTALLDIR=/path/to/use to tell"
- elog "grub where to install in a non-interactive way."
-
-}
-
-pkg_config() {
- local dir
- if [ ! -d "${GRUB_ALT_INSTALLDIR}" ]; then
- einfo "Enter the directory where you want to setup grub:"
- read dir
- else
- dir="${GRUB_ALT_INSTALLDIR}"
- fi
- setup_boot_dir "${dir}"
-}
diff --git a/sys-boot/grub-static/metadata.xml b/sys-boot/grub-static/metadata.xml
deleted file mode 100644
index 0c723031cff1..000000000000
--- a/sys-boot/grub-static/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="project">
- <email>amd64@gentoo.org</email>
- <name>AMD64 Project</name>
-</maintainer>
-</pkgmetadata>