summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2021-09-14 10:00:46 -0400
committerMike Gilbert <floppym@gentoo.org>2021-09-14 10:01:57 -0400
commit3bd87a8adfebcc22f55823568418f7cb4365a245 (patch)
tree3aa4a914684cc8f9581fb30b62b8ec903502da9b /sys-boot
parentdev-python/pytest-xvfb: enable py3.10, cleanup python_test (diff)
downloadgentoo-3bd87a8adfebcc22f55823568418f7cb4365a245.tar.gz
gentoo-3bd87a8adfebcc22f55823568418f7cb4365a245.tar.bz2
gentoo-3bd87a8adfebcc22f55823568418f7cb4365a245.zip
sys-boot/grub: document global variables
Bug: https://bugs.gentoo.org/813037 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/grub/grub-2.06-r1.ebuild13
-rw-r--r--sys-boot/grub/grub-9999.ebuild13
2 files changed, 26 insertions, 0 deletions
diff --git a/sys-boot/grub/grub-2.06-r1.ebuild b/sys-boot/grub/grub-2.06-r1.ebuild
index 09e5054052a6..932676d67fd8 100644
--- a/sys-boot/grub/grub-2.06-r1.ebuild
+++ b/sys-boot/grub/grub-2.06-r1.ebuild
@@ -3,6 +3,19 @@
EAPI=7
+# This ebuild uses 3 special global variables:
+# GRUB_BOOTSTRAP: Depend on python and invoke bootstrap (gnulib).
+# GRUB_AUTOGEN: Depend on python and invoke the autogen.sh.
+# GRUB_AUTORECONF: Inherit autotools and invoke eautoreconf.
+#
+# When applying patches:
+# If gnulib is updated, set GRUB_BOOTSTRAP=1
+# If *.def is updated, set GRUB_AUTOGEN=1
+# If gnulib, *.def, or any autotools files are updated, set GRUB_AUTORECONF=1
+#
+# If any of the above applies to a user patch, the user should set the
+# corresponding variable in make.conf or the environment.
+
if [[ ${PV} == 9999 ]]; then
GRUB_AUTORECONF=1
GRUB_BOOTSTRAP=1
diff --git a/sys-boot/grub/grub-9999.ebuild b/sys-boot/grub/grub-9999.ebuild
index 119378453e6b..7ba93a504196 100644
--- a/sys-boot/grub/grub-9999.ebuild
+++ b/sys-boot/grub/grub-9999.ebuild
@@ -3,6 +3,19 @@
EAPI=7
+# This ebuild uses 3 special global variables:
+# GRUB_BOOTSTRAP: Depend on python and invoke bootstrap (gnulib).
+# GRUB_AUTOGEN: Depend on python and invoke the autogen.sh.
+# GRUB_AUTORECONF: Inherit autotools and invoke eautoreconf.
+#
+# When applying patches:
+# If gnulib is updated, set GRUB_BOOTSTRAP=1
+# If *.def is updated, set GRUB_AUTOGEN=1
+# If gnulib, *.def, or any autotools files are updated, set GRUB_AUTORECONF=1
+#
+# If any of the above applies to a user patch, the user should set the
+# corresponding variable in make.conf or the environment.
+
if [[ ${PV} == 9999 ]]; then
GRUB_AUTORECONF=1
GRUB_BOOTSTRAP=1