summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-11-23 05:00:54 +0000
committerSam James <sam@gentoo.org>2020-11-23 05:00:54 +0000
commit8d3b254fc21d48751b4fb814cc88ce39595d3aa2 (patch)
tree0629df4e49b219901fc073436b420f2c5c2908b3 /sys-boot
parentsys-boot/raspberrypi-firmware: cleanup old (diff)
downloadgentoo-8d3b254fc21d48751b4fb814cc88ce39595d3aa2.tar.gz
gentoo-8d3b254fc21d48751b4fb814cc88ce39595d3aa2.tar.bz2
gentoo-8d3b254fc21d48751b4fb814cc88ce39595d3aa2.zip
sys-boot/raspberrypi-firmware: QA & style fixups
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/raspberrypi-firmware/raspberrypi-firmware-1.20201022.ebuild61
-rw-r--r--sys-boot/raspberrypi-firmware/raspberrypi-firmware-9999.ebuild61
2 files changed, 60 insertions, 62 deletions
diff --git a/sys-boot/raspberrypi-firmware/raspberrypi-firmware-1.20201022.ebuild b/sys-boot/raspberrypi-firmware/raspberrypi-firmware-1.20201022.ebuild
index b2767ce80518..7fe926ad7820 100644
--- a/sys-boot/raspberrypi-firmware/raspberrypi-firmware-1.20201022.ebuild
+++ b/sys-boot/raspberrypi-firmware/raspberrypi-firmware-1.20201022.ebuild
@@ -5,17 +5,6 @@ EAPI=7
inherit mount-boot readme.gentoo-r1
-DESCRIPTION="Raspberry Pi (all versions) bootloader and GPU firmware"
-HOMEPAGE="https://github.com/raspberrypi/firmware"
-LICENSE="GPL-2 raspberrypi-videocore-bin"
-SLOT="0"
-
-# Temporary safety measure to prevent ending up with a pair of
-# sys-kernel/raspberrypi-image and sys-boot/raspberrypi-firmware
-# none of which installed device tree files.
-# Remove when the mentioned version and all older ones are deleted.
-RDEPEND="!<=sys-kernel/raspberrypi-image-4.19.57_p20190709"
-
if [[ "${PV}" == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/raspberrypi/firmware"
@@ -26,30 +15,20 @@ else
S="${WORKDIR}/firmware-${PV}"
fi
+DESCRIPTION="Raspberry Pi (all versions) bootloader and GPU firmware"
+HOMEPAGE="https://github.com/raspberrypi/firmware"
+
+LICENSE="GPL-2 raspberrypi-videocore-bin"
+SLOT="0"
RESTRICT="binchecks strip"
-pkg_preinst() {
- if [ -z "${REPLACING_VERSIONS}" ] ; then
- local msg=""
- if [ -e "${D}"/boot/cmdline.txt -a -e /boot/cmdline.txt ] ; then
- msg+="/boot/cmdline.txt "
- fi
- if [ -e "${D}"/boot/config.txt -a -e /boot/config.txt ] ; then
- msg+="/boot/config.txt "
- fi
- if [ -n "${msg}" ] ; then
- msg="This package installs following files: ${msg}."
- msg="${msg} Please remove(backup) your copies durning install"
- msg="${msg} and merge settings afterwards."
- msg="${msg} Further updates will be CONFIG_PROTECTed."
- die "${msg}"
- fi
- fi
-}
+DOC_CONTENTS="Please configure your ram setup by editing /boot/config.txt"
src_prepare() {
default
+
cp "${FILESDIR}"/${PN}-1.20201022-config.txt "${WORKDIR}" || die
+
if use arm64; then
# Force selection of the 64-bit kernel8.img to match our userland
echo "arm_64bit=1" >> "${WORKDIR}"/${PN}-1.20201022-config.txt || die
@@ -66,8 +45,28 @@ src_install() {
readme.gentoo_create_doc
}
+pkg_preinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]] ; then
+ local msg=""
+
+ if [[ -e "${ED}"/boot/cmdline.txt ]] && [[ -e /boot/cmdline.txt ]] ; then
+ msg+="/boot/cmdline.txt "
+ fi
+
+ if [[ -e "${ED}"/boot/config.txt ]] && [[ -e /boot/config.txt ]] ; then
+ msg+="/boot/config.txt "
+ fi
+
+ if [[ -n "${msg}" ]] ; then
+ msg="This package installs following files: ${msg}."
+ msg="${msg} Please remove (backup) your copies durning install"
+ msg="${msg} and merge settings afterwards."
+ msg="${msg} Further updates will be CONFIG_PROTECTed."
+ die "${msg}"
+ fi
+ fi
+}
+
pkg_postinst() {
readme.gentoo_print_elog
}
-
-DOC_CONTENTS="Please configure your ram setup by editing /boot/config.txt"
diff --git a/sys-boot/raspberrypi-firmware/raspberrypi-firmware-9999.ebuild b/sys-boot/raspberrypi-firmware/raspberrypi-firmware-9999.ebuild
index b2767ce80518..7fe926ad7820 100644
--- a/sys-boot/raspberrypi-firmware/raspberrypi-firmware-9999.ebuild
+++ b/sys-boot/raspberrypi-firmware/raspberrypi-firmware-9999.ebuild
@@ -5,17 +5,6 @@ EAPI=7
inherit mount-boot readme.gentoo-r1
-DESCRIPTION="Raspberry Pi (all versions) bootloader and GPU firmware"
-HOMEPAGE="https://github.com/raspberrypi/firmware"
-LICENSE="GPL-2 raspberrypi-videocore-bin"
-SLOT="0"
-
-# Temporary safety measure to prevent ending up with a pair of
-# sys-kernel/raspberrypi-image and sys-boot/raspberrypi-firmware
-# none of which installed device tree files.
-# Remove when the mentioned version and all older ones are deleted.
-RDEPEND="!<=sys-kernel/raspberrypi-image-4.19.57_p20190709"
-
if [[ "${PV}" == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/raspberrypi/firmware"
@@ -26,30 +15,20 @@ else
S="${WORKDIR}/firmware-${PV}"
fi
+DESCRIPTION="Raspberry Pi (all versions) bootloader and GPU firmware"
+HOMEPAGE="https://github.com/raspberrypi/firmware"
+
+LICENSE="GPL-2 raspberrypi-videocore-bin"
+SLOT="0"
RESTRICT="binchecks strip"
-pkg_preinst() {
- if [ -z "${REPLACING_VERSIONS}" ] ; then
- local msg=""
- if [ -e "${D}"/boot/cmdline.txt -a -e /boot/cmdline.txt ] ; then
- msg+="/boot/cmdline.txt "
- fi
- if [ -e "${D}"/boot/config.txt -a -e /boot/config.txt ] ; then
- msg+="/boot/config.txt "
- fi
- if [ -n "${msg}" ] ; then
- msg="This package installs following files: ${msg}."
- msg="${msg} Please remove(backup) your copies durning install"
- msg="${msg} and merge settings afterwards."
- msg="${msg} Further updates will be CONFIG_PROTECTed."
- die "${msg}"
- fi
- fi
-}
+DOC_CONTENTS="Please configure your ram setup by editing /boot/config.txt"
src_prepare() {
default
+
cp "${FILESDIR}"/${PN}-1.20201022-config.txt "${WORKDIR}" || die
+
if use arm64; then
# Force selection of the 64-bit kernel8.img to match our userland
echo "arm_64bit=1" >> "${WORKDIR}"/${PN}-1.20201022-config.txt || die
@@ -66,8 +45,28 @@ src_install() {
readme.gentoo_create_doc
}
+pkg_preinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]] ; then
+ local msg=""
+
+ if [[ -e "${ED}"/boot/cmdline.txt ]] && [[ -e /boot/cmdline.txt ]] ; then
+ msg+="/boot/cmdline.txt "
+ fi
+
+ if [[ -e "${ED}"/boot/config.txt ]] && [[ -e /boot/config.txt ]] ; then
+ msg+="/boot/config.txt "
+ fi
+
+ if [[ -n "${msg}" ]] ; then
+ msg="This package installs following files: ${msg}."
+ msg="${msg} Please remove (backup) your copies durning install"
+ msg="${msg} and merge settings afterwards."
+ msg="${msg} Further updates will be CONFIG_PROTECTed."
+ die "${msg}"
+ fi
+ fi
+}
+
pkg_postinst() {
readme.gentoo_print_elog
}
-
-DOC_CONTENTS="Please configure your ram setup by editing /boot/config.txt"