summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-08-20 01:05:10 +0100
committerSam James <sam@gentoo.org>2022-08-20 01:05:27 +0100
commitca1e8709753d3ebc87a120ee254fb3ece618b0fb (patch)
treea12c8b3f3ad01fa057527b8414d1b00fac10a8c3 /sys-boot
parentapp-emulation/virt-manager: sort DEPEND (diff)
downloadgentoo-ca1e8709753d3ebc87a120ee254fb3ece618b0fb.tar.gz
gentoo-ca1e8709753d3ebc87a120ee254fb3ece618b0fb.tar.bz2
gentoo-ca1e8709753d3ebc87a120ee254fb3ece618b0fb.zip
sys-boot/palo: add 2.22
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/palo/Manifest1
-rw-r--r--sys-boot/palo/palo-2.22.ebuild49
-rw-r--r--sys-boot/palo/palo-9999.ebuild2
3 files changed, 51 insertions, 1 deletions
diff --git a/sys-boot/palo/Manifest b/sys-boot/palo/Manifest
index 2bc5869eabcf..a0d1226bc976 100644
--- a/sys-boot/palo/Manifest
+++ b/sys-boot/palo/Manifest
@@ -1,3 +1,4 @@
DIST palo-2.14.tar.gz 125207 BLAKE2B fcbc7e59552d83828c07acb055429c1155b738dd12e22c9fc81759b9f84382e3ea793e957421d420c93fa5818d5ad8f12b5317cfe6d5d45d95fc15b272c6fe8c SHA512 9d22ea2826a69a9bb661a4c17aaa78d648f0684b96c2dc0f164d2086f48fc85207e40c69227dd76d153dd171574dd62f6e5e90dd415209de372b4d7d8ab40f57
DIST palo-2.15.tar.gz 126696 BLAKE2B 38e9defd248fc3e1f9bd921097e0888695a6a815a4221f4b030f225712f206b722232d05f5070b7a76763c50f8a623bb1a3f41c5c84a3999318f3a098d665b14 SHA512 bb46308988399028808d801317421da5a072a504e1c932513a80ee993653f45bd6cbb862c1b85c369506bca3c5d213bf8344ba263fae7ef13d8f73d9d3a6d412
DIST palo-2.16.tar.gz 126696 BLAKE2B 06da7401d555eb0a468241e2fd71174ebfbe0b3d80d8758e65dfb57831f211dfc77128c4f3babb08ff0f99eafaec58e086751311936ee1a78a569dec50b574e2 SHA512 82f8bfe23e4722e3ee12a51b2c8691720fdc6caab368c294b0069435ba5ed07ac3e582c815bfce58fe320dd18d850bc7b1891e532429427e3735c82e32659360
+DIST palo-2.22.tar.gz 130037 BLAKE2B bbca5662ecc0d67bb8af478ee67f5d872888170b0072d6b2620b3c6ca61e52f6519209b620ffb1dfc40d1e746b522dc89118e292fd5cb78e9f3ba7eec7277a2b SHA512 817bf2dc40d01464aa943cd5495950b89196628f2ef002f6334bbc526515d9e4885532821bf18134b7d4b3adbd20d850ee2d6c2350a663f432d567ac56ef7a90
diff --git a/sys-boot/palo/palo-2.22.ebuild b/sys-boot/palo/palo-2.22.ebuild
new file mode 100644
index 000000000000..9f304fe83eaf
--- /dev/null
+++ b/sys-boot/palo/palo-2.22.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="PALO: PArisc Linux Loader"
+HOMEPAGE="https://parisc.wiki.kernel.org/"
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://git.kernel.org/pub/scm/linux/kernel/git/deller/palo.git"
+ inherit git-r3
+else
+ SRC_URI="https://git.kernel.org/pub/scm/linux/kernel/git/deller/${PN}.git/snapshot/${P}.tar.gz"
+ KEYWORDS="-* ~hppa"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.00-toolchain.patch
+)
+
+src_compile() {
+ local target
+ for target in '-C palo' '-C ipl' 'iplboot'; do
+ emake AR="$(tc-getAR)" CC="$(tc-getCC)" LD="$(tc-getLD)" ${target}
+ done
+}
+
+src_install() {
+ into /
+ dosbin palo/palo
+
+ insinto /usr/share/palo
+ doins iplboot
+
+ insinto /etc
+ doins "${FILESDIR}"/palo.conf
+
+ insinto /etc/kernel/postinst.d
+ insopts -m 0744
+ doins "${FILESDIR}"/99palo
+
+ doman palo.8
+
+ dodoc TODO debian/changelog README.html
+}
diff --git a/sys-boot/palo/palo-9999.ebuild b/sys-boot/palo/palo-9999.ebuild
index 2956c2939a97..9f304fe83eaf 100644
--- a/sys-boot/palo/palo-9999.ebuild
+++ b/sys-boot/palo/palo-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit toolchain-funcs