summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2018-01-07 17:16:02 +0100
committerUlrich Müller <ulm@gentoo.org>2018-01-07 17:22:37 +0100
commitdb8c3313d3e87dae284b1d2032c989b6f956035b (patch)
treec7c4fe52951b41cb7e4b8616ae5a9eb73bbd2682 /sys-boot
parentapp-text/poppler: Drop old (diff)
downloadgentoo-db8c3313d3e87dae284b1d2032c989b6f956035b.tar.gz
gentoo-db8c3313d3e87dae284b1d2032c989b6f956035b.tar.bz2
gentoo-db8c3313d3e87dae284b1d2032c989b6f956035b.zip
sys-boot/unetbootin: Test LINGUAS rather than linguas_* USE flags.
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/unetbootin/unetbootin-625.ebuild10
-rw-r--r--sys-boot/unetbootin/unetbootin-647.ebuild10
-rw-r--r--sys-boot/unetbootin/unetbootin-655.ebuild10
-rw-r--r--sys-boot/unetbootin/unetbootin-657.ebuild10
4 files changed, 12 insertions, 28 deletions
diff --git a/sys-boot/unetbootin/unetbootin-625.ebuild b/sys-boot/unetbootin/unetbootin-625.ebuild
index f6884665740b..aabc1aa868d7 100644
--- a/sys-boot/unetbootin/unetbootin-625.ebuild
+++ b/sys-boot/unetbootin/unetbootin-625.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -19,10 +19,6 @@ UNBI_LINGUAS="
zh_CN zh_TW
"
-for lingua in ${UNBI_LINGUAS}; do
- IUSE="${IUSE} linguas_${lingua}"
-done
-
S=${WORKDIR}/${P}/src/${PN}
DEPEND="dev-qt/qtgui:4"
@@ -52,7 +48,7 @@ src_prepare() {
# Remove localisations
local lingua
for lingua in ${UNBI_LINGUAS}; do
- if ! use linguas_${lingua}; then
+ if ! has ${lingua} ${LINGUAS-${lingua}}; then
sed -i ${PN}.pro -e "/\.*${PN}_${lingua}\.ts.*/d" || die
rm ${PN}_${lingua}.ts || die
fi
@@ -82,7 +78,7 @@ src_install() {
local lingua
for lingua in ${UNBI_LINGUAS}; do
- if use linguas_${lingua}; then
+ if has ${lingua} ${LINGUAS-${lingua}}; then
insinto /usr/share/${PN}
doins ${PN}_${lingua}.qm
fi
diff --git a/sys-boot/unetbootin/unetbootin-647.ebuild b/sys-boot/unetbootin/unetbootin-647.ebuild
index e449aefee55a..0371e75f2c8a 100644
--- a/sys-boot/unetbootin/unetbootin-647.ebuild
+++ b/sys-boot/unetbootin/unetbootin-647.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -19,10 +19,6 @@ UNBI_LINGUAS="
zh_CN zh_TW
"
-for lingua in ${UNBI_LINGUAS}; do
- IUSE="${IUSE} linguas_${lingua}"
-done
-
S=${WORKDIR}/${P}/src/${PN}
DEPEND="dev-qt/qtgui:4"
@@ -51,7 +47,7 @@ src_prepare() {
# Remove localisations
local lingua
for lingua in ${UNBI_LINGUAS}; do
- if ! use linguas_${lingua}; then
+ if ! has ${lingua} ${LINGUAS-${lingua}}; then
sed -i ${PN}.pro -e "/\.*${PN}_${lingua}\.ts.*/d" || die
rm ${PN}_${lingua}.ts || die
fi
@@ -81,7 +77,7 @@ src_install() {
local lingua
for lingua in ${UNBI_LINGUAS}; do
- if use linguas_${lingua}; then
+ if has ${lingua} ${LINGUAS-${lingua}}; then
insinto /usr/share/${PN}
doins ${PN}_${lingua}.qm
fi
diff --git a/sys-boot/unetbootin/unetbootin-655.ebuild b/sys-boot/unetbootin/unetbootin-655.ebuild
index 453496db6670..1007cc620a17 100644
--- a/sys-boot/unetbootin/unetbootin-655.ebuild
+++ b/sys-boot/unetbootin/unetbootin-655.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -19,10 +19,6 @@ UNBI_LINGUAS="
zh_CN zh_TW
"
-for lingua in ${UNBI_LINGUAS}; do
- IUSE="${IUSE} linguas_${lingua}"
-done
-
S=${WORKDIR}/${P}/src/${PN}
DEPEND="dev-qt/qtgui:4"
@@ -50,7 +46,7 @@ src_prepare() {
# Remove localisations
local lingua
for lingua in ${UNBI_LINGUAS}; do
- if ! use linguas_${lingua}; then
+ if ! has ${lingua} ${LINGUAS-${lingua}}; then
sed -i ${PN}.pro -e "/\.*${PN}_${lingua}\.ts.*/d" || die
rm ${PN}_${lingua}.ts || die
fi
@@ -80,7 +76,7 @@ src_install() {
local lingua
for lingua in ${UNBI_LINGUAS}; do
- if use linguas_${lingua}; then
+ if has ${lingua} ${LINGUAS-${lingua}}; then
insinto /usr/share/${PN}
doins ${PN}_${lingua}.qm
fi
diff --git a/sys-boot/unetbootin/unetbootin-657.ebuild b/sys-boot/unetbootin/unetbootin-657.ebuild
index 453496db6670..1007cc620a17 100644
--- a/sys-boot/unetbootin/unetbootin-657.ebuild
+++ b/sys-boot/unetbootin/unetbootin-657.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -19,10 +19,6 @@ UNBI_LINGUAS="
zh_CN zh_TW
"
-for lingua in ${UNBI_LINGUAS}; do
- IUSE="${IUSE} linguas_${lingua}"
-done
-
S=${WORKDIR}/${P}/src/${PN}
DEPEND="dev-qt/qtgui:4"
@@ -50,7 +46,7 @@ src_prepare() {
# Remove localisations
local lingua
for lingua in ${UNBI_LINGUAS}; do
- if ! use linguas_${lingua}; then
+ if ! has ${lingua} ${LINGUAS-${lingua}}; then
sed -i ${PN}.pro -e "/\.*${PN}_${lingua}\.ts.*/d" || die
rm ${PN}_${lingua}.ts || die
fi
@@ -80,7 +76,7 @@ src_install() {
local lingua
for lingua in ${UNBI_LINGUAS}; do
- if use linguas_${lingua}; then
+ if has ${lingua} ${LINGUAS-${lingua}}; then
insinto /usr/share/${PN}
doins ${PN}_${lingua}.qm
fi