summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-05-13 15:50:53 +0200
committerDavid Seifert <soap@gentoo.org>2021-05-13 15:50:53 +0200
commite8655e9d56d2b46ebb0e105e47009e25bcc85bca (patch)
treee46005627f86410cfd3035be66870d4b7b862619 /sys-boot
parentsys-libs/pwdb: add missing virtual/pkgconfig DEPEND (diff)
downloadgentoo-e8655e9d56d2b46ebb0e105e47009e25bcc85bca.tar.gz
gentoo-e8655e9d56d2b46ebb0e105e47009e25bcc85bca.tar.bz2
gentoo-e8655e9d56d2b46ebb0e105e47009e25bcc85bca.zip
sys-boot/efibootmgr: add missing virtual/pkgconfig (B)DEPEND
Found using: $(grep -rsn -L -e "virtual/pkgconfig" | xargs grep "tc-getPKG_CONFIG") Signed-off-by: Sam James <sam@gentoo.org> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/efibootmgr/efibootmgr-16.ebuild7
-rw-r--r--sys-boot/efibootmgr/efibootmgr-17.ebuild1
2 files changed, 6 insertions, 2 deletions
diff --git a/sys-boot/efibootmgr/efibootmgr-16.ebuild b/sys-boot/efibootmgr/efibootmgr-16.ebuild
index 35c97346021d..d16655fc906e 100644
--- a/sys-boot/efibootmgr/efibootmgr-16.ebuild
+++ b/sys-boot/efibootmgr/efibootmgr-16.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -16,7 +16,10 @@ IUSE=""
RDEPEND="sys-apps/pciutils
>=sys-libs/efivar-25:="
-DEPEND="${RDEPEND}"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
src_prepare() {
default
diff --git a/sys-boot/efibootmgr/efibootmgr-17.ebuild b/sys-boot/efibootmgr/efibootmgr-17.ebuild
index a6d695bcfe73..73e20c997bb1 100644
--- a/sys-boot/efibootmgr/efibootmgr-17.ebuild
+++ b/sys-boot/efibootmgr/efibootmgr-17.ebuild
@@ -18,6 +18,7 @@ RDEPEND="
>=sys-libs/efivar-37:=
"
DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
PATCHES=(
"${FILESDIR}/${P}-fix-efivar-37-conflict.patch"