summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-06-02 19:03:41 -0700
committerMatt Turner <mattst88@gentoo.org>2020-06-02 19:05:46 -0700
commitffdc2a3d24da099fce0afb76f9f6d2c8d2a5a254 (patch)
tree80c5aed8afb348d37efcb4f7ed3617b5218cce18 /sys-boot
parentwww-client/firefox-bin: bump to v77.0 (diff)
downloadgentoo-ffdc2a3d24da099fce0afb76f9f6d2c8d2a5a254.tar.gz
gentoo-ffdc2a3d24da099fce0afb76f9f6d2c8d2a5a254.tar.bz2
gentoo-ffdc2a3d24da099fce0afb76f9f6d2c8d2a5a254.zip
sys-boot/silo: Version bump to 1.4.14_p20200602
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/silo/Manifest1
-rw-r--r--sys-boot/silo/metadata.xml3
-rw-r--r--sys-boot/silo/silo-1.4.14_p20200602.ebuild65
3 files changed, 69 insertions, 0 deletions
diff --git a/sys-boot/silo/Manifest b/sys-boot/silo/Manifest
index e0c4be194e0b..70de039c9579 100644
--- a/sys-boot/silo/Manifest
+++ b/sys-boot/silo/Manifest
@@ -1,3 +1,4 @@
DIST silo-1.4.14_p20170829.tar.gz 183612 BLAKE2B 88fb4b0ce4e9b8fa9518bcb6226f4fe9ec7011bf3f73d9f0f1562ff837217ca8d54ee783eed0b50096b009fc56527be8e4211623f5b0e4ef5372c38c0fe304f1 SHA512 bda31084ba2ee5b01d331fd390cbccf039dc812debe25f3af97dd5d2855668cbe7e160dee4ca45c16af1fa4aa86224daf3b474fd49b22a8b7f453584a12f3c2b
+DIST silo-1.4.14_p20200602.tar.gz 183668 BLAKE2B e229cdb9fbc5f0111aa49919f4b3b91c0770492fa06f91bda15c65af160b728b9409365c3ff0a93091b1e3011c60d0b0bec1101ffabaddbaef7e1083158830b1 SHA512 7a70fe25c1bb3ce655e4fbb85b00fe0d29fe0a6f98b80c1b8267b72bc9324ac0749cd050921163cc286e094f7d9bc81315d63ff02d2442b5c30ce350a537fcc1
DIST silo_1.4.14+git20120819-1.diff.gz 10711 BLAKE2B c44a0204e3aece4eec8355f88b3a195c1ba7019c0aa648cc4e28ff6cb85fc6d96634bd282e5aaea9123dbc5835820acf2fc15054c91842d6b1040fc13cb0033b SHA512 60719b672a0f1dd2a005e763efd232bbf7aeb00198e0b46827208b78f1b32acc3a730d43944382dec4b95fddfbb373b1eb69dc911ad28ec9d1d1e6c45d84db20
DIST silo_1.4.14+git20120819.orig.tar.gz 755510 BLAKE2B f1185086671c12c901704c2aa1f582a4e983d2d4a2d5ec18194aebcd43a7bdf9e7ad329efebaf4911d40f8a417ff8c8566b61be4eac5fea13235ac44d0edf852 SHA512 2d1dd8f805fb0a272877b5e8e19e5a645aa9fe02cf2b5ef43b5d2894c0c6a5a82483a0e41556af50f01dc795dc5e43350ae92139485c19d64cda75c2aca01a38
diff --git a/sys-boot/silo/metadata.xml b/sys-boot/silo/metadata.xml
index fd1c35f8fbe2..a2966fc65e1a 100644
--- a/sys-boot/silo/metadata.xml
+++ b/sys-boot/silo/metadata.xml
@@ -8,4 +8,7 @@
<longdescription>
SILO is the SPARC/UltraSPARC Improved Loader, a boot loader for sparc similar to LILO.
</longdescription>
+<use>
+ <flag name="tilo-only">Install only the tilo netboot tool</flag>
+</use>
</pkgmetadata>
diff --git a/sys-boot/silo/silo-1.4.14_p20200602.ebuild b/sys-boot/silo/silo-1.4.14_p20200602.ebuild
new file mode 100644
index 000000000000..deeed7b293d6
--- /dev/null
+++ b/sys-boot/silo/silo-1.4.14_p20200602.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit mount-boot flag-o-matic toolchain-funcs vcs-snapshot
+
+MY_SNAPSHOT="${PN}-9277bfd433e398d0a6eabec79edead52d4cb8125"
+
+DESCRIPTION="SPARC/UltraSPARC Improved Loader, a boot loader for sparc"
+SRC_URI="https://git.kernel.org/pub/scm/linux/kernel/git/davem/silo.git/snapshot/${MY_SNAPSHOT}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="https://git.kernel.org/?p=linux/kernel/git/davem/silo.git;a=summary"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="-* ~sparc"
+IUSE="tilo-only"
+
+DEPEND="sys-fs/e2fsprogs
+ sys-apps/sparc-utils"
+RDEPEND=""
+
+src_prepare() {
+ default
+
+ # Set the correct version
+ sed -i -e "s/1.4.14/1.4.14_git20200602/g" Rules.make || die
+
+ # Fix build failure
+ sed -i -e "s/-fno-strict-aliasing/-fno-strict-aliasing -mcpu=v9/g" Rules.make || die
+
+ # Don't strip ieee32.b during compile
+ sed -i -e '/^ $(STRIP) ieee32.b/d' first/Makefile || die
+}
+
+src_compile() {
+ filter-flags "-fstack-protector"
+
+ CC="$(tc-getCC)" \
+ STRIP="$(tc-getSTRIP)" \
+ NM="$(tc-getNM)" \
+ LD="$(tc-getLD)" \
+ emake $(usex tilo-only '-C tilo' '')
+}
+
+src_install() {
+ default
+
+ dodoc first-isofs/README.SILO_ISOFS docs/README*
+
+ # Fix maketilo manpage
+ rm "${D}"/usr/share/man/man1/maketilo.1
+ dosym tilo.1 /usr/share/man/man1/maketilo.1
+}
+
+pkg_postinst() {
+ use tilo-only && return
+
+ mount-boot_pkg_postinst
+ ewarn "NOTE: If this is an upgrade to an existing SILO install,"
+ ewarn " you will need to re-run silo as the /boot/second.b"
+ ewarn " file has changed, else the system will fail to load"
+ ewarn " SILO at the next boot."
+ ewarn
+}