summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2018-08-07 21:38:34 +0200
committerPatrick McLean <chutzpah@gentoo.org>2018-08-07 16:36:45 -0700
commit2baf0a29ab0bcbaefba5a966346f2628237e3610 (patch)
tree64af5db32a7b2d917df779baaf90c8e78922adea /sys-cluster/ceph/files
parentnet-wireless/ubertooth: bump (diff)
downloadgentoo-2baf0a29ab0bcbaefba5a966346f2628237e3610.tar.gz
gentoo-2baf0a29ab0bcbaefba5a966346f2628237e3610.tar.bz2
gentoo-2baf0a29ab0bcbaefba5a966346f2628237e3610.zip
sys-cluster/ceph: remove unused patches
Closes: https://github.com/gentoo/gentoo/pull/9495
Diffstat (limited to 'sys-cluster/ceph/files')
-rw-r--r--sys-cluster/ceph/files/ceph-10.2.9-filestore_fix_infinit_loops_in_fiemap.patch82
-rw-r--r--sys-cluster/ceph/files/ceph-10.2.9-libradosstriper_fix_format_injection_vulnerability.patch35
-rw-r--r--sys-cluster/ceph/files/ceph-10.2.9-librbd_filter_expected_error_codes_from_is_exclusive_lock_owner.patch28
-rw-r--r--sys-cluster/ceph/files/ceph-10.2.9-osd-scrub_to_specifies_clone_ver_but_transaction_include.patch39
-rw-r--r--sys-cluster/ceph/files/ceph-10.2.9-rbd-do_not_attempt_to_load_key_if_auth_is_disabled.patch39
-rw-r--r--sys-cluster/ceph/files/ceph-10.2.9-rbd-nbd_relax_size_check_for_newer_kernel_versions.patch28
-rw-r--r--sys-cluster/ceph/files/ceph-10.2.9-unlock_sdata_op_ordering_lock_with_sdata_lock.patch32
-rw-r--r--sys-cluster/ceph/files/ceph-12.2.2-build-without-radosgw.patch34
-rw-r--r--sys-cluster/ceph/files/ceph-12.2.4-boost-sonames.patch152
-rw-r--r--sys-cluster/ceph/files/ceph.confd-r28
-rw-r--r--sys-cluster/ceph/files/ceph.initd-r449
-rw-r--r--sys-cluster/ceph/files/ceph.initd-r587
-rw-r--r--sys-cluster/ceph/files/ceph.initd-r687
13 files changed, 0 insertions, 700 deletions
diff --git a/sys-cluster/ceph/files/ceph-10.2.9-filestore_fix_infinit_loops_in_fiemap.patch b/sys-cluster/ceph/files/ceph-10.2.9-filestore_fix_infinit_loops_in_fiemap.patch
deleted file mode 100644
index e67113e51cc8..000000000000
--- a/sys-cluster/ceph/files/ceph-10.2.9-filestore_fix_infinit_loops_in_fiemap.patch
+++ /dev/null
@@ -1,82 +0,0 @@
-From b52bfe6b443f0ff88c8614441752102058063699 Mon Sep 17 00:00:00 2001
-From: Ning Yao <yaoning@unitedstack.com>
-Date: Thu, 6 Apr 2017 11:12:04 +0000
-Subject: [PATCH] os/filestore: fix infinit loops in fiemap()
-
-since fiemap can get extents based on offset --> len
-but we should consider last extents is retrieved when len == 0
-even though it is not last fiemap extents
-
-Signed-off-by: Ning Yao <yaoning@unitedstack.com>
-(cherry picked from commit 36f6b668a8910d76847674086cbc86910c78faee)
----
- src/os/filestore/FileStore.cc | 13 +++++--------
- src/test/objectstore/store_test.cc | 21 +++++++++++++++++++++
- 2 files changed, 26 insertions(+), 8 deletions(-)
-
-diff --git a/src/os/filestore/FileStore.cc b/src/os/filestore/FileStore.cc
-index c47b0d0d2eae..95f48cdf4960 100644
---- a/src/os/filestore/FileStore.cc
-+++ b/src/os/filestore/FileStore.cc
-@@ -3102,17 +3102,14 @@ int FileStore::_do_fiemap(int fd, uint64_t offset, size_t len,
- i++;
- last = extent++;
- }
-- const bool is_last = last->fe_flags & FIEMAP_EXTENT_LAST;
-+ uint64_t xoffset = last->fe_logical + last->fe_length - offset;
-+ offset = last->fe_logical + last->fe_length;
-+ len -= xoffset;
-+ const bool is_last = (last->fe_flags & FIEMAP_EXTENT_LAST) || (len == 0);
-+ free(fiemap);
- if (!is_last) {
-- uint64_t xoffset = last->fe_logical + last->fe_length - offset;
-- offset = last->fe_logical + last->fe_length;
-- len -= xoffset;
-- free(fiemap); /* fix clang warn: use-after-free */
- goto more;
- }
-- else {
-- free(fiemap);
-- }
-
- return r;
- }
-diff --git a/src/test/objectstore/store_test.cc b/src/test/objectstore/store_test.cc
-index 5ab011ad17d8..4cada7e2e435 100644
---- a/src/test/objectstore/store_test.cc
-+++ b/src/test/objectstore/store_test.cc
-@@ -279,6 +279,7 @@ TEST_P(StoreTest, FiemapHoles) {
- ASSERT_EQ(r, 0);
- }
- {
-+ //fiemap test from 0 to SKIP_STEP * (MAX_EXTENTS - 1) + 3
- bufferlist bl;
- store->fiemap(cid, oid, 0, SKIP_STEP * (MAX_EXTENTS - 1) + 3, bl);
- map<uint64_t,uint64_t> m, e;
-@@ -295,6 +296,26 @@ TEST_P(StoreTest, FiemapHoles) {
- ASSERT_TRUE((m.size() == 1 &&
- m[0] > SKIP_STEP * (MAX_EXTENTS - 1)) ||
- (m.size() == MAX_EXTENTS && extents_exist));
-+
-+ // fiemap test from SKIP_STEP to SKIP_STEP * (MAX_EXTENTS - 2) + 3
-+ // reset bufferlist and map
-+ bl.clear();
-+ m.clear();
-+ e.clear();
-+ store->fiemap(cid, oid, SKIP_STEP, SKIP_STEP * (MAX_EXTENTS - 2) + 3, bl);
-+ p = bl.begin();
-+ ::decode(m, p);
-+ cout << " got " << m << std::endl;
-+ ASSERT_TRUE(!m.empty());
-+ ASSERT_GE(m[SKIP_STEP], 3u);
-+ extents_exist = true;
-+ if (m.size() == (MAX_EXTENTS - 2)) {
-+ for (uint64_t i = 1; i < MAX_EXTENTS - 1; i++)
-+ extents_exist = extents_exist && m.count(SKIP_STEP*i);
-+ }
-+ ASSERT_TRUE((m.size() == 1 &&
-+ m[SKIP_STEP] > SKIP_STEP * (MAX_EXTENTS - 2)) ||
-+ (m.size() == (MAX_EXTENTS - 1) && extents_exist));
- }
- {
- ObjectStore::Transaction t;
diff --git a/sys-cluster/ceph/files/ceph-10.2.9-libradosstriper_fix_format_injection_vulnerability.patch b/sys-cluster/ceph/files/ceph-10.2.9-libradosstriper_fix_format_injection_vulnerability.patch
deleted file mode 100644
index eaf18c35783d..000000000000
--- a/sys-cluster/ceph/files/ceph-10.2.9-libradosstriper_fix_format_injection_vulnerability.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-diff --git a/src/libradosstriper/RadosStriperImpl.cc b/src/libradosstriper/RadosStriperImpl.cc
-index 22352d9125..70dcb7569f 100644
---- a/src/libradosstriper/RadosStriperImpl.cc
-+++ b/src/libradosstriper/RadosStriperImpl.cc
-@@ -12,6 +12,8 @@
- *
- */
-
-+#include <boost/algorithm/string/replace.hpp>
-+
- #include "libradosstriper/RadosStriperImpl.h"
-
- #include <errno.h>
-@@ -466,7 +468,9 @@ int libradosstriper::RadosStriperImpl::aio_read(const std::string& soid,
- // get list of extents to be read from
- vector<ObjectExtent> *extents = new vector<ObjectExtent>();
- if (read_len > 0) {
-- std::string format = soid + RADOS_OBJECT_EXTENSION_FORMAT;
-+ std::string format = soid;
-+ boost::replace_all(format, "%", "%%");
-+ format += RADOS_OBJECT_EXTENSION_FORMAT;
- file_layout_t l;
- l.from_legacy(layout);
- Striper::file_to_extents(cct(), format.c_str(), &l, off, read_len,
-@@ -776,7 +780,9 @@ libradosstriper::RadosStriperImpl::internal_aio_write(const std::string& soid,
- if (len > 0) {
- // get list of extents to be written to
- vector<ObjectExtent> extents;
-- std::string format = soid + RADOS_OBJECT_EXTENSION_FORMAT;
-+ std::string format = soid;
-+ boost::replace_all(format, "%", "%%");
-+ format += RADOS_OBJECT_EXTENSION_FORMAT;
- file_layout_t l;
- l.from_legacy(layout);
- Striper::file_to_extents(cct(), format.c_str(), &l, off, len, 0, extents);
diff --git a/sys-cluster/ceph/files/ceph-10.2.9-librbd_filter_expected_error_codes_from_is_exclusive_lock_owner.patch b/sys-cluster/ceph/files/ceph-10.2.9-librbd_filter_expected_error_codes_from_is_exclusive_lock_owner.patch
deleted file mode 100644
index 6800285318f0..000000000000
--- a/sys-cluster/ceph/files/ceph-10.2.9-librbd_filter_expected_error_codes_from_is_exclusive_lock_owner.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From 787ba33e5dba285dff874955a8f0d7aabd3f87fe Mon Sep 17 00:00:00 2001
-From: Jason Dillaman <dillaman@redhat.com>
-Date: Mon, 5 Jun 2017 08:17:05 -0400
-Subject: [PATCH] librbd: filter expected error codes from
- is_exclusive_lock_owner
-
-Fixes: http://tracker.ceph.com/issues/20182
-Signed-off-by: Jason Dillaman <dillaman@redhat.com>
-(cherry picked from commit d4daaf54e6bc42cd4fb2111ea20b2042941b0c31)
----
- src/librbd/internal.cc | 4 +++-
- 1 file changed, 3 insertions(+), 1 deletion(-)
-
-diff --git a/src/librbd/internal.cc b/src/librbd/internal.cc
-index 9fecb1e1688f..6021be078090 100644
---- a/src/librbd/internal.cc
-+++ b/src/librbd/internal.cc
-@@ -2110,7 +2110,9 @@ int mirror_image_disable_internal(ImageCtx *ictx, bool force,
- // might have been blacklisted by peer -- ensure we still own
- // the lock by pinging the OSD
- int r = ictx->exclusive_lock->assert_header_locked();
-- if (r < 0) {
-+ if (r == -EBUSY || r == -ENOENT) {
-+ return 0;
-+ } else if (r < 0) {
- return r;
- }
-
diff --git a/sys-cluster/ceph/files/ceph-10.2.9-osd-scrub_to_specifies_clone_ver_but_transaction_include.patch b/sys-cluster/ceph/files/ceph-10.2.9-osd-scrub_to_specifies_clone_ver_but_transaction_include.patch
deleted file mode 100644
index 8bf14c2944ba..000000000000
--- a/sys-cluster/ceph/files/ceph-10.2.9-osd-scrub_to_specifies_clone_ver_but_transaction_include.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-From 153f77544118613e19d5e88c030c3901234cf950 Mon Sep 17 00:00:00 2001
-From: David Zafman <dzafman@redhat.com>
-Date: Tue, 18 Jul 2017 15:08:14 -0700
-Subject: [PATCH] osd: scrub_to specifies clone ver, but transaction include
- head write ver
-
-Fixes: http://tracker.ceph.com/issues/20041
-
-Signed-off-by: David Zafman <dzafman@redhat.com>
-(cherry picked from commit fd598a0d23d61c645633ae774c3404a43d035e3c)
-
-Conflicts:
- src/osd/ReplicatedPG.cc (trivial)
----
- src/osd/ReplicatedPG.cc | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/src/osd/ReplicatedPG.cc b/src/osd/ReplicatedPG.cc
-index 4b4dc34c602a..4d80ad1770e1 100644
---- a/src/osd/ReplicatedPG.cc
-+++ b/src/osd/ReplicatedPG.cc
-@@ -8318,7 +8318,7 @@ void ReplicatedPG::op_applied(const eversion_t &applied_version)
- last_update_applied = applied_version;
- if (is_primary()) {
- if (scrubber.active) {
-- if (last_update_applied == scrubber.subset_last_update) {
-+ if (last_update_applied >= scrubber.subset_last_update) {
- requeue_scrub();
- }
- } else {
-@@ -8326,7 +8326,7 @@ void ReplicatedPG::op_applied(const eversion_t &applied_version)
- }
- } else {
- if (scrubber.active_rep_scrub) {
-- if (last_update_applied == static_cast<MOSDRepScrub*>(
-+ if (last_update_applied >= static_cast<MOSDRepScrub*>(
- scrubber.active_rep_scrub->get_req())->scrub_to) {
- osd->op_wq.queue(
- make_pair(
diff --git a/sys-cluster/ceph/files/ceph-10.2.9-rbd-do_not_attempt_to_load_key_if_auth_is_disabled.patch b/sys-cluster/ceph/files/ceph-10.2.9-rbd-do_not_attempt_to_load_key_if_auth_is_disabled.patch
deleted file mode 100644
index 4b03e335bc58..000000000000
--- a/sys-cluster/ceph/files/ceph-10.2.9-rbd-do_not_attempt_to_load_key_if_auth_is_disabled.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-From 0cd7df3649d7486d444a61cab89c48a89ddd3e8d Mon Sep 17 00:00:00 2001
-From: Jason Dillaman <dillaman@redhat.com>
-Date: Thu, 29 Jun 2017 14:54:40 -0400
-Subject: [PATCH] rbd: do not attempt to load key if auth is disabled
-
-Fixes: http://tracker.ceph.com/issues/19035
-Signed-off-by: Jason Dillaman <dillaman@redhat.com>
-(cherry picked from commit 8b9c8df6d7f0b75c5451953bb322bc1f9afb6299)
----
- src/krbd.cc | 16 +++++++++-------
- 1 file changed, 9 insertions(+), 7 deletions(-)
-
-diff --git a/src/krbd.cc b/src/krbd.cc
-index a0e546fa7f6f..2bb6b4270abd 100644
---- a/src/krbd.cc
-+++ b/src/krbd.cc
-@@ -129,13 +129,15 @@ static int build_map_buf(CephContext *cct, const char *pool, const char *image,
- oss << " name=" << cct->_conf->name.get_id();
-
- KeyRing keyring;
-- r = keyring.from_ceph_context(cct);
-- if (r == -ENOENT && !(cct->_conf->keyfile.length() ||
-- cct->_conf->key.length()))
-- r = 0;
-- if (r < 0) {
-- cerr << "rbd: failed to get secret" << std::endl;
-- return r;
-+ if (cct->_conf->auth_client_required != "none") {
-+ r = keyring.from_ceph_context(cct);
-+ if (r == -ENOENT && !(cct->_conf->keyfile.length() ||
-+ cct->_conf->key.length()))
-+ r = 0;
-+ if (r < 0) {
-+ cerr << "rbd: failed to get secret" << std::endl;
-+ return r;
-+ }
- }
-
- CryptoKey secret;
diff --git a/sys-cluster/ceph/files/ceph-10.2.9-rbd-nbd_relax_size_check_for_newer_kernel_versions.patch b/sys-cluster/ceph/files/ceph-10.2.9-rbd-nbd_relax_size_check_for_newer_kernel_versions.patch
deleted file mode 100644
index 5cb89be0edf1..000000000000
--- a/sys-cluster/ceph/files/ceph-10.2.9-rbd-nbd_relax_size_check_for_newer_kernel_versions.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-diff --git a/src/tools/rbd_nbd/rbd-nbd.cc b/src/tools/rbd_nbd/rbd-nbd.cc
-index 2e399ab832..88e1e0ff65 100644
---- a/src/tools/rbd_nbd/rbd-nbd.cc
-+++ b/src/tools/rbd_nbd/rbd-nbd.cc
-@@ -469,6 +469,10 @@ static int open_device(const char* path, bool try_load_moudle = false)
-
- static int check_device_size(int nbd_index, unsigned long expected_size)
- {
-+ // There are bugs with some older kernel versions that result in an
-+ // overflow for large image sizes. This check is to ensure we are
-+ // not affected.
-+
- unsigned long size = 0;
- std::string path = "/sys/block/nbd" + stringify(nbd_index) + "/size";
- std::ifstream ifs;
-@@ -480,6 +484,12 @@ static int check_device_size(int nbd_index, unsigned long expected_size)
- ifs >> size;
- size *= RBD_NBD_BLKSIZE;
-
-+ if (size == 0) {
-+ // Newer kernel versions will report real size only after nbd
-+ // connect. Assume this is the case and return success.
-+ return 0;
-+ }
-+
- if (size != expected_size) {
- cerr << "rbd-nbd: kernel reported invalid device size (" << size
- << ", expected " << expected_size << ")" << std::endl;
diff --git a/sys-cluster/ceph/files/ceph-10.2.9-unlock_sdata_op_ordering_lock_with_sdata_lock.patch b/sys-cluster/ceph/files/ceph-10.2.9-unlock_sdata_op_ordering_lock_with_sdata_lock.patch
deleted file mode 100644
index 60f46ab36a40..000000000000
--- a/sys-cluster/ceph/files/ceph-10.2.9-unlock_sdata_op_ordering_lock_with_sdata_lock.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From 3fa277b479d69699bf5a6875cd4a5efcf9ae0788 Mon Sep 17 00:00:00 2001
-From: Alexey Sheplyakov <asheplyakov@mirantis.com>
-Date: Tue, 27 Jun 2017 16:07:01 +0400
-Subject: [PATCH] jewel: osd: unlock sdata_op_ordering_lock with sdata_lock
- hold to avoid missing wakeup signal
-
-Based on commit bc683385819146f3f6f096ceec97e1226a3cd237. The OSD code has
-been refactored a lot since Jewel, hence cherry-picking that patch introduces
-a lot of unrelated changes, and is much more difficult than reusing the idea.
-
-Fixes: http://tracker.ceph.com/issues/20428
-
-Signed-off-by: Alexey Sheplyakov <asheplyakov@mirantis.com>
----
- src/osd/OSD.cc | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/osd/OSD.cc b/src/osd/OSD.cc
-index f5cfda3b686a..38a2711f6f92 100644
---- a/src/osd/OSD.cc
-+++ b/src/osd/OSD.cc
-@@ -8727,9 +8727,9 @@ void OSD::ShardedOpWQ::_process(uint32_t thread_index, heartbeat_handle_d *hb )
- assert(NULL != sdata);
- sdata->sdata_op_ordering_lock.Lock();
- if (sdata->pqueue->empty()) {
-- sdata->sdata_op_ordering_lock.Unlock();
- osd->cct->get_heartbeat_map()->reset_timeout(hb, 4, 0);
- sdata->sdata_lock.Lock();
-+ sdata->sdata_op_ordering_lock.Unlock();
- sdata->sdata_cond.WaitInterval(osd->cct, sdata->sdata_lock, utime_t(2, 0));
- sdata->sdata_lock.Unlock();
- sdata->sdata_op_ordering_lock.Lock();
diff --git a/sys-cluster/ceph/files/ceph-12.2.2-build-without-radosgw.patch b/sys-cluster/ceph/files/ceph-12.2.2-build-without-radosgw.patch
deleted file mode 100644
index 29257c4747d6..000000000000
--- a/sys-cluster/ceph/files/ceph-12.2.2-build-without-radosgw.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-From b00ac12f4045cd39ac9a436cf32d233d16bc3485 Mon Sep 17 00:00:00 2001
-From: Jason Dillaman <dillaman@redhat.com>
-Date: Tue, 5 Dec 2017 09:58:04 -0500
-Subject: [PATCH] ceph-dencoder: moved RBD types outside of RGW preprocessor
- guard
-
-Fixes: http://tracker.ceph.com/issues/22321
-Signed-off-by: Jason Dillaman <dillaman@redhat.com>
----
- src/test/encoding/types.h | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/src/test/encoding/types.h b/src/test/encoding/types.h
-index c061e93bd58c..4cfcb15edff1 100644
---- a/src/test/encoding/types.h
-+++ b/src/test/encoding/types.h
-@@ -405,6 +405,8 @@ TYPE(rgw_data_sync_info)
- TYPE(rgw_data_sync_marker)
- TYPE(rgw_data_sync_status)
-
-+#endif
-+
- #ifdef WITH_RBD
- #include "cls/rbd/cls_rbd.h"
- TYPE(cls_rbd_parent)
-@@ -416,8 +418,6 @@ TYPE(cls::rbd::MirrorImage)
- TYPE(cls::rbd::MirrorImageMap)
- #endif
-
--#endif
--
- #include "cls/lock/cls_lock_types.h"
- TYPE(rados::cls::lock::locker_id_t)
- TYPE_FEATUREFUL(rados::cls::lock::locker_info_t)
diff --git a/sys-cluster/ceph/files/ceph-12.2.4-boost-sonames.patch b/sys-cluster/ceph/files/ceph-12.2.4-boost-sonames.patch
deleted file mode 100644
index 59c645dea95c..000000000000
--- a/sys-cluster/ceph/files/ceph-12.2.4-boost-sonames.patch
+++ /dev/null
@@ -1,152 +0,0 @@
-diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
-index 7aa8a4392e..111f669f2e 100644
---- a/src/CMakeLists.txt
-+++ b/src/CMakeLists.txt
-@@ -622,13 +622,13 @@ set(ceph_common_objs
- $<TARGET_OBJECTS:crush_objs>)
- set(ceph_common_deps
- json_spirit erasure_code rt ${LIB_RESOLV}
-- Boost::thread
-- Boost::system
-- Boost::regex
-- Boost::random
-- Boost::program_options
-- Boost::date_time
-- Boost::iostreams
-+ boost_thread
-+ boost_system
-+ boost_regex
-+ boost_random
-+ boost_program_options
-+ boost_date_time
-+ boost_iostreams
- ${BLKID_LIBRARIES}
- ${Backtrace_LIBRARIES}
- ${BLKIN_LIBRARIES}
-@@ -712,7 +712,7 @@ if (WITH_MGR)
- $<TARGET_OBJECTS:heap_profiler_objs>)
- target_include_directories(ceph-mgr PRIVATE "${PYTHON_INCLUDE_DIRS}")
- target_link_libraries(ceph-mgr osdc client global-static common
-- Boost::python ${PYTHON_LIBRARIES} ${BLKID_LIBRARIES} ${CMAKE_DL_LIBS} ${ALLOC_LIBS})
-+ boost_python-${EPYTHON_VERSION} ${PYTHON_LIBRARIES} ${BLKID_LIBRARIES} ${CMAKE_DL_LIBS} ${ALLOC_LIBS})
- install(TARGETS ceph-mgr DESTINATION bin)
- endif (WITH_MGR)
-
-@@ -885,7 +885,7 @@ set(ceph_mds_srcs
- ceph_mds.cc)
- add_executable(ceph-mds ${ceph_mds_srcs})
- target_link_libraries(ceph-mds mds ${CMAKE_DL_LIBS} global-static common
-- Boost::thread)
-+ boost_thread)
- install(TARGETS ceph-mds DESTINATION bin)
-
- add_subdirectory(erasure-code)
-diff --git a/src/test/CMakeLists.txt b/src/test/CMakeLists.txt
-index f3999e3b01..0ce7fca1ba 100644
---- a/src/test/CMakeLists.txt
-+++ b/src/test/CMakeLists.txt
-@@ -148,7 +148,7 @@ add_executable(ceph_omapbench
- )
- target_link_libraries(ceph_omapbench
- librados
-- Boost::program_options
-+ boost_program_options
- global
- ${BLKID_LIBRARIES}
- ${CMAKE_DL_LIBS}
-@@ -202,7 +202,7 @@ if(${WITH_RADOSGW})
- cls_rgw_client
- cls_user_client
- cls_lock_client
-- Boost::regex
-+ boost_regex
- ${BLKID_LIBRARIES}
- ${CURL_LIBRARIES}
- ${EXPAT_LIBRARIES}
-@@ -232,7 +232,7 @@ if(${WITH_RADOSGW})
- cls_rgw_client
- cls_user_client
- cls_lock_client
-- Boost::regex
-+ boost_regex
- ${BLKID_LIBRARIES}
- ${CURL_LIBRARIES}
- ${EXPAT_LIBRARIES}
-diff --git a/src/test/bench/CMakeLists.txt b/src/test/bench/CMakeLists.txt
-index 9fba701e05..da3cbcfe96 100644
---- a/src/test/bench/CMakeLists.txt
-+++ b/src/test/bench/CMakeLists.txt
-@@ -8,7 +8,7 @@ set(smalliobench_srcs
- add_executable(ceph_smalliobench
- ${smalliobench_srcs}
- )
--target_link_libraries(ceph_smalliobench librados Boost::program_options global
-+target_link_libraries(ceph_smalliobench librados boost_program_options global
- ${BLKID_LIBRARIES} ${CMAKE_DL_LIBS})
-
- # ceph_smalliobenchrbd
-@@ -27,7 +27,7 @@ if(WITH_RBD)
- librados
- os
- global
-- Boost::program_options
-+ boost_program_options
- ${BLKID_LIBRARIES}
- ${CMAKE_DL_LIBS}
- )
-@@ -50,7 +50,7 @@ set(ceph_smalliobenchfs_srcs
- add_executable(ceph_smalliobenchfs
- ${ceph_smalliobenchfs_srcs}
- )
--target_link_libraries(ceph_smalliobenchfs librados Boost::program_options os global
-+target_link_libraries(ceph_smalliobenchfs librados boost_program_options os global
- ${BLKID_LIBRARIES} ${CMAKE_DL_LIBS})
-
- # ceph_smalliobenchdumb
-@@ -63,7 +63,7 @@ set(smalliobenchdumb_srcs
- add_executable(ceph_smalliobenchdumb
- ${smalliobenchdumb_srcs}
- )
--target_link_libraries(ceph_smalliobenchdumb librados Boost::program_options os global
-+target_link_libraries(ceph_smalliobenchdumb librados boost_program_options os global
- ${BLKID_LIBRARIES} ${CMAKE_DL_LIBS})
-
- # ceph_tpbench
-@@ -73,7 +73,7 @@ set(tpbench_srcs
- add_executable(ceph_tpbench
- ${tpbench_srcs}
- )
--target_link_libraries(ceph_tpbench librados Boost::program_options global
-+target_link_libraries(ceph_tpbench librados boost_program_options global
- ${BLKID_LIBRARIES} ${CMAKE_DL_LIBS})
-
- install(TARGETS
-diff --git a/src/tools/CMakeLists.txt b/src/tools/CMakeLists.txt
-index 7502085895..1a430c201a 100644
---- a/src/tools/CMakeLists.txt
-+++ b/src/tools/CMakeLists.txt
-@@ -23,13 +23,13 @@ target_link_libraries(ceph_radosacl librados global)
- install(TARGETS ceph_radosacl DESTINATION bin)
-
- add_executable(ceph-osdomap-tool ceph_osdomap_tool.cc)
--target_link_libraries(ceph-osdomap-tool os global Boost::program_options)
-+target_link_libraries(ceph-osdomap-tool os global boost_program_options)
- install(TARGETS ceph-osdomap-tool DESTINATION bin)
-
- add_executable(ceph-monstore-tool
- ceph_monstore_tool.cc
- ../mgr/mgr_commands.cc)
--target_link_libraries(ceph-monstore-tool os global Boost::program_options)
-+target_link_libraries(ceph-monstore-tool os global boost_program_options)
- install(TARGETS ceph-monstore-tool DESTINATION bin)
- install(PROGRAMS
- ceph-monstore-update-crush.sh
-@@ -40,7 +40,7 @@ add_executable(ceph-objectstore-tool
- ceph_objectstore_tool.cc
- rebuild_mondb.cc
- RadosDump.cc)
--target_link_libraries(ceph-objectstore-tool osd os global Boost::program_options ${CMAKE_DL_LIBS})
-+target_link_libraries(ceph-objectstore-tool osd os global boost_program_options ${CMAKE_DL_LIBS})
- if(WITH_FUSE)
- target_link_libraries(ceph-objectstore-tool fuse)
- endif(WITH_FUSE)
diff --git a/sys-cluster/ceph/files/ceph.confd-r2 b/sys-cluster/ceph/files/ceph.confd-r2
deleted file mode 100644
index 13b1cfad4588..000000000000
--- a/sys-cluster/ceph/files/ceph.confd-r2
+++ /dev/null
@@ -1,8 +0,0 @@
-# default ceph conf file
-#ceph_conf="/etc/ceph/ceph.conf"
-
-# Set ulimits for Ceph services.
-rc_ulimit="-n 32768"
-
-# initd stop timeout.
-#CEPH_TERMTIMEOUT="TERM/60/KILL/5"
diff --git a/sys-cluster/ceph/files/ceph.initd-r4 b/sys-cluster/ceph/files/ceph.initd-r4
deleted file mode 100644
index 33e1a3002ac9..000000000000
--- a/sys-cluster/ceph/files/ceph.initd-r4
+++ /dev/null
@@ -1,49 +0,0 @@
-#!/sbin/openrc-run
-
-ceph_conf="${ceph_conf:-/etc/ceph/ceph.conf}"
-extra_commands="reload"
-daemon_type="${RC_SVCNAME#ceph-}"
-daemon_type="${daemon_type%%.*}"
-daemon_id="${RC_SVCNAME#ceph-*.}"
-daemon_id="${daemon_id:-0}"
-command="/usr/bin/ceph-${daemon_type}"
-pidfile="/run/ceph/${daemon_type}.${daemon_id}.pid"
-command_args="-i ${daemon_id} --pid-file ${pidfile} -c ${ceph_conf}"
-start_stop_daemon_args="--user ceph --group ceph"
-retry="${CEPH_TERMTIMEOUT:-TERM/60/KILL/5}"
-
-depend() {
- after net ntpd ntp-client chronyd
- before netmount
-}
-
-is_type_valid() {
- case ${daemon_type} in
- mon|mds|osd) return 0;;
- *) return 1;;
- esac
-}
-
-start_pre() {
- export CEPH_CONF="${ceph_conf}"
-
- checkpath -d -q -o ceph "$(dirname "${pidfile}")"
-
- if ! is_type_valid ;then
- eerror "Please give valid Ceph Server Type: mds, mon, osd"
- return 1
- fi
-
- if pgrep -f "[c]eph-${daemon_type} -i ${daemon_id} "; then
- eerror "${daemon_type}.${daemon_id} is still running, refusing to start"
- return 1
- fi
-}
-
-reload() {
- ebegin "Reloading Ceph ${daemon_type}.${daemon_id}"
- start-stop-daemon --signal 1 ${start_stop_daemon_args} --pidfile "${pidfile}"
- eend $?
-}
-
-# vim:ft=gentoo-init-d:ts=4:sts=4:sw=4:noet:
diff --git a/sys-cluster/ceph/files/ceph.initd-r5 b/sys-cluster/ceph/files/ceph.initd-r5
deleted file mode 100644
index 18f539a57a8f..000000000000
--- a/sys-cluster/ceph/files/ceph.initd-r5
+++ /dev/null
@@ -1,87 +0,0 @@
-#!/sbin/openrc-run
-
-ceph_conf="${ceph_conf:-/etc/ceph/ceph.conf}"
-extra_commands="reload"
-daemon_type="${RC_SVCNAME#ceph-}"
-daemon_type="${daemon_type%%.*}"
-daemon_id="${RC_SVCNAME#ceph-*.}"
-daemon_id="${daemon_id:-0}"
-: ${rundir:=/run/ceph}
-: ${user:=ceph}
-: ${group:=ceph}
-: ${rc_ulimit:=-n 131072 -u 257256}
-
-pidfile="${rundir}/supervisor-${daemon_type}.${daemon_id}.pid"
-daemon_pidfile="${rundir}/${daemon_type}.${daemon_id}.pid"
-
-command="/usr/bin/${RC_SVCNAME%%.*}"
-command_args="-i ${daemon_id} --pid-file ${daemon_pidfile} -c ${ceph_conf}"
-command_args_foreground="--foreground"
-
-retry="${CEPH_TERMTIMEOUT:-TERM/120/KILL/5}"
-start_stop_daemon_args="--user ${user} --group ${group}"
-supervise_daemon_args="--user ${user} --group ${group}"
-
-: ${supervisor:=supervise-daemon}
-: ${stdout:=/dev/null}
-: ${stderr:=/dev/null}
-: ${respawn_delay:=10}
-: ${respawn_max:=5}
-: ${respawn_period:=1800}
-
-: ${osd_respawn_delay:=15}
-: ${osd_respawn_max:=10}
-
-: ${radosgw_respawn_max:=5}
-: ${radosgw_respawn_period:=30}
-
-depend() {
- use dns logger
- after net ntpd ntp-client chronyd
- before netmount
-}
-
-is_type_valid() {
- case ${daemon_type} in
- mon|mds|osd|mgr|radosgw) return 0;;
- *) return 1;;
- esac
-}
-
-start_pre() {
- export CEPH_CONF="${ceph_conf}"
-
- checkpath -d -q -o "${user}:${group}" "${rundir}"
-
- if ! is_type_valid ;then
- eerror "Please give valid Ceph Server Type: mds, mon, osd"
- return 1
-
- elif pgrep -f "[c]eph-${daemon_type} -i ${daemon_id} "; then
- eerror "${daemon_type}.${daemon_id} is still running, refusing to start"
- return 1
- fi
-
- local arg_name arg_val
- for arg_name in std{out,err} respawn_{delay,max,period}; do
- eval arg_val="\${${daemon_type}_${arg_name}}"
-
- if [ -z "${arg_val}" ]; then
- eval arg_val="\${${arg_name}}"
- else
- eval "${arg_name}=\"${arg_val}\""
- fi
-
- if [ "${arg_name}" = "stderr" ] || [ "${arg_name}" = "stdout" ]; then
- supervise_daemon_args="${supervise_daemon_args} --${arg_name//_/-}=${arg_val}.${daemon_id}-${arg_name}.log"
- fi
- done
-}
-
-reload() {
- ebegin "Reloading Ceph ${daemon_type}.${daemon_id}"
- start-stop-daemon --signal 1 "${start_stop_daemon_args}"
- eend ${?}
-}
-
-# vim:ft=gentoo-init-d:ts=4:sts=4:sw=4:noet:
diff --git a/sys-cluster/ceph/files/ceph.initd-r6 b/sys-cluster/ceph/files/ceph.initd-r6
deleted file mode 100644
index fd31b17eb5e3..000000000000
--- a/sys-cluster/ceph/files/ceph.initd-r6
+++ /dev/null
@@ -1,87 +0,0 @@
-#!/sbin/openrc-run
-
-ceph_conf="${ceph_conf:-/etc/ceph/ceph.conf}"
-extra_commands="reload"
-daemon_type="${RC_SVCNAME#ceph-}"
-daemon_type="${daemon_type%%.*}"
-daemon_id="${RC_SVCNAME#ceph-*.}"
-daemon_id="${daemon_id:-0}"
-: ${rundir:=/run/ceph}
-: ${user:=ceph}
-: ${group:=ceph}
-: ${rc_ulimit:=-n 1048576 -u 1048576}
-
-pidfile="${rundir}/supervisor-${daemon_type}.${daemon_id}.pid"
-daemon_pidfile="${rundir}/${daemon_type}.${daemon_id}.pid"
-
-command="/usr/bin/${RC_SVCNAME%%.*}"
-command_args="-i ${daemon_id} --pid-file ${daemon_pidfile} -c ${ceph_conf}"
-command_args_foreground="--foreground"
-
-retry="${CEPH_TERMTIMEOUT:-TERM/120/KILL/5}"
-start_stop_daemon_args="--user ${user} --group ${group}"
-supervise_daemon_args="--user ${user} --group ${group}"
-
-: ${supervisor:=supervise-daemon}
-: ${stdout:=/dev/null}
-: ${stderr:=/dev/null}
-: ${respawn_delay:=10}
-: ${respawn_max:=5}
-: ${respawn_period:=1800}
-
-: ${osd_respawn_delay:=15}
-: ${osd_respawn_max:=10}
-
-: ${radosgw_respawn_max:=5}
-: ${radosgw_respawn_period:=30}
-
-depend() {
- use dns logger
- after net ntpd ntp-client chronyd
- before netmount
-}
-
-is_type_valid() {
- case ${daemon_type} in
- mon|mds|osd|mgr|radosgw) return 0;;
- *) return 1;;
- esac
-}
-
-start_pre() {
- export CEPH_CONF="${ceph_conf}"
-
- checkpath -d -q -o "${user}:${group}" "${rundir}"
-
- if ! is_type_valid ;then
- eerror "Please give valid Ceph Server Type: mds, mon, osd"
- return 1
-
- elif pgrep -f "[c]eph-${daemon_type} -i ${daemon_id} "; then
- eerror "${daemon_type}.${daemon_id} is still running, refusing to start"
- return 1
- fi
-
- local arg_name arg_val
- for arg_name in std{out,err} respawn_{delay,max,period}; do
- eval arg_val="\${${daemon_type}_${arg_name}}"
-
- if [ -z "${arg_val}" ]; then
- eval arg_val="\${${arg_name}}"
- else
- eval "${arg_name}=\"${arg_val}\""
- fi
-
- if [ "${arg_name}" = "stderr" ] || [ "${arg_name}" = "stdout" ]; then
- supervise_daemon_args="${supervise_daemon_args} --${arg_name//_/-}=${arg_val}.${daemon_id}-${arg_name}.log"
- fi
- done
-}
-
-reload() {
- ebegin "Reloading Ceph ${daemon_type}.${daemon_id}"
- start-stop-daemon --signal 1 "${start_stop_daemon_args}"
- eend ${?}
-}
-
-# vim:ft=gentoo-init-d:ts=4:sts=4:sw=4:noet: