summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-04-15 16:26:37 -0700
committerPatrick McLean <chutzpah@gentoo.org>2019-04-15 16:26:37 -0700
commit9c1469bcc815ad185bba2b5300887a3a142e8603 (patch)
treea4db38b9888aa68e3dc17fef2e78dab02c33d9f0 /sys-cluster/ceph/files
parentmedia-gfx/argyllcms: 2.1.0 bump (diff)
downloadgentoo-9c1469bcc815ad185bba2b5300887a3a142e8603.tar.gz
gentoo-9c1469bcc815ad185bba2b5300887a3a142e8603.tar.bz2
gentoo-9c1469bcc815ad185bba2b5300887a3a142e8603.zip
sys-cluster/ceph: Revbumps, 681068, 651460, 671482, 682664, 638750
Cleanups for a lot of old bugs that had fallen through the cracks/ Closes: https://bugs.gentoo.org/681068 Closes: https://bugs.gentoo.org/651460 Closes: https://bugs.gentoo.org/671482 Closes: https://bugs.gentoo.org/682664 Closes: https://bugs.gentoo.org/638750 Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'sys-cluster/ceph/files')
-rw-r--r--sys-cluster/ceph/files/ceph-12.2.12-ncurses-tinfo.patch20
-rw-r--r--sys-cluster/ceph/files/ceph-14.2.1-ncurses-tinfo.patch30
2 files changed, 50 insertions, 0 deletions
diff --git a/sys-cluster/ceph/files/ceph-12.2.12-ncurses-tinfo.patch b/sys-cluster/ceph/files/ceph-12.2.12-ncurses-tinfo.patch
new file mode 100644
index 000000000000..1b72e5447dbe
--- /dev/null
+++ b/sys-cluster/ceph/files/ceph-12.2.12-ncurses-tinfo.patch
@@ -0,0 +1,20 @@
+diff --git a/src/tools/rbd/CMakeLists.txt b/src/tools/rbd/CMakeLists.txt
+index 7aa42e9efd..66186b159f 100644
+--- a/src/tools/rbd/CMakeLists.txt
++++ b/src/tools/rbd/CMakeLists.txt
+@@ -1,3 +1,6 @@
++set(CURSES_NEED_NCURSES TRUE)
++find_package(Curses REQUIRED)
++
+ set(rbd_srcs
+ rbd.cc
+ ArgumentTypes.cc
+@@ -46,7 +49,7 @@ target_link_libraries(rbd librbd librados
+ cls_journal_client cls_rbd_client
+ rbd_types
+ journal
+- ceph-common global
++ ceph-common global ${CURSES_LIBRARIES}
+ ${BLKID_LIBRARIES} ${CMAKE_DL_LIBS})
+ if(WITH_KRBD)
+ target_link_libraries(rbd
diff --git a/sys-cluster/ceph/files/ceph-14.2.1-ncurses-tinfo.patch b/sys-cluster/ceph/files/ceph-14.2.1-ncurses-tinfo.patch
new file mode 100644
index 000000000000..7f74a102d777
--- /dev/null
+++ b/sys-cluster/ceph/files/ceph-14.2.1-ncurses-tinfo.patch
@@ -0,0 +1,30 @@
+From b7bf406cff5e0f82fc87f19d5987cd4e719919e1 Mon Sep 17 00:00:00 2001
+From: Lars Wendler <polynomial-c@gentoo.org>
+Date: Mon, 8 Apr 2019 16:34:53 +0200
+Subject: [PATCH] cmake: Fix build against ncurses with separate libtinfo
+
+Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
+---
+ src/tools/rbd/CMakeLists.txt | 5 ++++-
+ 1 file changed, 4 insertions(+), 1 deletion(-)
+
+diff --git a/src/tools/rbd/CMakeLists.txt b/src/tools/rbd/CMakeLists.txt
+index 36b2408a8d28..0e38a033ff55 100644
+--- a/src/tools/rbd/CMakeLists.txt
++++ b/src/tools/rbd/CMakeLists.txt
+@@ -1,3 +1,6 @@
++set(CURSES_NEED_NCURSES TRUE)
++find_package(Curses REQUIRED)
++
+ set(rbd_srcs
+ rbd.cc
+ ArgumentTypes.cc
+@@ -52,7 +55,7 @@ target_link_libraries(rbd librbd librados
+ cls_journal_client cls_rbd_client
+ rbd_types
+ journal
+- ceph-common global ncurses
++ ceph-common global ${CURSES_LIBRARIES}
+ ${BLKID_LIBRARIES} ${CMAKE_DL_LIBS})
+ if(WITH_KRBD)
+ target_link_libraries(rbd