summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-03-28 19:22:17 -0700
committerPatrick McLean <chutzpah@gentoo.org>2019-03-28 19:22:17 -0700
commit4af9cbde3856cdc92a13441e6cceb1f06c067d78 (patch)
tree868486aa968e1952ed58d1af19740562a2b80c27 /sys-cluster/ceph
parentapp-crypt/nwipe: Version bump to 0.25 (diff)
downloadgentoo-4af9cbde3856cdc92a13441e6cceb1f06c067d78.tar.gz
gentoo-4af9cbde3856cdc92a13441e6cceb1f06c067d78.tar.bz2
gentoo-4af9cbde3856cdc92a13441e6cceb1f06c067d78.zip
sys-cluster/ceph: Fix 12.2.11 compile fail on x86 (bug #679414)
Closes: https://bugs.gentoo.org/679414 Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'sys-cluster/ceph')
-rw-r--r--sys-cluster/ceph/ceph-12.2.11.ebuild1
-rw-r--r--sys-cluster/ceph/files/ceph-12.2.11-fix-min-call.patch13
2 files changed, 14 insertions, 0 deletions
diff --git a/sys-cluster/ceph/ceph-12.2.11.ebuild b/sys-cluster/ceph/ceph-12.2.11.ebuild
index d828bc7be4f3..761d8f534952 100644
--- a/sys-cluster/ceph/ceph-12.2.11.ebuild
+++ b/sys-cluster/ceph/ceph-12.2.11.ebuild
@@ -134,6 +134,7 @@ PATCHES=(
"${FILESDIR}/ceph-12.2.4-rocksdb-cflags.patch"
"${FILESDIR}/ceph-12.2.5-no-werror.patch"
"${FILESDIR}/ceph-13.2.2-dont-install-sysvinit-script.patch"
+ "${FILESDIR}/ceph-12.2.11-fix-min-call.patch"
)
check-reqs_export_vars() {
diff --git a/sys-cluster/ceph/files/ceph-12.2.11-fix-min-call.patch b/sys-cluster/ceph/files/ceph-12.2.11-fix-min-call.patch
new file mode 100644
index 000000000000..cd9eb4891cb5
--- /dev/null
+++ b/sys-cluster/ceph/files/ceph-12.2.11-fix-min-call.patch
@@ -0,0 +1,13 @@
+diff --git a/src/osd/PrimaryLogPG.cc b/src/osd/PrimaryLogPG.cc
+index 0074c7964b..98991be7d2 100644
+--- a/src/osd/PrimaryLogPG.cc
++++ b/src/osd/PrimaryLogPG.cc
+@@ -1582,7 +1582,7 @@ void PrimaryLogPG::calc_trim_to()
+ if (limit != eversion_t() &&
+ limit != pg_trim_to &&
+ pg_log.get_log().approx_size() > target) {
+- size_t num_to_trim = std::min(pg_log.get_log().approx_size() - target,
++ size_t num_to_trim = std::min((uint64_t)(pg_log.get_log().approx_size() - target),
+ cct->_conf->osd_pg_log_trim_max);
+ if (num_to_trim < cct->_conf->osd_pg_log_trim_min &&
+ cct->_conf->osd_pg_log_trim_max >= cct->_conf->osd_pg_log_trim_min) {