summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOliver Freyermuth <o.freyermuth@googlemail.com>2019-07-16 23:50:38 +0200
committerMichał Górny <mgorny@gentoo.org>2019-07-18 09:58:31 +0200
commitd9410e9ab65866de556b845fe4837568d86637e1 (patch)
tree77ec401dad5dc7de64d0ceb3ccc03c7e26277331 /sys-cluster/charliecloud/charliecloud-0.10.ebuild
parentdev-python/flask-paginate: verbump to 0.5.3 (diff)
downloadgentoo-d9410e9ab65866de556b845fe4837568d86637e1.tar.gz
gentoo-d9410e9ab65866de556b845fe4837568d86637e1.tar.bz2
gentoo-d9410e9ab65866de556b845fe4837568d86637e1.zip
sys-cluster/charliecloud: Version bump to 0.10
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Oliver Freyermuth <o.freyermuth@googlemail.com> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-cluster/charliecloud/charliecloud-0.10.ebuild')
-rw-r--r--sys-cluster/charliecloud/charliecloud-0.10.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/sys-cluster/charliecloud/charliecloud-0.10.ebuild b/sys-cluster/charliecloud/charliecloud-0.10.ebuild
new file mode 100644
index 000000000000..fdf652c5e31a
--- /dev/null
+++ b/sys-cluster/charliecloud/charliecloud-0.10.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+inherit python-single-r1
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/hpc/${PN}.git"
+ S="${WORKDIR}/${P}"
+else
+ SRC_URI="https://github.com/hpc/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+DESCRIPTION="Lightweight user-defined software stacks for high-performance computing"
+HOMEPAGE="https://hpc.github.io/charliecloud/"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+IUSE="doc examples +pv"
+
+# Extensive test suite exists, but downloads container images
+# directly and via Docker and installs packages inside using apt/yum.
+# Additionally, clashes with portage namespacing and sandbox.
+RESTRICT="test"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ pv? ( sys-apps/pv )
+"
+DEPEND="doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
+ net-misc/rsync
+ )"
+
+PATCHES=(
+ # See upstream bug: https://github.com/hpc/charliecloud/pull/481/
+ "${FILESDIR}"/"${PN}-${PV}"-fix-hardcoded-gcc.patch
+)
+
+src_compile() {
+ emake
+ use doc && emake -C doc-src
+}
+
+src_install() {
+ emake install PREFIX="${EPREFIX}/usr" DESTDIR="${D}" DOCDIR="${ED}/usr/share/doc/${PF}" LIBEXEC_DIR="libexec/${PF}"
+ if use examples; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ dodoc -r examples
+ fi
+ einstalldocs
+}