summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOliver Freyermuth <o.freyermuth@googlemail.com>2021-06-29 21:11:31 +0200
committerNicolas Bock <nicolasbock@gentoo.org>2021-06-30 07:23:39 +0200
commita1e7e1869211d11acc0dc1f6e1923dcd92cb89b4 (patch)
tree7413dd51df5abd4228efa0ed8f0ac7b60a59c973 /sys-cluster/charliecloud
parentsys-cluster/charliecloud: Bump to version 0.24. (diff)
downloadgentoo-a1e7e1869211d11acc0dc1f6e1923dcd92cb89b4.tar.gz
gentoo-a1e7e1869211d11acc0dc1f6e1923dcd92cb89b4.tar.bz2
gentoo-a1e7e1869211d11acc0dc1f6e1923dcd92cb89b4.zip
sys-cluster/charliecloud: Drop old.
Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Oliver Freyermuth <o.freyermuth@googlemail.com> Signed-off-by: Nicolas Bock <nicolasbock@gentoo.org>
Diffstat (limited to 'sys-cluster/charliecloud')
-rw-r--r--sys-cluster/charliecloud/Manifest1
-rw-r--r--sys-cluster/charliecloud/charliecloud-0.22.ebuild80
2 files changed, 0 insertions, 81 deletions
diff --git a/sys-cluster/charliecloud/Manifest b/sys-cluster/charliecloud/Manifest
index b2887b4dba62..f67be3cd9335 100644
--- a/sys-cluster/charliecloud/Manifest
+++ b/sys-cluster/charliecloud/Manifest
@@ -1,3 +1,2 @@
-DIST charliecloud-0.22.tar.gz 402106 BLAKE2B 4c2d4bf77424c5b46e5593bc28bbe10891c353c23c8d382a9ca7515187538f5fef4d90b95f34572f65223f27433ccab9021bf9e4bc31931787894924d1dd02e2 SHA512 c528ffa9ecddbd4a26b0a8b6cc593340f3aaa0911cf45e1f6a5fe860178917f069ca9b31b7c1aee6220762bbe4b75114219eac4cdd3987bcb3f3338e2b6fb18e
DIST charliecloud-0.23.tar.gz 403281 BLAKE2B f7a6824782e7bf3bdb51ae791fdca2f5929f5c713590ff49cc8a7e1e1c1758e83bdd429a99497dd15e565d01f0f66f2873f64edddacf24ea78f68c2326669db7 SHA512 35543ed3d838b80fbb64fe3e658993fe9f7ded2d1dfd92e0e9a7725fab6d872503a790964c0f3fabb6438c8bd872b5b00cdf31a028f26588b318b9d0dc568119
DIST charliecloud-0.24.tar.gz 420852 BLAKE2B ca55231c74012a678c24133b28e341392865a562653086766e6b5e570744f31ce69d1afa2bbb2cc85d5e52b6ed6e9f42f67187d9998afd3852a10fd4a8ff29d3 SHA512 41f44ef5f12dc35d7972923a84044b7255801705d4fcabf76e675dcb70a9f25422e7d584a7b49135ef2ae5dc1751a39efd84f8eb719653a769b41f46bd558fd2
diff --git a/sys-cluster/charliecloud/charliecloud-0.22.ebuild b/sys-cluster/charliecloud/charliecloud-0.22.ebuild
deleted file mode 100644
index a2e756974dbc..000000000000
--- a/sys-cluster/charliecloud/charliecloud-0.22.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8} )
-
-inherit autotools optfeature python-single-r1
-
-if [[ ${PV} == "9999" ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/hpc/${PN}.git"
- S="${WORKDIR}/${P}"
-else
- SRC_URI="https://github.com/hpc/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86 ~x86-linux"
-fi
-
-DESCRIPTION="Lightweight user-defined software stacks for high-performance computing"
-HOMEPAGE="https://hpc.github.io/charliecloud/"
-
-SLOT="0"
-LICENSE="Apache-2.0"
-IUSE="ch-image doc"
-
-# Extensive test suite exists, but downloads container images
-# directly and via Docker and installs packages inside using apt/yum.
-# Additionally, clashes with portage namespacing and sandbox.
-RESTRICT="test"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="${PYTHON_DEPS}"
-DEPEND="
- ch-image? (
- $(python_gen_cond_dep '
- dev-python/lark-parser[${PYTHON_MULTI_USEDEP}]
- dev-python/requests[${PYTHON_MULTI_USEDEP}]
- ')
- )
- doc? (
- $(python_gen_cond_dep '
- dev-python/sphinx[${PYTHON_MULTI_USEDEP}]
- dev-python/sphinx_rtd_theme[${PYTHON_MULTI_USEDEP}]
- ')
- net-misc/rsync
- )"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-0.22-sphinx-4.patch
-)
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- local econf_args=()
- econf_args+=(
- $(use_enable doc html)
- $(use_enable ch-image)
- # Libdir is used as a libexec-style destination.
- --libdir="${EPREFIX}"/usr/lib
- # Attempts to call python-exec directly otherwise.
- --with-sphinx-python=${PYTHON}
- # This disables -Werror, see also: https://github.com/hpc/charliecloud/pull/808
- --enable-buggy-build
- )
- econf "${econf_args[@]}"
-}
-
-pkg_postinst() {
- elog "Various builders are supported, as alternative to the internal ch-image."
- optfeature "Building with Buildah" app-emulation/buildah
- optfeature "Building with Docker" app-emulation/docker
- optfeature "Progress bars during long operations" sys-apps/pv
- optfeature "Pack and unpack squashfs images" sys-fs/squashfs-tools
- optfeature "Mount and umount squashfs images" sys-fs/squashfuse
-}