summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-cluster/cluster-glue/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-cluster/cluster-glue/files')
-rw-r--r--sys-cluster/cluster-glue/files/1.0.12-respect_cflags.patch11
-rw-r--r--sys-cluster/cluster-glue/files/1.0.5-docs.patch40
-rw-r--r--sys-cluster/cluster-glue/files/1.0.5-respect_cflags.patch11
-rw-r--r--sys-cluster/cluster-glue/files/1.0.7-fix_configure.patch13
-rw-r--r--sys-cluster/cluster-glue/files/1.0.9-glib-2.32.patch13
-rw-r--r--sys-cluster/cluster-glue/files/heartbeat-logd.init47
6 files changed, 135 insertions, 0 deletions
diff --git a/sys-cluster/cluster-glue/files/1.0.12-respect_cflags.patch b/sys-cluster/cluster-glue/files/1.0.12-respect_cflags.patch
new file mode 100644
index 000000000000..52a879574ccb
--- /dev/null
+++ b/sys-cluster/cluster-glue/files/1.0.12-respect_cflags.patch
@@ -0,0 +1,11 @@
+--- a/configure.ac 2014-07-23 10:37:39.052887243 +0200
++++ b/configure.ac 2014-07-23 10:37:53.541464249 +0200
+@@ -1226,8 +1226,6 @@
+ CFLAGS="$CFLAGS -g"
+ enable_fatal_warnings=no
+ else
+- CFLAGS="$CFLAGS -ggdb"
+-
+ # We had to eliminate -Wnested-externs because of libtool changes
+ EXTRA_FLAGS="-fgnu89-inline
+ -fstack-protector-all
diff --git a/sys-cluster/cluster-glue/files/1.0.5-docs.patch b/sys-cluster/cluster-glue/files/1.0.5-docs.patch
new file mode 100644
index 000000000000..424c529623f0
--- /dev/null
+++ b/sys-cluster/cluster-glue/files/1.0.5-docs.patch
@@ -0,0 +1,40 @@
+--- doc/Makefile.am
++++ doc/Makefile.am
+@@ -29,11 +29,10 @@
+
+ if BUILD_DOC
+ man_MANS += hb_report.8 ha_logd.8 ha_logger.1 stonith.8 meatclient.8
+-endif
+
+ EXTRA_DIST = $(man_MANS)
+
+-STYLESHEET_PREFIX ?= http://docbook.sourceforge.net/release/xsl/current
++STYLESHEET_PREFIX ?= /usr/share/sgml/docbook/xsl-stylesheets/
+ MANPAGES_STYLESHEET ?= $(STYLESHEET_PREFIX)/manpages/docbook.xsl
+ HTML_STYLESHEET ?= $(STYLESHEET_PREFIX)/xhtml/docbook.xsl
+ FO_STYLESHEET ?= $(STYLESHEET_PREFIX)/fo/docbook.xsl
+@@ -47,3 +46,4 @@
+ $(XSLTPROC) \
+ $(XSLTPROC_MANPAGES_OPTIONS) \
+ $(MANPAGES_STYLESHEET) $<
++endif
+--- configure.ac
++++ configure.ac
+@@ -492,11 +492,13 @@
+ AC_PATH_PROGS(PKGCONFIG, pkg-config)
+ AC_PATH_PROGS(XML2CONFIG, xml2-config)
+
+-AC_PATH_PROGS(XSLTPROC, xsltproc)
+-AM_CONDITIONAL(BUILD_DOC, test "x$XSLTPROC" != "x" )
+-if test "x$XSLTPROC" = "x"; then
+- AC_MSG_WARN([xsltproc not installed, unable to (re-)build manual pages])
++AC_ARG_ENABLE([doc],
++ [ --enable-doc build documentation, [default=no]],
++ [enable_doc=$withval], [enable_doc=no])
++if test "x$enable_doc" != "xno"; then
++ AC_PATH_PROGS(XSLTPROC, xsltproc)
+ fi
++AM_CONDITIONAL(BUILD_DOC, test "x$enable_doc" != "xno" )
+
+ AC_PATH_PROGS(VALGRIND_BIN, valgrind, /usr/bin/valgrind)
+ AC_DEFINE_UNQUOTED(VALGRIND_BIN, "$VALGRIND_BIN", Valgrind command)
diff --git a/sys-cluster/cluster-glue/files/1.0.5-respect_cflags.patch b/sys-cluster/cluster-glue/files/1.0.5-respect_cflags.patch
new file mode 100644
index 000000000000..f89432fc7eed
--- /dev/null
+++ b/sys-cluster/cluster-glue/files/1.0.5-respect_cflags.patch
@@ -0,0 +1,11 @@
+--- configure.ac
++++ configure.ac
+@@ -1149,8 +1149,6 @@
+ CFLAGS="$CFLAGS -g"
+ enable_fatal_warnings=no
+ else
+- CFLAGS="$CFLAGS -ggdb3 -O0"
+-
+ # We had to eliminate -Wnested-externs because of libtool changes
+ EXTRA_FLAGS="-fgnu89-inline
+ -fstack-protector-all
diff --git a/sys-cluster/cluster-glue/files/1.0.7-fix_configure.patch b/sys-cluster/cluster-glue/files/1.0.7-fix_configure.patch
new file mode 100644
index 000000000000..fff85b003322
--- /dev/null
+++ b/sys-cluster/cluster-glue/files/1.0.7-fix_configure.patch
@@ -0,0 +1,13 @@
+Fix enable/disable of libnet
+
+--- a/configure.ac 2010-12-06 18:17:03.000000000 +0100
++++ b/configure.ac 2011-01-11 13:22:16.271977100 +0100
+@@ -928,7 +928,7 @@
+
+ AC_ARG_ENABLE([libnet],
+ [ --enable-libnet Use libnet for ARP based funcationality, [default=try]],
+- [enable_libnet=$withval], [enable_libnet=try])
++ [], [enable_libnet=try])
+
+ libnet=""
+ libnet_version="none"
diff --git a/sys-cluster/cluster-glue/files/1.0.9-glib-2.32.patch b/sys-cluster/cluster-glue/files/1.0.9-glib-2.32.patch
new file mode 100644
index 000000000000..a2dff8341bfd
--- /dev/null
+++ b/sys-cluster/cluster-glue/files/1.0.9-glib-2.32.patch
@@ -0,0 +1,13 @@
+Index: Reusable-Cluster-Components-glue--glue-1.0.9/include/clplumbing/cl_uuid.h
+===================================================================
+--- Reusable-Cluster-Components-glue--glue-1.0.9.orig/include/clplumbing/cl_uuid.h
++++ Reusable-Cluster-Components-glue--glue-1.0.9/include/clplumbing/cl_uuid.h
+@@ -16,7 +16,7 @@
+
+ #ifndef _CL_UUID_H_
+ #define _CL_UUID_H_
+-#include <glib/gtypes.h>
++#include <glib.h>
+
+ typedef struct cl_uuid_s{
+ unsigned char uuid[16];
diff --git a/sys-cluster/cluster-glue/files/heartbeat-logd.init b/sys-cluster/cluster-glue/files/heartbeat-logd.init
new file mode 100644
index 000000000000..60de12026db5
--- /dev/null
+++ b/sys-cluster/cluster-glue/files/heartbeat-logd.init
@@ -0,0 +1,47 @@
+#!/sbin/runscript
+
+PIDFILE=/var/run/heartbeat-logd.pid
+
+depend() {
+ need net
+}
+
+BINARY="/usr/%libdir%/heartbeat/ha_logd"
+USER="hacluster"
+GROUP="haclient"
+CONFIG="/etc/logd.cf"
+LOGFILE="/var/log/ha_logger.log"
+
+start() {
+ ebegin "Starting heartbeat non-blocking log service"
+
+ COMMAND_ARGS="-d"
+ [[ -f "${CONFIG}" ]] && COMMAND_ARGS+=" -c ${CONFIG}"
+
+ if [ -n "${RC_UNAME}" ]; then
+ PARAMS="--background --stdout '${LOGFILE}' --stderr '${LOGFILE}' -- ${ARGS}"
+ else
+ PARAMS="-- ${ARGS} >> '${LOGFILE}' 2>&1 &"
+ fi
+ eval ${CHRT} start-stop-daemon \
+ --quiet --start --chdir "${RUNTIMEDIR}" \
+ --pidfile "${PIDFILE}" \
+ --make-pidfile \
+ --exec ${BINARY} ${COMMAND_ARGS} --chuid "${USER}:${GROUP}" \
+ --nicelevel "${NICELEVEL}" \
+ ${PARAMS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping heartbeat non-blocking log service"
+ start-stop-daemon --stop --retry 3 --quiet --exec "${BINARY}"
+ rm -f "${PIDFILE}"
+ eend $?
+}
+
+restart() {
+ stop
+ sleep 3
+ start
+}