summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2018-03-09 23:33:30 +0000
committerJames Le Cuirot <chewi@gentoo.org>2018-03-09 23:34:49 +0000
commitc4217a516c1e8dc5b04400198f9b0e20a37d0bd0 (patch)
tree0b982094ec4d9e3e758ab4d723b50b4911efcb0f /sys-cluster/glusterfs/glusterfs-9999.ebuild
parentsys-apps/portage: rsync-verify off by default (bug 649276) (diff)
downloadgentoo-c4217a516c1e8dc5b04400198f9b0e20a37d0bd0.tar.gz
gentoo-c4217a516c1e8dc5b04400198f9b0e20a37d0bd0.tar.bz2
gentoo-c4217a516c1e8dc5b04400198f9b0e20a37d0bd0.zip
sys-cluster/glusterfs: Add ipv6 USE flag to control ipv6-default
This is important because ipv6-default breaks Gluster for systems that have IPv6 disabled. A couple of patches were required because --without-ipv6-default is broken and the configure summary is sometimes misleading. Bug: https://bugs.gentoo.org/639838 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'sys-cluster/glusterfs/glusterfs-9999.ebuild')
-rw-r--r--sys-cluster/glusterfs/glusterfs-9999.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/sys-cluster/glusterfs/glusterfs-9999.ebuild b/sys-cluster/glusterfs/glusterfs-9999.ebuild
index 2733e7788033..c48c92ed2f03 100644
--- a/sys-cluster/glusterfs/glusterfs-9999.ebuild
+++ b/sys-cluster/glusterfs/glusterfs-9999.ebuild
@@ -20,10 +20,11 @@ HOMEPAGE="https://www.gluster.org/"
LICENSE="|| ( GPL-2 LGPL-3+ )"
SLOT="0"
-IUSE="bd-xlator crypt-xlator debug emacs +fuse +georeplication glupy infiniband +libtirpc qemu-block rsyslog static-libs +syslog systemtap test +tiering vim-syntax +xml"
+IUSE="bd-xlator crypt-xlator debug emacs +fuse +georeplication glupy infiniband ipv6 +libtirpc qemu-block rsyslog static-libs +syslog systemtap test +tiering vim-syntax +xml"
REQUIRED_USE="georeplication? ( ${PYTHON_REQUIRED_USE} )
- glupy? ( ${PYTHON_REQUIRED_USE} )"
+ glupy? ( ${PYTHON_REQUIRED_USE} )
+ ipv6? ( libtirpc )"
# the tests must be run as root
RESTRICT="test"
@@ -66,6 +67,8 @@ SITEFILE="50${PN}-mode-gentoo.el"
PATCHES=(
"${FILESDIR}/${PN}-3.12.2-poisoned-sysmacros.patch"
"${FILESDIR}/${PN}-4.1.0-silent_rules.patch"
+ "${FILESDIR}/${PN}-without-ipv6-default.patch"
+ "${FILESDIR}/${PN}-TIRPC-config-summary.patch"
)
DOCS=( AUTHORS ChangeLog NEWS README.md THANKS )
@@ -117,7 +120,7 @@ src_configure() {
$(use_enable test cmocka) \
$(use_enable tiering) \
$(use_enable xml xml-output) \
- $(use_with libtirpc ipv6-default) \
+ $(use_with ipv6 ipv6-default) \
$(use_with libtirpc) \
--with-tmpfilesdir="${EPREFIX}"/etc/tmpfiles.d \
--docdir="${EPREFIX}"/usr/share/doc/${PF} \