summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKurt Kanzenbach <kurt@kmk-computers.de>2020-07-12 16:18:09 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-07-24 15:03:30 +0300
commitf29658991e1fd295f10bf26d7a1275eebc43befa (patch)
tree67ff110e6c3bdcae97a833799d902e0ea82dea0d /sys-cluster/hpx
parentmedia-gfx/gscan2pdf: remove old 2.6.7 (diff)
downloadgentoo-f29658991e1fd295f10bf26d7a1275eebc43befa.tar.gz
gentoo-f29658991e1fd295f10bf26d7a1275eebc43befa.tar.bz2
gentoo-f29658991e1fd295f10bf26d7a1275eebc43befa.zip
sys-cluster/hpx: Fix memory requirement
Instead of guessing the number of make jobs, better use the corresponding eclass to get it. Closes: https://bugs.gentoo.org/732274 Package-Manager: Portage-2.3.99, Repoman-2.3.23 Signed-off-by: Kurt Kanzenbach <kurt@kmk-computers.de> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-cluster/hpx')
-rw-r--r--sys-cluster/hpx/hpx-1.4.1.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/sys-cluster/hpx/hpx-1.4.1.ebuild b/sys-cluster/hpx/hpx-1.4.1.ebuild
index 964325329bb6..7206bca40824 100644
--- a/sys-cluster/hpx/hpx-1.4.1.ebuild
+++ b/sys-cluster/hpx/hpx-1.4.1.ebuild
@@ -12,7 +12,7 @@ else
SRC_URI="https://stellar.cct.lsu.edu/files/${PN}_${PV}.tar.gz"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
fi
-inherit cmake fortran-2 python-single-r1 check-reqs
+inherit cmake fortran-2 python-single-r1 check-reqs multiprocessing
DESCRIPTION="C++ runtime system for parallel and distributed applications"
HOMEPAGE="https://stellar.cct.lsu.edu/tag/hpx/"
@@ -65,7 +65,7 @@ hpx_memory_requirement() {
if [[ -z ${MAKEOPTS} ]] ; then
echo "2G"
else
- local jobs=`echo ${MAKEOPTS} | cut -d j -f 2`
+ local jobs=$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")
echo "${jobs}G"
fi
}