summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2019-08-19 16:29:44 +0200
committerManuel Rüger <mrueg@gentoo.org>2019-08-19 16:29:44 +0200
commitc61ebdbebaa75b8037b46127a4837ba6424e5c5a (patch)
treef9231e213b6d4b0d5d88bd757c3fdbffa790a66f /sys-cluster/kube-proxy/kube-proxy-1.14.6.ebuild
parentsys-cluster/kube-proxy: Version bump to 1.13.10 (diff)
downloadgentoo-c61ebdbebaa75b8037b46127a4837ba6424e5c5a.tar.gz
gentoo-c61ebdbebaa75b8037b46127a4837ba6424e5c5a.tar.bz2
gentoo-c61ebdbebaa75b8037b46127a4837ba6424e5c5a.zip
sys-cluster/kube-proxy: Version bump to 1.14.6
Package-Manager: Portage-2.3.72, Repoman-2.3.16 Signed-off-by: Manuel Rüger <mrueg@gentoo.org>
Diffstat (limited to 'sys-cluster/kube-proxy/kube-proxy-1.14.6.ebuild')
-rw-r--r--sys-cluster/kube-proxy/kube-proxy-1.14.6.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/sys-cluster/kube-proxy/kube-proxy-1.14.6.ebuild b/sys-cluster/kube-proxy/kube-proxy-1.14.6.ebuild
new file mode 100644
index 000000000000..f519690e8b2f
--- /dev/null
+++ b/sys-cluster/kube-proxy/kube-proxy-1.14.6.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit golang-build golang-vcs-snapshot
+
+EGO_PN="k8s.io/kubernetes"
+ARCHIVE_URI="https://github.com/kubernetes/kubernetes/archive/v${PV}.tar.gz -> kubernetes-${PV}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Kubernetes Proxy service"
+HOMEPAGE="https://github.com/kubernetes/kubernetes https://kubernetes.io"
+SRC_URI="${ARCHIVE_URI}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+DEPEND="dev-go/go-bindata
+ >=dev-lang/go-1.11"
+
+RDEPEND="net-firewall/conntrack-tools"
+
+RESTRICT="test"
+
+src_prepare() {
+ default
+ sed -i -e "/vendor\/github.com\/jteeuwen\/go-bindata\/go-bindata/d" -e "s/-s -w/-w/" src/${EGO_PN}/hack/lib/golang.sh || die
+ sed -i -e "/export PATH/d" src/${EGO_PN}/hack/generate-bindata.sh || die
+}
+
+src_compile() {
+ LDFLAGS="" GOPATH="${WORKDIR}/${P}" emake -j1 -C src/${EGO_PN} WHAT=cmd/${PN} GOFLAGS=-v
+}
+
+src_install() {
+ pushd src/${EGO_PN} || die
+ dobin _output/bin/${PN}
+ popd || die
+ keepdir /var/log/${PN} /var/lib/${PN}
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/${PN}.logrotated ${PN}
+}