summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <william.hubbs@sony.com>2020-02-18 15:32:50 -0600
committerWilliam Hubbs <williamh@gentoo.org>2020-02-18 15:32:50 -0600
commit80e89db697abdf1c88e518f31fc22326fedbe5e4 (patch)
treefd84cfe552c963ae1b9e7cc3c81aa07a9d9f8456 /sys-cluster/kube-proxy/kube-proxy-1.17.3.ebuild
parentsys-cluster/kube-controller-manager: 1.17.3 bump (diff)
downloadgentoo-80e89db697abdf1c88e518f31fc22326fedbe5e4.tar.gz
gentoo-80e89db697abdf1c88e518f31fc22326fedbe5e4.tar.bz2
gentoo-80e89db697abdf1c88e518f31fc22326fedbe5e4.zip
sys-cluster/kube-proxy: 1.17.3 bump
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'sys-cluster/kube-proxy/kube-proxy-1.17.3.ebuild')
-rw-r--r--sys-cluster/kube-proxy/kube-proxy-1.17.3.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sys-cluster/kube-proxy/kube-proxy-1.17.3.ebuild b/sys-cluster/kube-proxy/kube-proxy-1.17.3.ebuild
new file mode 100644
index 000000000000..db6bdd0cb855
--- /dev/null
+++ b/sys-cluster/kube-proxy/kube-proxy-1.17.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit go-module
+
+DESCRIPTION="Kubernetes Proxy service"
+HOMEPAGE="https://github.com/kubernetes/kubernetes https://kubernetes.io"
+SRC_URI="https://github.com/kubernetes/kubernetes/archive/v${PV}.tar.gz -> kubernetes-${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="dev-go/go-bindata
+ >=dev-lang/go-1.13"
+
+RDEPEND="net-firewall/conntrack-tools"
+
+RESTRICT="test"
+S="${WORKDIR}/kubernetes-${PV}"
+
+src_prepare() {
+ default
+ sed -i -e "/vendor\/github.com\/jteeuwen\/go-bindata\/go-bindata/d" -e "s/-s -w/-w/" hack/lib/golang.sh || die
+ sed -i -e "/export PATH/d" hack/generate-bindata.sh || die
+}
+
+src_compile() {
+ LDFLAGS="" emake -j1 WHAT=cmd/${PN} GOFLAGS=-v
+}
+
+src_install() {
+ dobin _output/bin/${PN}
+ keepdir /var/log/${PN} /var/lib/${PN}
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/${PN}.logrotated ${PN}
+}