summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2020-09-13 15:43:42 -0500
committerWilliam Hubbs <williamh@gentoo.org>2020-09-13 17:12:08 -0500
commit6a2ed20f7ded20744b414299aaaa362aaf1c7d10 (patch)
tree0caf7e50334160e9709cc2a47a31464c6a343e9b /sys-cluster/kubeadm/kubeadm-1.18.8.ebuild
parentdev-cpp/asio: drop old 1.16.1 (diff)
downloadgentoo-6a2ed20f7ded20744b414299aaaa362aaf1c7d10.tar.gz
gentoo-6a2ed20f7ded20744b414299aaaa362aaf1c7d10.tar.bz2
gentoo-6a2ed20f7ded20744b414299aaaa362aaf1c7d10.zip
sys-cluster/kubeadm: 1.17.11, 1.18.8 and 1.19.1 bump
Bug: https://bugs.gentoo.org/741572 Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'sys-cluster/kubeadm/kubeadm-1.18.8.ebuild')
-rw-r--r--sys-cluster/kubeadm/kubeadm-1.18.8.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sys-cluster/kubeadm/kubeadm-1.18.8.ebuild b/sys-cluster/kubeadm/kubeadm-1.18.8.ebuild
new file mode 100644
index 000000000000..5de1641ab6f5
--- /dev/null
+++ b/sys-cluster/kubeadm/kubeadm-1.18.8.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit bash-completion-r1 go-module
+
+DESCRIPTION="CLI to Easily bootstrap a secure Kubernetes cluster"
+HOMEPAGE="https://kubernetes.io"
+SRC_URI="https://github.com/kubernetes/kubernetes/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="hardened"
+
+BDEPEND="=dev-lang/go-1.14*"
+
+RESTRICT+=" test"
+S="${WORKDIR}/kubernetes-${PV}"
+
+src_compile() {
+ CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')" \
+ emake -j1 GOFLAGS=-v GOLDFLAGS="" LDFLAGS="" WHAT=cmd/${PN}
+}
+
+src_install() {
+ dobin _output/bin/kubeadm
+ _output/bin/${PN} completion bash > ${PN}.bash || die
+ _output/bin/${PN} completion zsh > ${PN}.zsh || die
+ newbashcomp ${PN}.bash ${PN}
+ insinto /usr/share/zsh/site-functions
+ newins ${PN}.zsh _${PN}
+}