summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Molik <dan@danmolik.com>2019-02-18 09:27:48 -0500
committerManuel Rüger <mrueg@gentoo.org>2019-02-25 16:50:56 +0100
commit00c71f5d239ed1b883995b5a39b2a7e9193d7657 (patch)
tree775601fe547febe40a85a4f7a623bfa1535a6a93 /sys-cluster/kubeadm
parentwww-apps/grafana-bin: Version bump to 6.0.0 (diff)
downloadgentoo-00c71f5d239ed1b883995b5a39b2a7e9193d7657.tar.gz
gentoo-00c71f5d239ed1b883995b5a39b2a7e9193d7657.tar.bz2
gentoo-00c71f5d239ed1b883995b5a39b2a7e9193d7657.zip
sys-cluster/kubeadm: update to 1.13.3
Package-Manager: Portage-2.3.61, Repoman-2.3.12 Signed-off-by: Dan Molik <dan@danmolik.com> Tested-by: Dan Molik <dan@danmolik.com> Bug: https://bugs.gentoo.org/678236 Closes: https://bugs.gentoo.org/678236 Signed-off-by: Manuel Rüger <mrueg@gentoo.org>
Diffstat (limited to 'sys-cluster/kubeadm')
-rw-r--r--sys-cluster/kubeadm/Manifest1
-rw-r--r--sys-cluster/kubeadm/kubeadm-1.13.3.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/sys-cluster/kubeadm/Manifest b/sys-cluster/kubeadm/Manifest
index 5ecce56fc15b..519d3532fa9a 100644
--- a/sys-cluster/kubeadm/Manifest
+++ b/sys-cluster/kubeadm/Manifest
@@ -1 +1,2 @@
DIST kubernetes-1.13.2.tar.gz 28771642 BLAKE2B 4a5c5a8e0c05faab3fb6a26854e7c8643b893c2a1f5d5b56aacea869d86426dffe358222034b826d66dfd19855bee71cad7356ff483c27218019e4adda499ce7 SHA512 2f24119fc21d7bdbb60174b46da94ce3f2f6a3c638e9d96323c93c20039aeb06f9c9a3a48c43bb36b71eff25cf72967e780e3339b35ad7ad7a7a7c35662c96bd
+DIST kubernetes-1.13.3.tar.gz 28781320 BLAKE2B 7ae1a6ddeff5b8d19bacc868ad5970cc8ea81239f1ce709207e321ab97c0f155c6c363b3b0f9af25f6e6ce68d99678cf2b10c841a45f082f486bd9dee7be5e3a SHA512 45c2639a88e04d16511c92ca48ca6326b12422f0765df92fb883a1afe7fda9adefcf111d76855532f69b48c6e681774ee0c7e08f74594de808b50e11f8ec52c5
diff --git a/sys-cluster/kubeadm/kubeadm-1.13.3.ebuild b/sys-cluster/kubeadm/kubeadm-1.13.3.ebuild
new file mode 100644
index 000000000000..6c4b699b7594
--- /dev/null
+++ b/sys-cluster/kubeadm/kubeadm-1.13.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit golang-build golang-vcs-snapshot bash-completion-r1
+
+EGO_PN="k8s.io/kubernetes"
+ARCHIVE_URI="https://github.com/kubernetes/kubernetes/archive/v${PV}.tar.gz -> kubernetes-${PV}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="CLI to Easily bootstrap a secure Kubernetes cluster"
+HOMEPAGE="https://github.com/kubernetes/kubernetes https://kubernetes.io"
+SRC_URI="${ARCHIVE_URI}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=dev-lang/go-1.11
+ dev-go/go-bindata"
+
+RESTRICT="test"
+
+src_prepare() {
+ default
+ sed -i -e "/vendor\/github.com\/jteeuwen\/go-bindata\/go-bindata/d" -e "s/-s -w/-w/" src/${EGO_PN}/hack/lib/golang.sh || die
+ sed -i -e "/export PATH/d" src/${EGO_PN}/hack/generate-bindata.sh || die
+}
+
+src_compile() {
+ LDFLAGS="" GOPATH="${WORKDIR}/${P}" emake -j1 -C src/${EGO_PN} WHAT=cmd/${PN} GOFLAGS=-v
+ pushd src/${EGO_PN} || die
+ _output/bin/${PN} completion bash > ${PN}.bash || die
+ _output/bin/${PN} completion zsh > ${PN}.zsh || die
+ popd || die
+}
+
+src_install() {
+ pushd src/${EGO_PN} || die
+ dobin _output/bin/${PN}
+
+ newbashcomp ${PN}.bash ${PN}
+ insinto /usr/share/zsh/site-functions
+ newins ${PN}.zsh _${PN}
+
+ popd || die
+}