summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2015-10-10 08:49:55 -0600
committerChristoph Junghans <ottxor@gentoo.org>2015-10-10 08:50:36 -0600
commitf372e8337de2ac74e6766883be3320e8bea009f6 (patch)
tree3876516ecf4172a4bfab978ab850f97ae7b6908d /sys-cluster/libcircle
parentsys-cluster/libquo: version bump (diff)
downloadgentoo-f372e8337de2ac74e6766883be3320e8bea009f6.tar.gz
gentoo-f372e8337de2ac74e6766883be3320e8bea009f6.tar.bz2
gentoo-f372e8337de2ac74e6766883be3320e8bea009f6.zip
sys-cluster/libcircle: version bump
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'sys-cluster/libcircle')
-rw-r--r--sys-cluster/libcircle/Manifest1
-rw-r--r--sys-cluster/libcircle/libcircle-0.2.1_rc1.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/sys-cluster/libcircle/Manifest b/sys-cluster/libcircle/Manifest
index 28bac28f1192..2aea37171c24 100644
--- a/sys-cluster/libcircle/Manifest
+++ b/sys-cluster/libcircle/Manifest
@@ -1 +1,2 @@
DIST libcircle-0.2.0_rc1.tar.gz 351901 SHA256 59ed75c0bdf2b24f96fbc0230848a5aab57d4eab5a68895489d59a7f68ddd2ee SHA512 1ce07ae012c281fe3e6fbae29bf48e1079768ed5f92f9375c3be02880bed1b1feee6630b31560d7129f76640990e94da1753f55b11a0a8977adaaf9e51144044 WHIRLPOOL 984713d28ee80f686daea7d419a1135360bcda542f904a1aa4ea0ef03b87482e60c2c0858a9e6fd85d7bde1ef557bd61c717ba924f942dfd82d7cbeb9a2e0359
+DIST libcircle-0.2.1_rc1.tar.gz 354251 SHA256 a0d0d75db2be9e47045572ad40f7e1077b7c3540f79180ad1db265ca89438db3 SHA512 9a125bc9f95b1dfb1c777dece4310a709cec46f820651216cd3a34486260f80221e564b82dfaf1ba58b8091b18c6d6b87b0c64d24a940cae6593dc144426fb54 WHIRLPOOL ec77f629c8d5b2391a8f25aa888e0606a0d0240ccf86e6bbe5ba8a04c5e411a6d3f077777da6cdd7badaa87c40b44b6a67b7b901ceb94fb3bec3b118b8465a0a
diff --git a/sys-cluster/libcircle/libcircle-0.2.1_rc1.ebuild b/sys-cluster/libcircle/libcircle-0.2.1_rc1.ebuild
new file mode 100644
index 000000000000..c702e2734878
--- /dev/null
+++ b/sys-cluster/libcircle/libcircle-0.2.1_rc1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils
+
+if [ "${PV}" = "9999" ]; then
+ EGIT_REPO_URI="git://github.com/hpc/${PN}.git https://github.com/hpc/${PN}.git"
+ inherit git-2
+ KEYWORDS=""
+else
+ inherit vcs-snapshot
+ SRC_URI="https://github.com/hpc/${PN}/archive/${PV/_rc/-rc.}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux"
+fi
+
+DESCRIPTION="an API for distributing embarrassingly parallel workloads using self-stabilization"
+HOMEPAGE="https://github.com/hpc/libcircle"
+
+SLOT="0"
+LICENSE="BSD"
+IUSE="doc test"
+
+RDEPEND="virtual/mpi"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ test? ( dev-libs/check )"
+
+DOCS=( HACKING.md README.md )
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable test tests)
+ $(use_enable doc doxygen)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ use doc && HTML_DOCS=( "${BUILD_DIR}/doc/html/" )
+ autotools-utils_src_install
+}