summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-cluster/libcman
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-cluster/libcman')
-rw-r--r--sys-cluster/libcman/Manifest2
-rw-r--r--sys-cluster/libcman/libcman-3.1.5.ebuild47
-rw-r--r--sys-cluster/libcman/libcman-3.2.0.ebuild47
-rw-r--r--sys-cluster/libcman/metadata.xml6
4 files changed, 102 insertions, 0 deletions
diff --git a/sys-cluster/libcman/Manifest b/sys-cluster/libcman/Manifest
new file mode 100644
index 000000000000..0e8513fbb082
--- /dev/null
+++ b/sys-cluster/libcman/Manifest
@@ -0,0 +1,2 @@
+DIST cluster-3.1.5.tar.gz 651449 SHA256 95be1b484f9c58af3c47a9d46dc2802d37f1b2b9028053f243a2c8bd1f07623e
+DIST cluster-3.2.0.tar.gz 688411 SHA256 96651381645cde0e32b06f83e180b1664232a5c589c72f06206e0539e0036cfb SHA512 00620b89564c4f9b67b679695749cd7515f49af43ace6a565e32e020ee66db219f3db3f53420d6460ea8c1cab03258305735fe5db81aab3953777015119533e9 WHIRLPOOL cc468ac8e879dadc157d585b22615d6ffcf0b38a5c93196f8aa9564467e8b8aae6c2688faa9d9e8a98e68a605b86d84b6a79edb474d0cde231e5a78729ebb4e4
diff --git a/sys-cluster/libcman/libcman-3.1.5.ebuild b/sys-cluster/libcman/libcman-3.1.5.ebuild
new file mode 100644
index 000000000000..f570f8425f02
--- /dev/null
+++ b/sys-cluster/libcman/libcman-3.1.5.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit linux-info multilib toolchain-funcs versionator
+
+CLUSTER_RELEASE="${PV}"
+MY_P="cluster-${CLUSTER_RELEASE}"
+
+MAJ_PV="$(get_major_version)"
+MIN_PV="$(get_version_component_range 2-3)"
+
+DESCRIPTION="Cluster Manager Library"
+HOMEPAGE="https://fedorahosted.org/cluster/wiki/HomePage"
+SRC_URI="https://fedorahosted.org/releases/c/l/cluster/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE="static-libs"
+
+DEPEND=">=sys-kernel/linux-headers-2.6.24"
+RDEPEND="!sys-cluster/cman-lib"
+
+S="${WORKDIR}/${MY_P}/cman/lib"
+
+src_configure() {
+ cd "${WORKDIR}/${MY_P}"
+ ./configure \
+ --cc=$(tc-getCC) \
+ --cflags="-Wall" \
+ --libdir=/usr/$(get_libdir) \
+ --disable_kernel_check \
+ --kernel_src=${KERNEL_DIR} \
+ --somajor="$MAJ_PV" \
+ --sominor="$MIN_PV" \
+ --cmanlibdir=/usr/$(get_libdir) \
+ --cmanincdir=/usr/include \
+ || die "configure failed"
+}
+
+src_install() {
+ default
+ use static-libs || rm -f "${D}"/usr/lib*/*.a
+}
diff --git a/sys-cluster/libcman/libcman-3.2.0.ebuild b/sys-cluster/libcman/libcman-3.2.0.ebuild
new file mode 100644
index 000000000000..058dec9d07f2
--- /dev/null
+++ b/sys-cluster/libcman/libcman-3.2.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit linux-info multilib toolchain-funcs versionator
+
+CLUSTER_RELEASE="${PV}"
+MY_P="cluster-${CLUSTER_RELEASE}"
+
+MAJ_PV="$(get_major_version)"
+MIN_PV="$(get_version_component_range 2-3)"
+
+DESCRIPTION="Cluster Manager Library"
+HOMEPAGE="https://fedorahosted.org/cluster/wiki/HomePage"
+SRC_URI="https://fedorahosted.org/releases/c/l/cluster/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE="static-libs"
+
+DEPEND=">=sys-kernel/linux-headers-2.6.24"
+RDEPEND="!sys-cluster/cman-lib"
+
+S="${WORKDIR}/${MY_P}/cman/lib"
+
+src_configure() {
+ cd "${WORKDIR}/${MY_P}"
+ ./configure \
+ --cc=$(tc-getCC) \
+ --cflags="-Wall" \
+ --libdir=/usr/$(get_libdir) \
+ --disable_kernel_check \
+ --kernel_src=${KERNEL_DIR} \
+ --somajor="$MAJ_PV" \
+ --sominor="$MIN_PV" \
+ --cmanlibdir=/usr/$(get_libdir) \
+ --cmanincdir=/usr/include \
+ || die "configure failed"
+}
+
+src_install() {
+ default
+ use static-libs || rm -f "${D}"/usr/lib*/*.a
+}
diff --git a/sys-cluster/libcman/metadata.xml b/sys-cluster/libcman/metadata.xml
new file mode 100644
index 000000000000..db8831ecb877
--- /dev/null
+++ b/sys-cluster/libcman/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>cluster</herd>
+ <longdescription>Cluster Manager Library</longdescription>
+</pkgmetadata>