summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Bronder <jsbronder@gentoo.org>2017-11-26 16:24:47 -0500
committerJustin Bronder <jsbronder@gentoo.org>2017-11-26 16:25:13 -0500
commit640954319ea6cd1213d9a3203ae40fd8bcb1bfe7 (patch)
tree81c8bffedbc64ec835a82688f71255e68c8e242e /sys-cluster/openmpi
parentapp-portage/gemato: keyworded 4 for ppc/ppc64, bug #638776 (diff)
downloadgentoo-640954319ea6cd1213d9a3203ae40fd8bcb1bfe7.tar.gz
gentoo-640954319ea6cd1213d9a3203ae40fd8bcb1bfe7.tar.bz2
gentoo-640954319ea6cd1213d9a3203ae40fd8bcb1bfe7.zip
sys-cluster/openmpi: bump 3.0.0
Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'sys-cluster/openmpi')
-rw-r--r--sys-cluster/openmpi/Manifest1
-rw-r--r--sys-cluster/openmpi/openmpi-3.0.0.ebuild171
2 files changed, 172 insertions, 0 deletions
diff --git a/sys-cluster/openmpi/Manifest b/sys-cluster/openmpi/Manifest
index a158d00edd79..7f00f19cdd54 100644
--- a/sys-cluster/openmpi/Manifest
+++ b/sys-cluster/openmpi/Manifest
@@ -9,3 +9,4 @@ DIST openmpi-1.8.8.tar.bz2 13231433 SHA256 a28382d1e6a36f4073412dc00836ff2524e42
DIST openmpi-2.0.2.tar.bz2 8311215 SHA256 cae396e643f9f91f0a795f8d8694adf7bacfb16f967c22fb39e9e28d477730d3 SHA512 87dc3c23db4b9cb92dbacc9b384b21ce8c4288fe4edc204fbf4a3bef70d8ac4329269e777ed190fa87933d78b73b9e5550ea3b925b2039599cfef3953567232a WHIRLPOOL 9403135fbf1682597c211b1ca0d1e300bd6f49294e9a70bf21f030c48a54f85d2d7ce8de8693dccaf81e2b46fbfd9a43a817bf598dc1f96e122b3f6ea6ffc3c6
DIST openmpi-2.0.4.tar.bz2 8272983 BLAKE2B 7d0a392fbc8c896cdccefb9bf0ff83fbd8db8a42d17f06cb23ac88ba896e2c75e1b1b7a79559d0ce3c2b881f197f54ce1bd8967c889bafe2b97f95fb6b957501 SHA512 2cccb83847d44f6282ec24f7bc12ab51b84dc5ac1a2a919ef0761847ff7cdcb31cfb1f38dca33df7063a98c27a64575a108002716d207cbba3a54773b999e6c5
DIST openmpi-2.1.2.tar.bz2 8278459 BLAKE2B 83f6617322baad4fb13d399fa6a491d1d8dec1a5862974552a5f0cb033ab2a27eb0a44055e2670e3fbe79dbac68ed0130bdfec057cad48e474b814ccd56e59e6 SHA512 8a27a67cab384f9f03efe69bfdd51a8e8790f47a156e3a7e34f26a29d033889653070981c0105f142a96f00293fc069536bd020ae28a97afb564eab747e60457
+DIST openmpi-3.0.0.tar.bz2 9267606 BLAKE2B 9ee569a9c5f5918bb3d389a2945a2e7a5d98464afbd111eb2426a4e8296a23cf6d5b558554ce8126b13f910bd59acbb77e93ac297f3cf222c4bc764836b39ee6 SHA512 7e37eacf959a803d6d89dff4291b64a1f3d83bc7941b778a2fb13d12be0f205cb904e4a807d79676ad1e31fd99ffb15f255c8a227e830673455abb144f14616a
diff --git a/sys-cluster/openmpi/openmpi-3.0.0.ebuild b/sys-cluster/openmpi/openmpi-3.0.0.ebuild
new file mode 100644
index 000000000000..b50c4f2ad163
--- /dev/null
+++ b/sys-cluster/openmpi/openmpi-3.0.0.ebuild
@@ -0,0 +1,171 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+FORTRAN_NEEDED=fortran
+
+inherit cuda flag-o-matic fortran-2 java-pkg-opt-2 toolchain-funcs versionator multilib-minimal
+
+MY_P=${P/-mpi}
+S=${WORKDIR}/${MY_P}
+
+IUSE_OPENMPI_FABRICS="
+ openmpi_fabrics_ofed
+ openmpi_fabrics_knem
+ openmpi_fabrics_psm"
+
+IUSE_OPENMPI_RM="
+ openmpi_rm_pbs
+ openmpi_rm_slurm"
+
+IUSE_OPENMPI_OFED_FEATURES="
+ openmpi_ofed_features_control-hdr-padding
+ openmpi_ofed_features_udcm
+ openmpi_ofed_features_rdmacm
+ openmpi_ofed_features_dynamic-sl"
+
+DESCRIPTION="A high-performance message passing library (MPI)"
+HOMEPAGE="http://www.open-mpi.org"
+SRC_URI="http://www.open-mpi.org/software/ompi/v$(get_version_component_range 1-2)/downloads/${MY_P}.tar.bz2"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux"
+IUSE="cma cuda cxx elibc_FreeBSD fortran heterogeneous ipv6 java numa romio
+ ${IUSE_OPENMPI_FABRICS} ${IUSE_OPENMPI_RM} ${IUSE_OPENMPI_OFED_FEATURES}"
+
+REQUIRED_USE="openmpi_rm_slurm? ( !openmpi_rm_pbs )
+ openmpi_rm_pbs? ( !openmpi_rm_slurm )
+ openmpi_fabrics_psm? ( openmpi_fabrics_ofed )
+ openmpi_ofed_features_control-hdr-padding? ( openmpi_fabrics_ofed )
+ openmpi_ofed_features_udcm? ( openmpi_fabrics_ofed )
+ openmpi_ofed_features_rdmacm? ( openmpi_fabrics_ofed )
+ openmpi_ofed_features_dynamic-sl? ( openmpi_fabrics_ofed )"
+
+# dev-util/nvidia-cuda-toolkit is always multilib
+CDEPEND="
+ !sys-cluster/mpich
+ !sys-cluster/mpich2
+ !sys-cluster/nullmpi
+ !sys-cluster/mpiexec
+ >=dev-libs/libevent-2.0.22[${MULTILIB_USEDEP},threads]
+ dev-libs/libltdl:0[${MULTILIB_USEDEP}]
+ >=sys-apps/hwloc-1.11.2[${MULTILIB_USEDEP},numa?]
+ >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
+ cuda? ( >=dev-util/nvidia-cuda-toolkit-6.5.19-r1 )
+ elibc_FreeBSD? ( dev-libs/libexecinfo )
+ openmpi_fabrics_ofed? ( sys-fabric/ofed:* )
+ openmpi_fabrics_knem? ( sys-cluster/knem )
+ openmpi_fabrics_psm? ( sys-fabric/infinipath-psm:* )
+ openmpi_rm_pbs? ( sys-cluster/torque )
+ openmpi_rm_slurm? ( sys-cluster/slurm )
+ openmpi_ofed_features_rdmacm? ( sys-fabric/librdmacm:* )"
+
+RDEPEND="${CDEPEND}
+ java? ( >=virtual/jre-1.6 )"
+
+DEPEND="${CDEPEND}
+ java? ( >=virtual/jdk-1.6 )"
+
+MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/mpi.h
+ /usr/include/openmpi/ompi/mpi/java/mpiJava.h
+)
+
+pkg_setup() {
+ fortran-2_pkg_setup
+ java-pkg-opt-2_pkg_setup
+
+ elog
+ elog "OpenMPI has an overwhelming count of configuration options."
+ elog "Don't forget the EXTRA_ECONF environment variable can let you"
+ elog "specify configure options if you find them necessary."
+ elog
+}
+
+src_prepare() {
+ default
+
+ # Necessary for scalibility, see
+ # http://www.open-mpi.org/community/lists/users/2008/09/6514.php
+ echo 'oob_tcp_listen_mode = listen_thread' \
+ >> opal/etc/openmpi-mca-params.conf || die
+}
+
+multilib_src_configure() {
+ if use java; then
+ # We must always build with the right -source and -target
+ # flags. Passing flags to javac isn't explicitly supported here
+ # but we can cheat by overriding the configure test for javac.
+ export ac_cv_path_JAVAC="$(java-pkg_get-javac) $(java-pkg_javac-args)"
+ fi
+
+ ECONF_SOURCE=${S} econf \
+ --sysconfdir="${EPREFIX}/etc/${PN}" \
+ --enable-pretty-print-stacktrace \
+ --enable-orterun-prefix-by-default \
+ --with-hwloc="${EPREFIX}/usr" \
+ --with-libltdl="${EPREFIX}/usr" \
+ --with-libevent="${EPREFIX}/usr" \
+ --enable-mpi-fortran=$(usex fortran all no) \
+ $(use_enable cxx mpi-cxx) \
+ $(use_with cma) \
+ $(use_with cuda cuda "${EPREFIX}"/opt/cuda) \
+ $(use_enable romio io-romio) \
+ $(use_enable heterogeneous) \
+ $(use_enable ipv6) \
+ $(multilib_native_use_enable java) \
+ $(multilib_native_use_enable java mpi-java) \
+ $(multilib_native_use_with openmpi_fabrics_ofed verbs "${EPREFIX}"/usr) \
+ $(multilib_native_use_with openmpi_fabrics_knem knem "${EPREFIX}"/usr) \
+ $(multilib_native_use_with openmpi_fabrics_psm psm "${EPREFIX}"/usr) \
+ $(multilib_native_use_enable openmpi_ofed_features_control-hdr-padding openib-control-hdr-padding) \
+ $(multilib_native_use_enable openmpi_ofed_features_rdmacm openib-rdmacm) \
+ $(multilib_native_use_enable openmpi_ofed_features_udcm openib-udcm) \
+ $(multilib_native_use_enable openmpi_ofed_features_dynamic-sl openib-dynamic-sl) \
+ $(multilib_native_use_with openmpi_rm_pbs tm) \
+ $(multilib_native_use_with openmpi_rm_slurm slurm)
+}
+
+multilib_src_test() {
+ # Doesn't work with the default src_test as the dry run (-n) fails.
+ emake -j1 check
+}
+
+multilib_src_install() {
+ default
+
+ # fortran header cannot be wrapped (bug #540508), workaround part 1
+ if multilib_is_native_abi && use fortran; then
+ mkdir "${T}"/fortran || die
+ mv "${ED}"usr/include/mpif* "${T}"/fortran || die
+ else
+ # some fortran files get installed unconditionally
+ rm \
+ "${ED}"usr/include/mpif* \
+ "${ED}"usr/bin/mpif* \
+ "${ED}"usr/bin/oshfort \
+ "${ED}"usr/bin/shmemfort \
+ || die
+ fi
+}
+
+multilib_src_install_all() {
+ # fortran header cannot be wrapped (bug #540508), workaround part 2
+ if use fortran; then
+ mv "${T}"/fortran/mpif* "${ED}"usr/include || die
+ fi
+
+ # Remove la files, no static libs are installed and we have pkg-config
+ find "${ED}" -name '*.la' -delete || die
+
+ if use java; then
+ local mpi_jar="${ED}"usr/$(get_libdir)/mpi.jar
+ java-pkg_dojar "${mpi_jar}"
+ # We don't want to install the jar file twice
+ # so let's clean after ourselves.
+ rm "${mpi_jar}" || die
+ fi
+
+ einstalldocs
+}