summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel M. Weeks <dan@danweeks.net>2020-07-09 00:30:30 -0400
committerMikle Kolyada <zlogene@gentoo.org>2020-07-09 20:31:58 +0300
commit51c32bc73cde578ebf2e2fe367aed69290a1108c (patch)
tree5ad86d85ad60d93f8a0153a5b7ff37e23364a998 /sys-cluster/rdma-core
parentx11-drivers/nvidia-drivers: Install supported-gpus.json (diff)
downloadgentoo-51c32bc73cde578ebf2e2fe367aed69290a1108c.tar.gz
gentoo-51c32bc73cde578ebf2e2fe367aed69290a1108c.tar.bz2
gentoo-51c32bc73cde578ebf2e2fe367aed69290a1108c.zip
sys-cluster/rdma-core: Fix default RUNDIR
Build system logic relies on user (ebuild) setting CMAKE_INSTALL_RUNDIR *not* CMAKE_INSTALL_FULL_RUNDIR. A default CMAKE_INSTALL_RUNDIR will always be appended to prefix. Closes: https://bugs.gentoo.org/731808 Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Daniel M. Weeks <dan@danweeks.net> Closes: https://github.com/gentoo/gentoo/pull/16643 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'sys-cluster/rdma-core')
-rw-r--r--sys-cluster/rdma-core/rdma-core-26.0-r2.ebuild (renamed from sys-cluster/rdma-core/rdma-core-26.0-r1.ebuild)2
-rw-r--r--sys-cluster/rdma-core/rdma-core-26.1-r1.ebuild (renamed from sys-cluster/rdma-core/rdma-core-26.1.ebuild)2
-rw-r--r--sys-cluster/rdma-core/rdma-core-27.0-r2.ebuild (renamed from sys-cluster/rdma-core/rdma-core-27.0-r1.ebuild)2
-rw-r--r--sys-cluster/rdma-core/rdma-core-28.0-r1.ebuild (renamed from sys-cluster/rdma-core/rdma-core-28.0.ebuild)2
-rw-r--r--sys-cluster/rdma-core/rdma-core-29.0-r1.ebuild (renamed from sys-cluster/rdma-core/rdma-core-29.0.ebuild)2
-rw-r--r--sys-cluster/rdma-core/rdma-core-30.0-r1.ebuild (renamed from sys-cluster/rdma-core/rdma-core-30.0.ebuild)2
-rw-r--r--sys-cluster/rdma-core/rdma-core-9999.ebuild2
7 files changed, 7 insertions, 7 deletions
diff --git a/sys-cluster/rdma-core/rdma-core-26.0-r1.ebuild b/sys-cluster/rdma-core/rdma-core-26.0-r2.ebuild
index 39c6e4a73b19..74779b99fe8f 100644
--- a/sys-cluster/rdma-core/rdma-core-26.0-r1.ebuild
+++ b/sys-cluster/rdma-core/rdma-core-26.0-r2.ebuild
@@ -66,7 +66,7 @@ pkg_setup() {
src_configure() {
local mycmakeargs=(
-DCMAKE_INSTALL_SYSCONFDIR=/etc
- -DCMAKE_INSTALL_FULL_RUNDIR=/run
+ -DCMAKE_INSTALL_RUNDIR=/run
-DCMAKE_INSTALL_SHAREDSTATEDIR=/var/lib
-DCMAKE_INSTALL_UDEV_RULESDIR="$(get_udevdir)"/rules.d
-DCMAKE_INSTALL_SYSTEMD_SERVICEDIR="$(systemd_get_systemunitdir)"
diff --git a/sys-cluster/rdma-core/rdma-core-26.1.ebuild b/sys-cluster/rdma-core/rdma-core-26.1-r1.ebuild
index 39537f768f10..19ce4ff4082f 100644
--- a/sys-cluster/rdma-core/rdma-core-26.1.ebuild
+++ b/sys-cluster/rdma-core/rdma-core-26.1-r1.ebuild
@@ -66,7 +66,7 @@ pkg_setup() {
src_configure() {
local mycmakeargs=(
-DCMAKE_INSTALL_SYSCONFDIR=/etc
- -DCMAKE_INSTALL_FULL_RUNDIR=/run
+ -DCMAKE_INSTALL_RUNDIR=/run
-DCMAKE_INSTALL_SHAREDSTATEDIR=/var/lib
-DCMAKE_INSTALL_UDEV_RULESDIR="$(get_udevdir)"/rules.d
-DCMAKE_INSTALL_SYSTEMD_SERVICEDIR="$(systemd_get_systemunitdir)"
diff --git a/sys-cluster/rdma-core/rdma-core-27.0-r1.ebuild b/sys-cluster/rdma-core/rdma-core-27.0-r2.ebuild
index f8ee8760f4e5..7f6e171699e5 100644
--- a/sys-cluster/rdma-core/rdma-core-27.0-r1.ebuild
+++ b/sys-cluster/rdma-core/rdma-core-27.0-r2.ebuild
@@ -66,7 +66,7 @@ pkg_setup() {
src_configure() {
local mycmakeargs=(
-DCMAKE_INSTALL_SYSCONFDIR=/etc
- -DCMAKE_INSTALL_FULL_RUNDIR=/run
+ -DCMAKE_INSTALL_RUNDIR=/run
-DCMAKE_INSTALL_SHAREDSTATEDIR=/var/lib
-DCMAKE_INSTALL_UDEV_RULESDIR="$(get_udevdir)"/rules.d
-DCMAKE_INSTALL_SYSTEMD_SERVICEDIR="$(systemd_get_systemunitdir)"
diff --git a/sys-cluster/rdma-core/rdma-core-28.0.ebuild b/sys-cluster/rdma-core/rdma-core-28.0-r1.ebuild
index f476dc0f72b1..895bd252e6e6 100644
--- a/sys-cluster/rdma-core/rdma-core-28.0.ebuild
+++ b/sys-cluster/rdma-core/rdma-core-28.0-r1.ebuild
@@ -66,7 +66,7 @@ pkg_setup() {
src_configure() {
local mycmakeargs=(
-DCMAKE_INSTALL_SYSCONFDIR=/etc
- -DCMAKE_INSTALL_FULL_RUNDIR=/run
+ -DCMAKE_INSTALL_RUNDIR=/run
-DCMAKE_INSTALL_SHAREDSTATEDIR=/var/lib
-DCMAKE_INSTALL_UDEV_RULESDIR="$(get_udevdir)"/rules.d
-DCMAKE_INSTALL_SYSTEMD_SERVICEDIR="$(systemd_get_systemunitdir)"
diff --git a/sys-cluster/rdma-core/rdma-core-29.0.ebuild b/sys-cluster/rdma-core/rdma-core-29.0-r1.ebuild
index b5518fdad7d5..9a120345c302 100644
--- a/sys-cluster/rdma-core/rdma-core-29.0.ebuild
+++ b/sys-cluster/rdma-core/rdma-core-29.0-r1.ebuild
@@ -66,7 +66,7 @@ pkg_setup() {
src_configure() {
local mycmakeargs=(
-DCMAKE_INSTALL_SYSCONFDIR=/etc
- -DCMAKE_INSTALL_FULL_RUNDIR=/run
+ -DCMAKE_INSTALL_RUNDIR=/run
-DCMAKE_INSTALL_SHAREDSTATEDIR=/var/lib
-DCMAKE_INSTALL_UDEV_RULESDIR="$(get_udevdir)"/rules.d
-DCMAKE_INSTALL_SYSTEMD_SERVICEDIR="$(systemd_get_systemunitdir)"
diff --git a/sys-cluster/rdma-core/rdma-core-30.0.ebuild b/sys-cluster/rdma-core/rdma-core-30.0-r1.ebuild
index 66af444d7865..9bcb28a2f0be 100644
--- a/sys-cluster/rdma-core/rdma-core-30.0.ebuild
+++ b/sys-cluster/rdma-core/rdma-core-30.0-r1.ebuild
@@ -66,7 +66,7 @@ pkg_setup() {
src_configure() {
local mycmakeargs=(
-DCMAKE_INSTALL_SYSCONFDIR=/etc
- -DCMAKE_INSTALL_FULL_RUNDIR=/run
+ -DCMAKE_INSTALL_RUNDIR=/run
-DCMAKE_INSTALL_SHAREDSTATEDIR=/var/lib
-DCMAKE_INSTALL_UDEV_RULESDIR="$(get_udevdir)"/rules.d
-DCMAKE_INSTALL_SYSTEMD_SERVICEDIR="$(systemd_get_systemunitdir)"
diff --git a/sys-cluster/rdma-core/rdma-core-9999.ebuild b/sys-cluster/rdma-core/rdma-core-9999.ebuild
index a8c381b38698..fae3876a639c 100644
--- a/sys-cluster/rdma-core/rdma-core-9999.ebuild
+++ b/sys-cluster/rdma-core/rdma-core-9999.ebuild
@@ -64,7 +64,7 @@ pkg_setup() {
src_configure() {
local mycmakeargs=(
-DCMAKE_INSTALL_SYSCONFDIR=/etc
- -DCMAKE_INSTALL_FULL_RUNDIR=/run
+ -DCMAKE_INSTALL_RUNDIR=/run
-DCMAKE_INSTALL_SHAREDSTATEDIR=/var/lib
-DCMAKE_INSTALL_UDEV_RULESDIR="$(get_udevdir)"/rules.d
-DCMAKE_INSTALL_SYSTEMD_SERVICEDIR="$(systemd_get_systemunitdir)"