summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuilherme Amadio <amadio@gentoo.org>2021-11-19 15:20:52 +0100
committerGuilherme Amadio <amadio@gentoo.org>2021-11-19 17:27:29 +0100
commit6697c19b01b6a9aeadde245f5f8e52295b6e3943 (patch)
treea0a35ccce4f39681d78c1170105146f08f31270b /sys-cluster/rdma-core
parentsys-cluster/rdma-code: fix bashism in srpd.init (diff)
downloadgentoo-6697c19b01b6a9aeadde245f5f8e52295b6e3943.tar.gz
gentoo-6697c19b01b6a9aeadde245f5f8e52295b6e3943.tar.bz2
gentoo-6697c19b01b6a9aeadde245f5f8e52295b6e3943.zip
sys-cluster/rdma-core: version bump to 38.0
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
Diffstat (limited to 'sys-cluster/rdma-core')
-rw-r--r--sys-cluster/rdma-core/Manifest1
-rw-r--r--sys-cluster/rdma-core/rdma-core-38.0.ebuild96
2 files changed, 97 insertions, 0 deletions
diff --git a/sys-cluster/rdma-core/Manifest b/sys-cluster/rdma-core/Manifest
index 2ab8d411f412..fb0f292ed20d 100644
--- a/sys-cluster/rdma-core/Manifest
+++ b/sys-cluster/rdma-core/Manifest
@@ -4,3 +4,4 @@ DIST rdma-core-32.0.tar.gz 1525119 BLAKE2B 8f754c04be3f13a90a162fde09f96b26d6653
DIST rdma-core-33.0.tar.gz 1549162 BLAKE2B 7b7c8711eaeb9e66159962bcf0f70644cbb4af96df70f3c9ee6e9d9c8c3e4de5d3248666a0b3fe490537f91cc18c5d09448c72b98c45585e0645594deedee071 SHA512 64ace358c6336519131aea858012e22791bf2ab95f06d655a87835361b5822f5ce0c29db8ddb83121a62f4606418d5fa11358e7ad84da4f93f6233fb3947e52c
DIST rdma-core-34.0.tar.gz 1571236 BLAKE2B 1c6799ba742926ef99f8fa7a0e20d7b910e0f3157e5de4350f7068d7d6f4fa79b8fa6be631e9675517bd12b91083c5e92157a1c097691ead0888823702c3583a SHA512 33ce5fbf0d468a31f7ac0e513cf107e3d730f5db279368aa986536f70d684f40e7bacdf965d18b77922272b0420a6cd973c0b73371758107d8f7751be5851ee7
DIST rdma-core-36.0.tar.gz 1649117 BLAKE2B e3d58d8584f440cff437dedba1ccf34c2b62ecc63b5a039f71fc7666aed8e277ffbba2bbb4f8eda428f2f5f5890a5939163c6ebf6d420d3b3b0037a721d45e42 SHA512 89ad37c381ec7b5f18db01dbcbe65351b40fc1d0bc76e2088d663c6c560bf5f119841930ecf1042c997f5bf644683b906748c38d85f1eb561aadda060baa2368
+DIST rdma-core-38.0.tar.gz 1760189 BLAKE2B ab028ce9367353201748f19d05d4d02170920b155b7ebb3584043729422e377cfb4ae29ed442ce7f965faa2470fe558499e9b2e7da51f282fa65ab029d4bcaa9 SHA512 98b3e3d26675891d54652817851f172855443faf6950b5c17177f10f5b3b197778590ad0e9640ecceaba17cf4aceb276ddb145ab46c1f6af9d2f6954688c3239
diff --git a/sys-cluster/rdma-core/rdma-core-38.0.ebuild b/sys-cluster/rdma-core/rdma-core-38.0.ebuild
new file mode 100644
index 000000000000..f78ff20324b2
--- /dev/null
+++ b/sys-cluster/rdma-core/rdma-core-38.0.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..10} )
+
+inherit cmake python-single-r1 udev systemd
+
+DESCRIPTION="Userspace components for the Linux Kernel's drivers/infiniband subsystem"
+HOMEPAGE="https://github.com/linux-rdma/rdma-core"
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/linux-rdma/rdma-core"
+else
+ SRC_URI="https://github.com/linux-rdma/rdma-core/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+LICENSE="|| ( GPL-2 ( CC0-1.0 MIT BSD BSD-with-attribution ) )"
+SLOT="0"
+IUSE="neigh python static-libs systemd valgrind"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+COMMON_DEPEND="
+ virtual/libudev:=
+ neigh? ( dev-libs/libnl:3 )
+ systemd? ( sys-apps/systemd:= )
+ valgrind? ( dev-util/valgrind )
+ python? ( ${PYTHON_DEPS} )"
+
+DEPEND="${COMMON_DEPEND}
+ python? (
+ $(python_gen_cond_dep '
+ dev-python/cython[${PYTHON_MULTI_USEDEP}]
+ ')
+ )"
+
+RDEPEND="${COMMON_DEPEND}
+ !sys-fabric/infiniband-diags
+ !sys-fabric/libibverbs
+ !sys-fabric/librdmacm
+ !sys-fabric/libibumad
+ !sys-fabric/ibacm
+ !sys-fabric/libibmad
+ !sys-fabric/srptools
+ !sys-fabric/infinipath-psm
+ !sys-fabric/libcxgb3
+ !sys-fabric/libcxgb4
+ !sys-fabric/libmthca
+ !sys-fabric/libmlx4
+ !sys-fabric/libmlx5
+ !sys-fabric/libocrdma
+ !sys-fabric/libnes"
+
+BDEPEND="virtual/pkgconfig"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_SYSCONFDIR="${EPREFIX}"/etc
+ -DCMAKE_INSTALL_RUNDIR=/run
+ -DCMAKE_INSTALL_SHAREDSTATEDIR=/var/lib
+ -DCMAKE_INSTALL_UDEV_RULESDIR="${EPREFIX}""$(get_udevdir)"/rules.d
+ -DCMAKE_INSTALL_SYSTEMD_SERVICEDIR="$(systemd_get_systemunitdir)"
+ -DCMAKE_DISABLE_FIND_PACKAGE_Systemd="$(usex systemd no yes)"
+ -DENABLE_VALGRIND="$(usex valgrind)"
+ -DENABLE_RESOLVE_NEIGH="$(usex neigh)"
+ -DENABLE_STATIC="$(usex static-libs)"
+ -DNO_PYVERBS="$(usex python OFF ON)"
+ -DNO_MAN_PAGES=1
+ )
+
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ udev_dorules "${ED}"/etc/udev/rules.d/70-persistent-ipoib.rules
+ rm -r "${ED}"/etc/{udev,init.d} || die
+
+ if use neigh; then
+ newinitd "${FILESDIR}"/ibacm.init ibacm
+ newinitd "${FILESDIR}"/iwpmd.init iwpmd
+ fi
+
+ newinitd "${FILESDIR}"/srpd.init srpd
+
+ use python && python_optimize
+}