summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc Schiffbauer <mschiff@gentoo.org>2018-10-26 22:47:22 +0200
committerMarc Schiffbauer <mschiff@gentoo.org>2018-10-26 22:48:03 +0200
commitc36902752c7feed67a8a89effa08d27fc292d3eb (patch)
tree651de424e61e039402194e5dad441d2b5c4869ca /sys-cluster/sanlock
parentsci-chemistry/tm-align: Drop old (diff)
downloadgentoo-c36902752c7feed67a8a89effa08d27fc292d3eb.tar.gz
gentoo-c36902752c7feed67a8a89effa08d27fc292d3eb.tar.bz2
gentoo-c36902752c7feed67a8a89effa08d27fc292d3eb.zip
sys-cluster/sanlock: add version 3.6.0
fixes #616110 Signed-off-by: Marc Schiffbauer <mschiff@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'sys-cluster/sanlock')
-rw-r--r--sys-cluster/sanlock/Manifest1
-rw-r--r--sys-cluster/sanlock/sanlock-3.6.0.ebuild85
2 files changed, 86 insertions, 0 deletions
diff --git a/sys-cluster/sanlock/Manifest b/sys-cluster/sanlock/Manifest
index 5dfde700cebc..16d895e0bdda 100644
--- a/sys-cluster/sanlock/Manifest
+++ b/sys-cluster/sanlock/Manifest
@@ -1 +1,2 @@
DIST sanlock-3.4.0.tar.xz 157016 BLAKE2B 9d588214d260b88cfa3978e831bcd8086ae80aafc1a04b616274da141140a22c2765083632f29402cdae67cdbbdfcefdaff1539e5d45485c6f271e3ee7f6471a SHA512 8a10faaa5b9ce9f0506ca16620ad482804c9ca860b84a60a6f0b525a256059229a202163d366a57fb59169c0f4f822ced570b42562e412747f6f716509341f19
+DIST sanlock-3.6.0.tar.gz 221666 BLAKE2B 7fe95bd6813c13b76993b343a5ad605c7ba642583987ffa5fef583f34c053ee62b0f9e5979f5b5cb9e4fcde53268ae3debc5ec36b04f6651cc4cb902dff52df9 SHA512 59eb2a6f12e95d54886fdf6d56fd9a6814dd20fe11f39664f2bb82a56326fee48c9465ae30e6d04f970c8f1b0d9c2e22b90d21ab1f657c6d6b61ff9f02332443
diff --git a/sys-cluster/sanlock/sanlock-3.6.0.ebuild b/sys-cluster/sanlock/sanlock-3.6.0.ebuild
new file mode 100644
index 000000000000..a2ff725e30e2
--- /dev/null
+++ b/sys-cluster/sanlock/sanlock-3.6.0.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+inherit linux-info python-r1 systemd user
+
+DESCRIPTION="shared storage lock manager"
+HOMEPAGE="https://pagure.io/sanlock"
+SRC_URI="https://releases.pagure.org/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2+ GPL-2 GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="python"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+DEPEND="
+ dev-libs/libaio
+ sys-apps/util-linux
+ python? ( ${PYTHON_DEPS} )
+"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ local warning="You need to have CONFIG_SOFT_WATCHDOG enabled in your kernel for wdmd"
+ if linux_config_exists; then
+ if ! linux_chkconfig_present SOFT_WATCHDOG; then
+ ewarn ""
+ ewarn "$warning"
+ ewarn ""
+ fi
+ else
+ ewarn ""
+ ewarn "Could not be checked automatically: $warning"
+ ewarn ""
+ fi
+}
+
+pkg_preinst() {
+ enewgroup sanlock
+ enewuser sanlock -1 -1 -1 sanlock,disk
+
+}
+
+src_compile() {
+ for d in wdmd src fence_sanlock reset; do
+ cd $d; emake; cd ..
+ done
+ if use python; then
+ cd python; python_foreach_impl emake; cd ..
+ fi
+}
+
+src_install() {
+ for d in wdmd src fence_sanlock reset; do
+ cd $d; emake DESTDIR="${D}" LIBDIR="${EROOT}usr/$(get_libdir)" install; cd ..
+ done
+ if use python; then
+ cd python; python_foreach_impl emake DESTDIR="${D}" install; cd ..
+ fi
+
+ # config
+ dodir /etc/wdmd.d
+ dodir /etc/sanlock
+ insinto /etc/sanlock
+ doins src/sanlock.conf
+
+ # init
+ newconfd init.d/sanlock.sysconfig sanlock
+ newconfd init.d/wdmd.sysconfig wdmd
+ newinitd "${FILESDIR}"/sanlock.initd sanlock
+ newinitd "${FILESDIR}"/wdmd.initd wdmd
+ #doinitd ${FILESDIR}/sanlk-resetd.initd
+ #doinitd ${FILESDIR}/fence_sanlockd.initd
+
+ # systemd
+ systemd_newunit init.d/sanlock.service.native sanlock.service
+ sed -i 's,^ExecStartPre=,#ExecStartPre=,' init.d/wdmd.service.native
+ systemd_newunit init.d/wdmd.service.native wdmd.service
+ systemd_dounit init.d/sanlk-resetd.service
+ #systemd_dounit ${FILESDIR}/fence_sanlockd.service
+}