summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2022-04-14 10:52:25 +0100
committerMarek Szuba <marecki@gentoo.org>2022-04-14 10:52:25 +0100
commit53411b44a5f6c3e79248c20eb2d9bbea3b709749 (patch)
treeed6fe7a34caf593418774051a7d790c58cd655a4 /sys-cluster/singularity
parentprofiles: mask sys-cluster/singularity (diff)
downloadgentoo-53411b44a5f6c3e79248c20eb2d9bbea3b709749.tar.gz
gentoo-53411b44a5f6c3e79248c20eb2d9bbea3b709749.tar.bz2
gentoo-53411b44a5f6c3e79248c20eb2d9bbea3b709749.zip
sys-cluster/singularity: drop 3.8.5
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'sys-cluster/singularity')
-rw-r--r--sys-cluster/singularity/Manifest1
-rw-r--r--sys-cluster/singularity/singularity-3.8.5.ebuild71
2 files changed, 0 insertions, 72 deletions
diff --git a/sys-cluster/singularity/Manifest b/sys-cluster/singularity/Manifest
index 0632e57fb18f..f3dad2760ccf 100644
--- a/sys-cluster/singularity/Manifest
+++ b/sys-cluster/singularity/Manifest
@@ -1,2 +1 @@
-DIST singularity-3.8.5.tar.gz 7898598 BLAKE2B 3cf76734d6208340d8562f3d3d67f95c507bad3fad6797d82aed39aa39288385ca02d62854f3dddcfc1a1e3056e7485f27e6081c152b853c682ca8e3a587cf3a SHA512 857761f47528a841a3cf11b49583ab7e8a2d137703e1826ff194011abba3334ed06859219e0c457f352304e7b18f1c493a8b337cc5df67981eb428c567d0ac5f
DIST singularity-3.8.7.tar.gz 8185470 BLAKE2B afa1b0b5b3096e0f3634ce7b61bc19a9d5435a213e241220d2fb19cdb65e93b05e4d8a27db89eeaed6af6b4ab5e09a8914d21a3ff0be88a7c6c8d6245dce9e30 SHA512 5649264c15414b90bab47d1958ec61681fa0b9e37ee445a5059f78f3d822aa27f5b9c5c4f4010d053ec9d03e0215c67e2de8e315f74de7d3cd16b8399f40ee59
diff --git a/sys-cluster/singularity/singularity-3.8.5.ebuild b/sys-cluster/singularity/singularity-3.8.5.ebuild
deleted file mode 100644
index 0ecdfaee462b..000000000000
--- a/sys-cluster/singularity/singularity-3.8.5.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit linux-info toolchain-funcs
-
-DESCRIPTION="Application containers for Linux"
-HOMEPAGE="https://github.com/apptainer/singularity"
-SRC_URI="https://github.com/apptainer/${PN}/releases/download/v${PV}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="BSD"
-KEYWORDS="amd64 ~riscv x86 ~amd64-linux ~x86-linux"
-IUSE="examples +network +suid"
-
-# Do not complain about CFLAGS etc. since go projects do not use them.
-QA_FLAGS_IGNORED='.*'
-
-COMMON="sys-libs/libseccomp"
-BDEPEND="virtual/pkgconfig"
-DEPEND="${COMMON}
- >=dev-lang/go-1.16.0
- app-crypt/gpgme
- dev-libs/openssl
- sys-apps/util-linux
- sys-fs/cryptsetup"
-RDEPEND="${COMMON}
- sys-fs/squashfs-tools"
-
-CONFIG_CHECK="~SQUASHFS"
-
-src_configure() {
- local myconfargs=(
- -c "$(tc-getBUILD_CC)" \
- -x "$(tc-getBUILD_CXX)" \
- -C "$(tc-getCC)" \
- -X "$(tc-getCXX)" \
- --prefix="${EPREFIX}"/usr \
- --sysconfdir="${EPREFIX}"/etc \
- --runstatedir="${EPREFIX}"/run \
- --localstatedir="${EPREFIX}"/var \
- $(usex network "" "--without-network") \
- $(usex suid "" "--without-suid")
- )
- ./mconfig -v ${myconfargs[@]} || die "Error invoking mconfig"
-}
-
-src_compile() {
- emake -C builddir
-}
-
-src_install() {
- emake DESTDIR="${D}" -C builddir install
- keepdir /var/singularity/mnt/session
-
- # As of version 3.5.3 this seems to be very much broken, affecting
- # commands which have got nothing to do with singularity (example:
- # completion on 'udisks mount -b /dev/' rejects all files from that
- # directory other than 'autofs'). Moreover, this should go into
- # $(get_bashcompdir) (from bash-completion-r1.eclass) rather than /etc.
- # Hopefully temporary, which is why we delete this at install time
- # instead of patching build scripts not to generate bash-completion
- # data in the first place.
- rm -rf "${ED}"/etc/bash_completion.d || die
-
- dodoc README.md CONTRIBUTORS.md CONTRIBUTING.md
- if use examples; then
- dodoc -r examples
- fi
-}