summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-03-11 12:51:00 +0000
committerMarek Szuba <marecki@gentoo.org>2021-03-11 13:44:28 +0000
commit7407d736d6ad94cd8b9ef2aea1f90f418e8e5918 (patch)
treefc39e40ec1a57228949fb72acf5da7c48904707c /sys-cluster/singularity
parentsys-cluster/singularity: remove old (diff)
downloadgentoo-7407d736d6ad94cd8b9ef2aea1f90f418e8e5918.tar.gz
gentoo-7407d736d6ad94cd8b9ef2aea1f90f418e8e5918.tar.bz2
gentoo-7407d736d6ad94cd8b9ef2aea1f90f418e8e5918.zip
sys-cluster/singularity: bump to 3.7.2
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'sys-cluster/singularity')
-rw-r--r--sys-cluster/singularity/Manifest1
-rw-r--r--sys-cluster/singularity/singularity-3.7.2.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/sys-cluster/singularity/Manifest b/sys-cluster/singularity/Manifest
index 8f1c19fd5b34..9da8ead57402 100644
--- a/sys-cluster/singularity/Manifest
+++ b/sys-cluster/singularity/Manifest
@@ -1 +1,2 @@
DIST singularity-3.7.1.tar.gz 6121297 BLAKE2B 10399692559dbaf1a855229f4d3ff845af5b923d9a5b959638481ba58fd5bd04035fb751e5000aa44f816947d88ead85fbdceb8ad5cdb94aa54b0986cb922044 SHA512 ed87bd13bb4bbdcb49981cc02bf37e1db9a5d8fab3ef4314a15cfa391cb2210b55b2e54500fb03811eda8f31499ea7cead9a368a486da0cea0ac71037908c7cc
+DIST singularity-3.7.2.tar.gz 6268044 BLAKE2B d5a316046037dcb9c386f2d3b45204b77394cae273d0daa561282a354a463823c4be3c56e0935ff0a8dc9671cb841ad8cb75364b7652dce93ce099ede3e12ee3 SHA512 f31e383e645d394cc29e5b38da84ca805545e3226b069c696e667e7dde1569fa2373613f624c739482459a938e76e4e513062c19474685ccbfa5bd6162244466
diff --git a/sys-cluster/singularity/singularity-3.7.2.ebuild b/sys-cluster/singularity/singularity-3.7.2.ebuild
new file mode 100644
index 000000000000..50873aff393c
--- /dev/null
+++ b/sys-cluster/singularity/singularity-3.7.2.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info toolchain-funcs
+
+DESCRIPTION="Application containers for Linux"
+HOMEPAGE="https://sylabs.io"
+SRC_URI="https://github.com/hpcng/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples +network +suid"
+
+# Do not complain about CFLAGS etc. since go projects do not use them.
+QA_FLAGS_IGNORED='.*'
+
+COMMON="sys-libs/libseccomp"
+BDEPEND="virtual/pkgconfig"
+DEPEND="${COMMON}
+ >=dev-lang/go-1.13.0
+ app-crypt/gpgme
+ dev-libs/openssl
+ sys-apps/util-linux
+ sys-fs/cryptsetup"
+RDEPEND="${COMMON}
+ sys-fs/squashfs-tools"
+
+CONFIG_CHECK="~SQUASHFS"
+
+S=${WORKDIR}/${PN}
+
+src_configure() {
+ local myconfargs=(
+ -c "$(tc-getBUILD_CC)" \
+ -x "$(tc-getBUILD_CXX)" \
+ -C "$(tc-getCC)" \
+ -X "$(tc-getCXX)" \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --runstatedir=/run \
+ --localstatedir=/var \
+ $(usex network "" "--without-network") \
+ $(usex suid "" "--without-suid")
+ )
+ ./mconfig -v ${myconfargs[@]} || die "Error invoking mconfig"
+}
+
+src_compile() {
+ emake -C builddir
+}
+
+src_install() {
+ emake DESTDIR="${ED}" -C builddir install
+ keepdir /var/singularity/mnt/session
+
+ # As of version 3.5.3 this seems to be very much broken, affecting
+ # commands which have got nothing to do with singularity (example:
+ # completion on 'udisks mount -b /dev/' rejects all files from that
+ # directory other than 'autofs'). Moreover, this should go into
+ # $(get_bashcompdir) (from bash-completion-r1.eclass) rather than /etc.
+ # Hopefully temporary, which is why we delete this at install time
+ # instead of patching build scripts not to generate bash-completion
+ # data in the first place.
+ rm -rf "${ED}"/etc/bash_completion.d || die
+
+ dodoc README.md CONTRIBUTORS.md CONTRIBUTING.md
+ if use examples; then
+ dodoc -r examples
+ fi
+}