summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-11-30 12:37:30 +0100
committerMarek Szuba <marecki@gentoo.org>2021-11-30 12:37:30 +0100
commitadb5552a56b4290442745071768212c15376dc49 (patch)
treed72a74083ab9253bd686c19b72195d7e4d7327ba /sys-cluster/singularity
parentdev-python/mkdocs-minify-plugin: Keyword 0.5.0-r1 x86, #827200 (diff)
downloadgentoo-adb5552a56b4290442745071768212c15376dc49.tar.gz
gentoo-adb5552a56b4290442745071768212c15376dc49.tar.bz2
gentoo-adb5552a56b4290442745071768212c15376dc49.zip
sys-cluster/singularity: drop 3.8.3
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'sys-cluster/singularity')
-rw-r--r--sys-cluster/singularity/Manifest1
-rw-r--r--sys-cluster/singularity/singularity-3.8.3.ebuild71
2 files changed, 0 insertions, 72 deletions
diff --git a/sys-cluster/singularity/Manifest b/sys-cluster/singularity/Manifest
index 6e7f44d42947..4b0ea9e7a0b2 100644
--- a/sys-cluster/singularity/Manifest
+++ b/sys-cluster/singularity/Manifest
@@ -1,2 +1 @@
-DIST singularity-3.8.3.tar.gz 7948604 BLAKE2B 67c8f4e52faf46a25c1bc16d4f05100f92cfb67b111898bebaeed827bb545f9d44fc3aaae99cbea020ec934c7dd3412b119a3f7f3f003f3e09a5e86dd2816957 SHA512 ede69bfa6602d75f67354afc215a1cf51db769df052662b77a8f1ac88cf580f13683190231452611ba618cda0e63af746dcdf59ab41611a9035bd199f8b50ec5
DIST singularity-3.8.5.tar.gz 7898598 BLAKE2B 3cf76734d6208340d8562f3d3d67f95c507bad3fad6797d82aed39aa39288385ca02d62854f3dddcfc1a1e3056e7485f27e6081c152b853c682ca8e3a587cf3a SHA512 857761f47528a841a3cf11b49583ab7e8a2d137703e1826ff194011abba3334ed06859219e0c457f352304e7b18f1c493a8b337cc5df67981eb428c567d0ac5f
diff --git a/sys-cluster/singularity/singularity-3.8.3.ebuild b/sys-cluster/singularity/singularity-3.8.3.ebuild
deleted file mode 100644
index 8e297e844c82..000000000000
--- a/sys-cluster/singularity/singularity-3.8.3.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit linux-info toolchain-funcs
-
-DESCRIPTION="Application containers for Linux"
-HOMEPAGE="https://sylabs.io"
-SRC_URI="https://github.com/hpcng/${PN}/releases/download/v${PV}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="BSD"
-KEYWORDS="amd64 ~riscv x86 ~amd64-linux ~x86-linux"
-IUSE="examples +network +suid"
-
-# Do not complain about CFLAGS etc. since go projects do not use them.
-QA_FLAGS_IGNORED='.*'
-
-COMMON="sys-libs/libseccomp"
-BDEPEND="virtual/pkgconfig"
-DEPEND="${COMMON}
- >=dev-lang/go-1.13.0
- app-crypt/gpgme
- dev-libs/openssl
- sys-apps/util-linux
- sys-fs/cryptsetup"
-RDEPEND="${COMMON}
- sys-fs/squashfs-tools"
-
-CONFIG_CHECK="~SQUASHFS"
-
-src_configure() {
- local myconfargs=(
- -c "$(tc-getBUILD_CC)" \
- -x "$(tc-getBUILD_CXX)" \
- -C "$(tc-getCC)" \
- -X "$(tc-getCXX)" \
- --prefix=/usr \
- --sysconfdir=/etc \
- --runstatedir=/run \
- --localstatedir=/var \
- $(usex network "" "--without-network") \
- $(usex suid "" "--without-suid")
- )
- ./mconfig -v ${myconfargs[@]} || die "Error invoking mconfig"
-}
-
-src_compile() {
- emake -C builddir
-}
-
-src_install() {
- emake DESTDIR="${ED}" -C builddir install
- keepdir /var/singularity/mnt/session
-
- # As of version 3.5.3 this seems to be very much broken, affecting
- # commands which have got nothing to do with singularity (example:
- # completion on 'udisks mount -b /dev/' rejects all files from that
- # directory other than 'autofs'). Moreover, this should go into
- # $(get_bashcompdir) (from bash-completion-r1.eclass) rather than /etc.
- # Hopefully temporary, which is why we delete this at install time
- # instead of patching build scripts not to generate bash-completion
- # data in the first place.
- rm -rf "${ED}"/etc/bash_completion.d || die
-
- dodoc README.md CONTRIBUTORS.md CONTRIBUTING.md
- if use examples; then
- dodoc -r examples
- fi
-}