summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-09-09 12:17:07 +0100
committerMarek Szuba <marecki@gentoo.org>2021-09-09 12:20:24 +0100
commitcd1c5046d95441e49e002122422adc395f9a16b3 (patch)
tree91e6bd13842dd28f9b05b3579347df22997e1ce5 /sys-cluster/singularity
parentx11-misc/xdotool: add 3.20210903.1 (diff)
downloadgentoo-cd1c5046d95441e49e002122422adc395f9a16b3.tar.gz
gentoo-cd1c5046d95441e49e002122422adc395f9a16b3.tar.bz2
gentoo-cd1c5046d95441e49e002122422adc395f9a16b3.zip
sys-cluster/singularity: add 3.8.3
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'sys-cluster/singularity')
-rw-r--r--sys-cluster/singularity/Manifest1
-rw-r--r--sys-cluster/singularity/singularity-3.8.3.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/sys-cluster/singularity/Manifest b/sys-cluster/singularity/Manifest
index 25b0446840e9..63d1d26fe06f 100644
--- a/sys-cluster/singularity/Manifest
+++ b/sys-cluster/singularity/Manifest
@@ -1,2 +1,3 @@
DIST singularity-3.8.0.tar.gz 7892955 BLAKE2B a75c9a5646cf5bfcc906bdda0e72e062787f6694322ca62ff329c63dfad051edc6c751e4e58cf01476a133947d87ad6230ba60e2d7b7da75ba654486a6c8d48c SHA512 b1e3dc673fbf58d8fa13bea4c67114d1abf0f17e86f1958f585795374107f6b18dd854899b4a574dc3e4d8d4abf4177c26e63c7c3436ae1d35c66331f1630272
DIST singularity-3.8.1.tar.gz 7935330 BLAKE2B 112e04936086b5c068730f8ef52927f4c6c5257b5057828f80946e1a9a5fd83aa657ab55d55c270351835500ca9c0fccc22695cc0c3012d69f411f1b6c5152ab SHA512 7303f82c0ac821f30aab301eb7cb60bc3a56ccef3e21d881f2facc87805ac4b9cf9d776f502766512e91de59863e693189a7509296494fcf028f8453459758a8
+DIST singularity-3.8.3.tar.gz 7948604 BLAKE2B 67c8f4e52faf46a25c1bc16d4f05100f92cfb67b111898bebaeed827bb545f9d44fc3aaae99cbea020ec934c7dd3412b119a3f7f3f003f3e09a5e86dd2816957 SHA512 ede69bfa6602d75f67354afc215a1cf51db769df052662b77a8f1ac88cf580f13683190231452611ba618cda0e63af746dcdf59ab41611a9035bd199f8b50ec5
diff --git a/sys-cluster/singularity/singularity-3.8.3.ebuild b/sys-cluster/singularity/singularity-3.8.3.ebuild
new file mode 100644
index 000000000000..f65b278b7031
--- /dev/null
+++ b/sys-cluster/singularity/singularity-3.8.3.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-info toolchain-funcs
+
+DESCRIPTION="Application containers for Linux"
+HOMEPAGE="https://sylabs.io"
+SRC_URI="https://github.com/hpcng/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples +network +suid"
+
+# Do not complain about CFLAGS etc. since go projects do not use them.
+QA_FLAGS_IGNORED='.*'
+
+COMMON="sys-libs/libseccomp"
+BDEPEND="virtual/pkgconfig"
+DEPEND="${COMMON}
+ >=dev-lang/go-1.13.0
+ app-crypt/gpgme
+ dev-libs/openssl
+ sys-apps/util-linux
+ sys-fs/cryptsetup"
+RDEPEND="${COMMON}
+ sys-fs/squashfs-tools"
+
+CONFIG_CHECK="~SQUASHFS"
+
+src_configure() {
+ local myconfargs=(
+ -c "$(tc-getBUILD_CC)" \
+ -x "$(tc-getBUILD_CXX)" \
+ -C "$(tc-getCC)" \
+ -X "$(tc-getCXX)" \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --runstatedir=/run \
+ --localstatedir=/var \
+ $(usex network "" "--without-network") \
+ $(usex suid "" "--without-suid")
+ )
+ ./mconfig -v ${myconfargs[@]} || die "Error invoking mconfig"
+}
+
+src_compile() {
+ emake -C builddir
+}
+
+src_install() {
+ emake DESTDIR="${ED}" -C builddir install
+ keepdir /var/singularity/mnt/session
+
+ # As of version 3.5.3 this seems to be very much broken, affecting
+ # commands which have got nothing to do with singularity (example:
+ # completion on 'udisks mount -b /dev/' rejects all files from that
+ # directory other than 'autofs'). Moreover, this should go into
+ # $(get_bashcompdir) (from bash-completion-r1.eclass) rather than /etc.
+ # Hopefully temporary, which is why we delete this at install time
+ # instead of patching build scripts not to generate bash-completion
+ # data in the first place.
+ rm -rf "${ED}"/etc/bash_completion.d || die
+
+ dodoc README.md CONTRIBUTORS.md CONTRIBUTING.md
+ if use examples; then
+ dodoc -r examples
+ fi
+}