summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-10-10 18:02:05 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-10-10 18:09:23 -0500
commita7a9ccc4aef5b5e501c004048b1be390f32bd18b (patch)
treec1658edb2d20b67c1647883146b0c09f9c933f3d /sys-cluster/swift/swift-2020.2.9999.ebuild
parentverify-sig.eclass: Fix eclassdoc (diff)
downloadgentoo-a7a9ccc4aef5b5e501c004048b1be390f32bd18b.tar.gz
gentoo-a7a9ccc4aef5b5e501c004048b1be390f32bd18b.tar.bz2
gentoo-a7a9ccc4aef5b5e501c004048b1be390f32bd18b.zip
sys-cluster/swift: add DISTUTILS_USE_SETUPTOOLS=rdepend
Closes: https://bugs.gentoo.org/747721 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'sys-cluster/swift/swift-2020.2.9999.ebuild')
-rw-r--r--sys-cluster/swift/swift-2020.2.9999.ebuild8
1 files changed, 3 insertions, 5 deletions
diff --git a/sys-cluster/swift/swift-2020.2.9999.ebuild b/sys-cluster/swift/swift-2020.2.9999.ebuild
index 68cffb20f363..084afc372ec6 100644
--- a/sys-cluster/swift/swift-2020.2.9999.ebuild
+++ b/sys-cluster/swift/swift-2020.2.9999.ebuild
@@ -2,7 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_6 python3_7 )
+PYTHON_COMPAT=( python3_7 python3_8 )
+DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1 eutils linux-info
@@ -23,10 +24,7 @@ IUSE="account container doc +memcached +object proxy"
REQUIRED_USE="|| ( proxy account container object )"
CDEPEND=">=dev-python/pbr-1.8.0[${PYTHON_USEDEP}]"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- ${CDEPEND}"
-
+DEPEND="${CDEPEND}"
RDEPEND="
${CDEPEND}
>=dev-python/eventlet-0.25.0[${PYTHON_USEDEP}]