summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-02-04 14:12:45 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2020-02-04 14:13:05 -0600
commit726e6054f6eec0592d3fc78b3bf550563fb4ca31 (patch)
tree837f4ae4c6e135f5cb381ae122e1ba035e956d62 /sys-cluster/swift
parentdev-python/debtcollector: Remove py2 (diff)
downloadgentoo-726e6054f6eec0592d3fc78b3bf550563fb4ca31.tar.gz
gentoo-726e6054f6eec0592d3fc78b3bf550563fb4ca31.tar.bz2
gentoo-726e6054f6eec0592d3fc78b3bf550563fb4ca31.zip
sys-cluster/swift: 2.24.0 bump
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'sys-cluster/swift')
-rw-r--r--sys-cluster/swift/Manifest1
-rw-r--r--sys-cluster/swift/swift-2.24.0.ebuild120
-rw-r--r--sys-cluster/swift/swift-2019.2.9999.ebuild18
3 files changed, 128 insertions, 11 deletions
diff --git a/sys-cluster/swift/Manifest b/sys-cluster/swift/Manifest
index 68134a5f9e58..71eb9fd78c41 100644
--- a/sys-cluster/swift/Manifest
+++ b/sys-cluster/swift/Manifest
@@ -1,2 +1,3 @@
DIST swift-2.22.0.tar.gz 3070436 BLAKE2B 53049ba901cf5a46d4567c7fa3620b0ad486d88897beb75887d81c5beb747a08ff52e7eba93eab9e9e087c82447d99f0fd85c97211fb4e930ce5b27a1bba41f1 SHA512 855f9d35399251ac86d687b652a9372da4d2f03dff8dee1743357c14c79f6ea8903b7c67d99fed08b6b4cdfa2cfd6ecb78b010b2ee83195eda30c4a9463a5a0c
DIST swift-2.23.1.tar.gz 3044545 BLAKE2B b3b06aefa7c58b718f7d9c1c1b9bc92f442b83202b8d5c2dbbb777650088f2d939f5e9d0fbe83cea38fd6635d072cd8bb3894d64ed9767dde203064c1b81cfdb SHA512 48aa82b178f5e3901363c2b9eeeedeea12a58b1ba86cc46937dd9ec074ecc005b04a6ce732d4e9fce2497c6c62b659038da40ed43550256584bb371df4e596fb
+DIST swift-2.24.0.tar.gz 3177018 BLAKE2B f465f0e8f58cc097b5b1fdbe5c9736ee3e2247d13d8ae1beeb7e736dd1246e7d8820cb7241afb67e651ad85c269a48d9dbeda3479dadd773bfc1fe3278731afe SHA512 f8e3b0fec06776e095067b2c12f782a9a787c814cea8039ec32930c562be5c74b4b2bf4cb9dad3481953e5163bd051fe32f3074be7776fd1af0be94982d113b6
diff --git a/sys-cluster/swift/swift-2.24.0.ebuild b/sys-cluster/swift/swift-2.24.0.ebuild
new file mode 100644
index 000000000000..f9125af321f6
--- /dev/null
+++ b/sys-cluster/swift/swift-2.24.0.ebuild
@@ -0,0 +1,120 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_6 python3_7 )
+
+inherit distutils-r1 eutils linux-info
+
+DESCRIPTION="A highly available, distributed, and eventually consistent object/blob store"
+HOMEPAGE="https://launchpad.net/swift"
+if [[ ${PV} == *9999 ]];then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/openstack/swift.git"
+ EGIT_BRANCH="stable/train"
+else
+ SRC_URI="https://tarballs.openstack.org/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="account container doc +memcached +object proxy"
+REQUIRED_USE="|| ( proxy account container object )"
+
+CDEPEND=">=dev-python/pbr-1.8.0[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/eventlet-0.25.0[${PYTHON_USEDEP}]
+ >=dev-python/greenlet-0.3.2[${PYTHON_USEDEP}]
+ >=dev-python/netifaces-0.8[${PYTHON_USEDEP}]
+ !~dev-python/netifaces-0.10.0[${PYTHON_USEDEP}]
+ !~dev-python/netifaces-0.10.1[${PYTHON_USEDEP}]
+ >=dev-python/pastedeploy-1.3.3[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ dev-python/pyxattr[${PYTHON_USEDEP}]
+ >=dev-python/PyECLib-1.3.1[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-2.0.2[${PYTHON_USEDEP}]
+ >=dev-python/ipaddress-1.0.16[${PYTHON_USEDEP}]
+ memcached? ( net-misc/memcached )
+ net-misc/rsync[xattr]
+ acct-user/swift
+ acct-group/swift"
+
+pkg_pretend() {
+ linux-info_pkg_setup
+ CONFIG_CHECK="~EXT3_FS_XATTR ~SQUASHFS_XATTR ~CIFS_XATTR ~JFFS2_FS_XATTR
+ ~TMPFS_XATTR ~UBIFS_FS_XATTR ~EXT2_FS_XATTR ~REISERFS_FS_XATTR ~EXT4_FS_XATTR
+ ~ZFS"
+ if linux_config_exists; then
+ for module in ${CONFIG_CHECK}; do
+ linux_chkconfig_present ${module} || ewarn "${module} needs to be enabled"
+ done
+ fi
+}
+
+src_prepare() {
+ sed -i 's/xattr/pyxattr/g' requirements.txt || die
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}
+
+src_test () {
+ # https://bugs.launchpad.net/swift/+bug/1249727
+ find . \( -name test_wsgi.py -o -name test_locale.py -o -name test_utils.py \) -delete || die
+ SKIP_PIP_INSTALL=1 PBR_VERSION=0.6.0 sh .unittests || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ keepdir /etc/swift
+ insinto /etc/swift
+
+ newins "etc/swift.conf-sample" "swift.conf"
+ newins "etc/rsyncd.conf-sample" "rsyncd.conf"
+ newins "etc/mime.types-sample" "mime.types-sample"
+ newins "etc/memcache.conf-sample" "memcache.conf-sample"
+ newins "etc/drive-audit.conf-sample" "drive-audit.conf-sample"
+ newins "etc/dispersion.conf-sample" "dispersion.conf-sample"
+
+ if use proxy; then
+ newinitd "${FILESDIR}/swift-proxy.initd" "swift-proxy"
+ newins "etc/proxy-server.conf-sample" "proxy-server.conf"
+ if use memcached; then
+ sed -i '/depend/a\nneed memcached' "${D}/etc/init.d/swift-proxy"
+ fi
+ fi
+ if use account; then
+ newinitd "${FILESDIR}/swift-account.initd" "swift-account"
+ newins "etc/account-server.conf-sample" "account-server.conf"
+ fi
+ if use container; then
+ newinitd "${FILESDIR}/swift-container.initd" "swift-container"
+ newins "etc/container-server.conf-sample" "container-server.conf"
+ fi
+ if use object; then
+ newinitd "${FILESDIR}/swift-object.initd" "swift-object"
+ newins "etc/object-server.conf-sample" "object-server.conf"
+ newins "etc/object-expirer.conf-sample" "object-expirer.conf"
+ fi
+
+ if use doc; then
+ doman doc/manpages/*
+ dodoc -r doc/{s3api,saio,source}
+ fi
+
+ fowners root:swift "/etc/swift"
+ fperms 0750 /etc/swift
+}
+
+pkg_postinst() {
+ elog "Openstack swift will default to using insecure http unless a"
+ elog "certificate is created in /etc/swift/cert.crt and the associated key"
+ elog "in /etc/swift/cert.key. These can be created with the following:"
+ elog " * cd /etc/swift"
+ elog " * openssl req -new -x509 -nodes -out cert.crt -keyout cert.key"
+}
diff --git a/sys-cluster/swift/swift-2019.2.9999.ebuild b/sys-cluster/swift/swift-2019.2.9999.ebuild
index c9ab6d0b2f70..f9125af321f6 100644
--- a/sys-cluster/swift/swift-2019.2.9999.ebuild
+++ b/sys-cluster/swift/swift-2019.2.9999.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
PYTHON_COMPAT=( python3_6 python3_7 )
-inherit distutils-r1 eutils linux-info user
+inherit distutils-r1 eutils linux-info
DESCRIPTION="A highly available, distributed, and eventually consistent object/blob store"
HOMEPAGE="https://launchpad.net/swift"
@@ -19,7 +19,7 @@ fi
LICENSE="Apache-2.0"
SLOT="0"
-IUSE="account container doc +memcached object proxy"
+IUSE="account container doc +memcached +object proxy"
REQUIRED_USE="|| ( proxy account container object )"
CDEPEND=">=dev-python/pbr-1.8.0[${PYTHON_USEDEP}]"
@@ -41,7 +41,9 @@ RDEPEND="
>=dev-python/cryptography-2.0.2[${PYTHON_USEDEP}]
>=dev-python/ipaddress-1.0.16[${PYTHON_USEDEP}]
memcached? ( net-misc/memcached )
- net-misc/rsync[xattr]"
+ net-misc/rsync[xattr]
+ acct-user/swift
+ acct-group/swift"
pkg_pretend() {
linux-info_pkg_setup
@@ -55,11 +57,6 @@ pkg_pretend() {
fi
}
-pkg_setup() {
- enewuser swift
- enewgroup swift
-}
-
src_prepare() {
sed -i 's/xattr/pyxattr/g' requirements.txt || die
sed -i '/^hacking/d' test-requirements.txt || die
@@ -88,8 +85,7 @@ python_install_all() {
newinitd "${FILESDIR}/swift-proxy.initd" "swift-proxy"
newins "etc/proxy-server.conf-sample" "proxy-server.conf"
if use memcached; then
- sed -i '/depend/a\
- need memcached' "${D}/etc/init.d/swift-proxy"
+ sed -i '/depend/a\nneed memcached' "${D}/etc/init.d/swift-proxy"
fi
fi
if use account; then