summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGraeme Lawes <graemelawes@gmail.com>2019-11-10 16:00:23 -0500
committerJoonas Niilola <juippis@gentoo.org>2019-11-11 17:27:25 +0200
commit40b3c419f4b114aec12df02b124f1df4b4f57c15 (patch)
tree0cbe07c84f9991ae6ce867b8212bdd6915e22a06 /sys-cluster/teleport
parentapp-emulation/xen-pvgrub: remove unused patch (diff)
downloadgentoo-40b3c419f4b114aec12df02b124f1df4b4f57c15.tar.gz
gentoo-40b3c419f4b114aec12df02b124f1df4b4f57c15.tar.bz2
gentoo-40b3c419f4b114aec12df02b124f1df4b4f57c15.zip
sys-cluster/teleport: add v4.1.4
Signed-off-by: Graeme Lawes <graemelawes@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-cluster/teleport')
-rw-r--r--sys-cluster/teleport/Manifest1
-rw-r--r--sys-cluster/teleport/teleport-4.1.4.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/sys-cluster/teleport/Manifest b/sys-cluster/teleport/Manifest
index 0d6abc02555c..b786d5058603 100644
--- a/sys-cluster/teleport/Manifest
+++ b/sys-cluster/teleport/Manifest
@@ -1,2 +1,3 @@
DIST teleport-4.0.9.tar.gz 34927445 BLAKE2B 267ef0ab269efc405f0522a6442d9b626dea62c800717cf01a9f0bdf40a34015b218c58cbd0e5ccbdd17634e91516ece35f6bbfb17864411ef02ae60cf3391eb SHA512 6a9fb59780d4da7f62a2f204f7f2e4321a7b73d9fd60e2de7d7ac1cdcf05e24895115e754aacdbdb75f4c21d40f1e42808e7f4e6bbb54df461167b45ebb7de24
DIST teleport-4.1.1.tar.gz 42243379 BLAKE2B e01a32546bf3ecf52162d004ad24661160193e1586a98d045d83df63f01fc519ae2a6d4ad945da25a6509c153aacc3e23429be343914c35720f1b62da28d3e72 SHA512 7ed950ac7089052ec54872d9cf2ee12351a944268169ff442f0b1c91b3ad58fdf49c3c17839c8f330ae3c6192e9f4244a41cc2ba88f58b8f5435e334007348a5
+DIST teleport-4.1.4.tar.gz 42353194 BLAKE2B 905babaa899b80816b826a920f75dde55619ef7b476da6b3277347128a7301853241abcda852617363bfeb6fa432ef8f49d4b9444cde79e8e38ba9a79e2ec6dc SHA512 5aa8e872802924e03839d4311b346cf1ef00c786e77a62e43a7b182c49f8cee7430e153c5d9ce8400beba332c715d21cdffef7c75be86992e0290d3795b38f12
diff --git a/sys-cluster/teleport/teleport-4.1.4.ebuild b/sys-cluster/teleport/teleport-4.1.4.ebuild
new file mode 100644
index 000000000000..5421480e2d1b
--- /dev/null
+++ b/sys-cluster/teleport/teleport-4.1.4.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit golang-build systemd
+
+DESCRIPTION="Modern SSH server for teams managing distributed infrastructure"
+HOMEPAGE="https://gravitational.com/teleport"
+
+EGO_PN="github.com/gravitational/${PN}/..."
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3 golang-vcs
+ EGIT_REPO_URI="https://github.com/gravitational/${PN}.git"
+else
+ inherit golang-vcs-snapshot
+ SRC_URI="https://github.com/gravitational/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm"
+fi
+
+IUSE="pam"
+LICENSE="Apache-2.0 MIT BSD ISC"
+RESTRICT="test strip"
+SLOT="0"
+
+BDEPEND="app-arch/zip"
+RDEPEND="pam? ( sys-libs/pam )"
+
+src_compile() {
+ BUILDFLAGS="" GOPATH="${S}" emake -j1 -C src/${EGO_PN%/*} full
+}
+
+src_install() {
+ keepdir /var/lib/${PN} /etc/${PN}
+ dobin src/${EGO_PN%/*}/build/{tsh,tctl,teleport}
+
+ insinto /etc/${PN}
+ newins "${FILESDIR}"/${PN}.yaml ${PN}.yaml
+
+ newinitd "${FILESDIR}"/${PN}.init.d ${PN}
+ newconfd "${FILESDIR}"/${PN}.conf.d ${PN}
+
+ systemd_newunit "${FILESDIR}"/${PN}.service ${PN}.service
+ systemd_install_serviced "${FILESDIR}"/${PN}.service.conf ${PN}.service
+}
+
+src_test() {
+ BUILDFLAGS="" GOPATH="${S}" emake -C src/${EGO_PN%/*} test
+}